Defender Failed 0x800106ba-0x80092003

Discussion in 'Windows Vista Security' started by graydog7, Oct 11, 2007.

  1. graydog7

    graydog7 Guest

    I turned on my Vista64 PC today to find that Defender has decided to
    stop working!

    It pops up a message with error number 0x800106ba.

    A search of the knowledgebase advises removing Defender and
    re-installing with Run>appwiz.cpl but when I do this "Defender" isn't in
    the list of installed programs.

    It isn't in the "Turn Windows features on or off" section either.

    Running the WindowsDefender installer package just says it's already
    installed and doesn't offer Repair/Uninstall options.

    Starting the Defender service through "Computer Management" fails and
    produces an 0x80092003 error which is an error relating to reading or
    writing to a file.


    I feel this problem has been introduced by an Automatic Update as
    nothing else has changed since yesterday.

    Anyone else having this problem?

    Thanks GH
     
    graydog7, Oct 11, 2007
    #1
    1. Advertisements

  2. graydog7

    Engel Guest

    You might try this. Go to the main Windows Update window and
    click on "Installed Updates" (on the left-hand side of the window, at the
    bottom), and then remove "Update for Microsoft Windows (KB931099)" (only).
    Reboot. Reboot again. Go back to Windows Update, and re-install the same
    update, by clicking on the Check for Updates button.


    This should essentially re-install Windows Defender on Vista.

    -
     
    Engel, Oct 11, 2007
    #2
    1. Advertisements

  3. graydog7

    graydog7 Guest

    Hi Engel

    I saw your advice here in an earlier Post. Gave it a go, but It hasn't
    fixed the problem.

    Also tried a system restore, but the earliest resotre point now seems
    to be immediately after the offending update!

    GH
     
    graydog7, Oct 11, 2007
    #3
  4. graydog7

    Engel Guest

    Engel, Oct 11, 2007
    #4
  5. graydog7

    graydog7 Guest

    Tried many things. Your link above mainly relates to XP as most of the
    steps don't apply to Vista64 and those that do have no effect.

    I'm getting this error now:

    "application failed to initialize: 0x800106ba. The RPC server is
    unavailable."

    What a Crock! I've wasted the whole day trying to resolve this issue
    that seems to be the result of an Automatic Update!

    All I can do now is disable Defender in MSCONFIG and
    wait.....ZZZZzzzzzzz
     
    graydog7, Oct 11, 2007
    #5
  6. graydog7

    bongodrumm Guest

    try this..

    click start, and in the search box type " services ", and check tha
    windows defender is set to automati
     
    bongodrumm, Feb 5, 2009
    #6
  7. graydog7

    Mvgratz Guest

    I had the same problem after upgradeing from Vista32 bit to Vista64
    bit. Here's what I did to fix mine;
    1. Click start
    2.
     
    Mvgratz, Feb 6, 2009
    #7
  8. graydog7

    Ray Luca Guest

    You're a GENIUS!!!
     
    Ray Luca, Feb 6, 2009
    #8
  9. graydog7

    Ray Barnes Guest

    Use the admin settings to check the manuel or auto run settings and fi
    the error in windows defender by changing the way it runs. Auto o
    manuel and then reset back to run atuomatic at startup of system start
     
    Ray Barnes, Feb 20, 2009
    #9
  10. graydog7

    shirli Guest

    windows defender error 0x800106ba keeps popping up.. i don't know what to do..
    i have no clue how this happend and what to do....help
     
    shirli, Mar 9, 2009
    #10
  11. graydog7

    Frank Holman Guest

    Frank Holman, Mar 9, 2009
    #11
  12. Here's how I fixed it:


    Click Start
    In Search - services
    Click on Services in the list
    You will now have a list of services on the pc
    Scroll to Windows Defender and it will say Manual
    Change it to Automatic and Start it then
    Reboot and the message is gone from both of my computers.....
     
    Christine Williams, Mar 14, 2009
    #12
  13. graydog7

    kapin krunch Guest

    mvgrats.....thank you soooo much!!!:
     
    kapin krunch, Mar 21, 2009
    #13
  14. graydog7

    Ray Barnes Guest

    "Update to another fix

    You may also look at McAfee for the Site Advisor fix if you use McAfe
    Site Advisor
    There is a fix there but you have to save the .ini file to your deskto
    and reboot
    Then copy and past it back in the folder it beongs in to fix th
    problem!!!!
     
    Ray Barnes, Mar 21, 2009
    #14
  15. PA Bear [MS-MVP], Mar 21, 2009
    #15
  16. Glad to help!
    I looked everywhere for a solution to this problem and NON of the articles
    on the Microsoft site helped me.
    Glad to help someone else!!
     
    Christine Williams, Mar 26, 2009
    #16
  17. graydog7

    methanococci Guest

    Mvgratz..
    THANK YOU THANK YOU THANK YO
     
    methanococci, Mar 30, 2009
    #17
  18. graydog7

    Johnny Guest

    Christine,
    You're Awesome! Worked on my computer too! Thank You
    Johnny
     
    Johnny, Apr 2, 2009
    #18
  19. graydog7

    neednonerd Guest

    I tried the regcure, but you have to pay for it and I believe that this
    is a Windows Vista Problem that should be fix by Microsoft. However, try
    the following steps and do it yourself without paying for it.

    1 Go to control Panel and click on Administrative tools.
    2 Click on services and a new windows will appear.
    3 Look up for windows defender and right click on it, click on
    properties and select automatic, it should be on manual, change it to
    automatic and click apply then o.k. and will take you back to the
    services windows.
    4 Windows Defender should be highlighted and on the left hand side of
    the services windows, should be 2 links, click restart.
    5 Close all windows and open Windows Defender, it should work without a
    problem and your popup window at start up will not be display any
    longer.

    Hope this helps you.
     
    neednonerd, May 2, 2009
    #19
  20. graydog7

    neednonerd Guest

    I tried the regcure, but you have to pay for it and I believe that this
    is a Windows Vista Problem that should be fix by Microsoft. However, try
    the following steps and do it yourself without paying for it.

    1 Go to control Panel and click on Administrative tools.
    2 Click on services and a new windows will appear.
    3 Look up for windows defender and right click on it, click on
    properties and select automatic, it should be on manual, change it to
    automatic and click apply then o.k. and will take you back to the
    services windows.
    4 Windows Defender should be highlighted and on the left hand side of
    the services windows, should be 2 links, click restart.
    5 Close all windows and open Windows Defender, it should work without a
    problem and your popup window at start up will not be display any
    longer.
    Hope this helps you.
     
    neednonerd, May 2, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.