Defender - Wont turn on in security centre after updating definiti

Discussion in 'Windows Vista Security' started by nick, Feb 6, 2007.

  1. nick

    nick Guest

    I have a new version of Vista Home Ultimate installed and windows defender v
    1.15.2227.3 created 01/02/2007. The only other software i have on is sophos
    with remote update and a couple of games.

    The issue is that the security centre tells me defender is off. When i enter
    the centre and press "turn on" it says updating definitions - failed to find
    any new definitions and then it returns to the centre with it still logged as
    turned off.

    According to the services panel it is Started - Automatic - Local System.

    Is defender running and just reporting incorrectly to the security centre or
    is it broke.
     
    nick, Feb 6, 2007
    #1
    1. Advertisements

  2. nick

    Andrew H Guest

    Having the same problem here, except with AVG instead of Sophos. Security
    centre reports defender is off, but running defender seems to show
    everythings fine with up-to-date definitions..
     
    Andrew H, Feb 12, 2007
    #2
    1. Advertisements

  3. nick

    pj Guest

    Same problem here. Also using AVG Anti-Virus.

     
    pj, Mar 19, 2007
    #3
  4. nick

    Mohit Kapoor Guest

    Please perform the following to resolve your issues.

    Open elevated command prompt and type cd\windows\system32\wbem press enter

    Then type ren repository repository.old and press enter.

    Restart the computer and check your security center again hopefully
    everything should be working there.

    Thanks and Regards

    Mohit Kapoor
     
    Mohit Kapoor, Apr 26, 2007
    #4
  5. nick

    dkintheuk Guest

    I cannot change the files - they are locked - I am fully logged in as
    Admin. What else can I do?
     
    dkintheuk, Apr 28, 2007
    #5
  6. nick

    Mohit Kapoor Guest

    Simple All you need to do is

    Start->Search type cmd and command prompt will show up->Right click->Run as
    administrator and then type the commands as follows

    Cd c:\windows\system32\wbem
    ren repository repository.old press enter and reboot

    If this doesn't help start the computer in safe mode and rename the folder
    in safe mode.

    If it still doesn't works turn off UAC and then try to rename it with
    elevated command prompt in normal mode.

    If it still doesn't works up then right click on the repository folder under
    c:\windows\system32\wbem and go to properties ->Security Tab->Click
    advanced->Ownership->Check replace owner on the subcontainers and
    objects->Select your user name or administrators and click apply and then
    OK(Twice)
    Then click add (In the security tab) and then on the next window type
    everyone and click OK.Ensure to give all permissions to everyone and click OK.

    Rename the folder now.

    Thanks and Regards ,
    Mohit
     
    Mohit Kapoor, Apr 29, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.