deleted WDDM drivers, can't get them back!

Discussion in 'Windows Vista Hardware' started by Tim_Mac, Sep 24, 2006.

  1. Tim_Mac

    Tim_Mac Guest

    hi,
    yes i feel a bit stupid... i was pleased to see Vista had the option to
    delete the driver software when you uninstall a driver, so i tried it out on
    the Microsoft ATI WDDM driver before changing to the ATI catalyst driver to
    see if i could get glass.
    the catalyst driver didn't work, and now i can't revert to the WDDM driver
    either. what's more, i have extracted the install.wim file from build 5728
    and i can see the WDDM drivers there in the
    \Windows\System32\DriverStore\FileRepository\atiilhag.inf_a561f9b9 folder.
    i can point the update-driver wizard to this folder, and select my matching
    device, X1600 pro, and then click Next, it just says "Windows cannot find
    the file specified".

    i tried copying the files out of the mounted WIM onto the local disk and
    install the drivers from there but got the same result. anyone know how i
    can use the WDDM driver again?
    many thanks in advance
    tim
     
    Tim_Mac, Sep 24, 2006
    #1
    1. Advertisements

  2. Tim_Mac

    John Guest

    Exactly the same thing happened to me. To be honest, I don't see any reason
    to feel stupid :) - ATI recommend that you delete the old drivers before
    installing new ones so we were only following instructions.

    Luckily, trying the ATI drivers was the first thing I did following the 5728
    install so it was quicker to flatten the hard drive and re-install 5728 than
    struggle with the video drivers.

    Whether there's a problem in Vista when you try to delete drivers for an
    "essential service", I'm not sure but I did notice a similar issue with the
    network drivers if I tried to delete the Vista-supplied ones while the
    network was still connected - namely the Vista drivers tried to re-install
    themselves before I had chance to begin installing the new ones.

    John.
     
    John, Sep 25, 2006
    #2
    1. Advertisements

  3. Tim_Mac

    Tim_Mac Guest

    hi John ,
    thanks for the reply. seems like a bug if i can't re-install the drivers,
    even if i have the files.
    does anyone else know if it really is a bug?

    thanks
     
    Tim_Mac, Sep 25, 2006
    #3
  4. i tried copying the files out of the mounted WIM onto the local disk and
    Did you try copying the files into their original location on the hard
    drive? (ie. System32\DriverStore\FileRepository\atiilhag.inf_a561f9b9)

    I had the same problem when I had (manually) deleted the atiihag folder and
    then tried to restore it. Originally I just restored it to my desktop and
    got the 'cannot find the file' error when I pointed windows to the folder.
    Once I put the folder back in it's original location the drivers installed
    fine. Well, when I say fine, I mean they installed as well as they ever had
    (I'm struggling with the 'code 43' error that others seem to have.)
     
    Michael Christie, Sep 25, 2006
    #4
  5. Tim_Mac

    Tim_Mac Guest

    hi Michael,
    i did try that, although the original files were still there. i couldn't
    overwrite them because i wasn't a member of trusted installers. it's
    probably just a group thing i'll add myself to. i'll give it a go and post
    here if it works.

    thanks
    tim
     
    Tim_Mac, Sep 26, 2006
    #5
  6. Tim_Mac

    Kikker46 Guest

    I had the same problem with Vista beta 2, so I never deleted or installed
    any other drivers in the next installations for my ATI Mobile 9000
    videocard.

    Regards,

    Kikker46
     
    Kikker46, Sep 28, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.