Deleting a desktop shortcut

Discussion in 'Windows Vista Performance' started by FireDog, Apr 2, 2008.

  1. FireDog

    FireDog Guest

    How do I delete a desktop icon. Windows says that it can not find the file
    and will not delete it. I removed the program the way I should but it left
    the shortcut on the desktop and will not let me delete or move it. I've tried
    to change the properties , added sharing, and everything I can think of to
    remove the shortcut with no luck.
     
    FireDog, Apr 2, 2008
    #1
    1. Advertisements

  2. FireDog

    Charlie42 Guest

    On the desktop, hit F5, or right-click it and select refresh.

    Charlie42
     
    Charlie42, Apr 2, 2008
    #2
    1. Advertisements

  3. FireDog

    FireDog Guest

    FireDog
     
    FireDog, Apr 2, 2008
    #3
  4. FireDog

    Charlie42 Guest

    You are welcome, FireDog. Thanks for reporting back.

    Charlie42
     
    Charlie42, Apr 2, 2008
    #4
  5. FireDog

    dino Guest

    Hi Charlie, I have had the same problem however F5 does not work and if I
    right click on the icon I only get the option to open or explore which
    neither will open anyway ... any other ideas?
     
    dino, Jun 30, 2008
    #5
  6. FireDog

    Charlie42 Guest

    Did you right-click on the desktop surface? That should pop up the context
    menu with the Update choice.
    Try to reboot if this does not work, I have seen that take care of this
    problem before. Please, report back if neither of these remedies work.

    Charlie42
     
    Charlie42, Jun 30, 2008
    #6
  7. FireDog

    dino Guest

    Yes, I tried the right click in desktop I only get the update or refresh
    choice neither work. I have done numerous restarts since the problem occured
    and also tried reinstalling the program (Belkin Bluetooth which apparently is
    not compatible .. it is an old version). I have seen a few answers saying to
    reboot in safe mode however I am unsure on how to do this.
     
    dino, Jun 30, 2008
    #7
  8. FireDog

    Shane Nokes Guest

    Press F8 during startup after your BIOS screen and before the Vista loading
    screen.

    This will bring up a menu that will allow you to select safe mode.
     
    Shane Nokes, Jun 30, 2008
    #8
  9. FireDog

    Charlie42 Guest

    And check out this icon's properties. If it is read only, you have to make
    it writeable before deletion. This may require administrator privileges.
    Remember, the desktop icons (which are files really) can also be accessed in
    the %UserProfile%\Desktop folder.

    Charlie42
     
    Charlie42, Jun 30, 2008
    #9
  10. FireDog

    dino Guest

    Thanks shane finally managed to start in safe mode however did not fix my
    problem
     
    dino, Jul 1, 2008
    #10
  11. FireDog

    dino Guest

    Thanks Charlie, tried safe mode, all this did was change the type of icon. I
    still only get the 'open, explore and create icon options, if I create an
    icon it lets me delete that one just not the original. How do I get into user
    profile, i tried to do a search for the profile but it stated it could not
    find one.... starting to get really frustrated and all over a little icon I
    should just ignore :)
     
    dino, Jul 1, 2008
    #11
  12. FireDog

    Charlie42 Guest

    Assuming your system drive is C, you should be able to find the icon file
    in:

    C:\Users\<yourusername>\Desktop

    Make sure the file is not write protected before you attempt to delete it.
    Check the file properties.

    Charlie42
     
    Charlie42, Jul 1, 2008
    #12
  13. FireDog

    dino Guest

    :
    I checked out the desktop folder to do as below however the icon/program
    does not show in this folder it only shows the programs that are working
    (such as email, internet shortcuts)
     
    dino, Jul 5, 2008
    #13
  14. FireDog

    Charlie42 Guest

    Let me get this straight: you see an orphaned shortcut icon on your desktop,
    but it is not present in any of these two folders?

    C:\Users\<yourusername>\Desktop
    C:\Users\Public\Desktop

    What is the name and file extension of the icon? (Check its properties.)

    Charlie42
     
    Charlie42, Jul 5, 2008
    #14
  15. FireDog

    dino Guest

    Yes that is correct the users/desktop folder does not show the icon, the user
    public folder doesn't come up with a desktop folder. right clicking on the
    icon doesn't give me the option of properties, only open, explore or Create
    shortcut, when I create another shortcut the new shortcut then lets me acces
    properties, the first time I tried it came up with "Could not find this item
    .... this item no longer located in C:\Users\acer owner\desktop. Verify the
    items location and try again." from then on hitting properties of this
    duplicate shortcut took me to the desktop folder (second icon shows up in
    there just not the original.
     
    dino, Jul 5, 2008
    #15
  16. FireDog

    Charlie42 Guest

    I am beginning to get stymied here. My next suggestion is to use a
    diagnostic/repair tool: System File Checker, check your system drive for
    errors or resort to a repair install. However, I am not entirely sure this
    will help either. Also make sure your system files are set to be hidden.

    Consider top posting your next reply for better exposure.

    Hide system files:
    Open Windows Explorer. In Tools > Folder Options > View tab, make sure the
    "Hide system files" option is ticked.

    Check your hard drive for errors:
    http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx

    Run System File Checker:
    Go to All Programs > Accessories. Right-click the command prompt and select
    "Run as Administrator". At the prompt, type "sfc /scannow" (without the
    quotes). Keep your WinVista installation media close, SFC may need to
    reinstall files from it.

    Startup Repair:
    http://windowshelp.microsoft.com/Windows/en-US/Help/5c59f8c1-b0d1-4f1a-af55-74f3922f3f351033.mspx

    Charlie42
     
    Charlie42, Jul 6, 2008
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.