Denied permission to access folders

Discussion in 'Windows Vista Security' started by Jack K, May 31, 2007.

  1. Jack K

    chrayres Guest

    I'm having similar issues similar to this. I created my own topic sinc
    all scenarios that I've looked up are different and don't seem to work.
    This one might work, but I think I'm doing something wrong. I'm usin
    Windows XP Pro SP2.

    I formatted my C: and 3 of 7 folders on my F: are now giving me issues
    says Access is Denied. I used to fix it in the Security tab but ther
    isn't one showing. I'm the only user and I'm logged in as the admin.
    The folder says that there's 0 files and 0 bytes, I only have 70gb fre
    on a 465gb HDD but the folders only add up to 174gb. So there's
    couple hundred gigs that are on the drive but are not counting.

    I tried the solution given here by going to the cmd prompt, switchin
    to the F: (by typing F: and hitting enter. When I try the command
    listed it says that 'takeown' is not recognized as an internal o
    external command, operable program, or batch file. The folder i
    question is at this path: F:\desktop. I cannot access that folde
    through the command prompt either. I can access other folders on th
    drive, just not the 3 in question.

    There is another thread a
    'http://forums.techarena.in/operating-systems1058851.htm\
    (http://forums.techarena.in/operating-systems/1058851.htm) that
    created originally. Any help is appreciated
     
    chrayres, Oct 22, 2008
    #21
    1. Advertisements

  2. Use a Linux (or other) penetration disk.
     
    FromTheRafters, Oct 22, 2008
    #22
    1. Advertisements

  3. Jack K

    chrayres Guest

    yeah I dont know what that means. maybe like a super easy graphical
    button I can push and check a little radio button or something would be
    more up my alley.
     
    chrayres, Oct 22, 2008
    #23
  4. Jack K

    Guest Guest

    I think that some data maybe damaged or the uninstall of the system causes
    some problems of recognizing you right to read the files , though existing,
    but not being available through the file management of the operating system.
    It is certainly not available through command line.
    If you want to have your data recovered, you may use some professional
    software such as Handy Recovery, or asking professional data rescue team for
    help.
    And, I've no idea about the meaning of 'takeown'.

    Opinion above is only for reference. Make your own decision.
     
    Guest, Oct 22, 2008
    #24
  5. FromTheRafters, Oct 22, 2008
    #25
  6. Jack K

    Jimmy Brush Guest

    FYI the OP has resolved this issue at another forum by disabling simple file
    sharing, which turns on the security tab in XP.

    - JB
     
    Jimmy Brush, Oct 23, 2008
    #26
  7. Jack K

    gjgerber Guest

    I just tried Jimmy Brush's suggestion and it worked fine, except for the
    little error created by the insertion of the sad face in the command
    string.

    I tried every combination of letters and characters I could think of
    until I googled the search string and saw that it should read:

    Type: icacls . /grant USER:(OI)(CI)(F) /L /T /Q

    So, since my user name was owner-pc, the correct string to type in the
    command line would be:

    icacls . /grant owner-pc:(OI)(CI)(F) /L /T /Q

    Once I typed in that string, it immediately granted me access to all
    the files in the folder.

    Another trick is to find your real user name. I always assumed it was
    my screen name, but it wasn't. To find your user name in Vista, click on
    Start, Control Panel, User Accounts and Family Safety. Then click on
    User Accounts again.

    You will see your screen name, user type and picture on the far right.
    On the far left, you'll see a list of options. Click on Configure
    Advanced User Profile Properties and a new window will open showing your
    "official" user name. In my case it was Owner-PC.
     
    gjgerber, Nov 15, 2008
    #27
  8. Jack K

    fogjuice Guest

    - Click *Start*
    - Type: cmd
    - Right-click cmd when it appears and select *Run As
    - Change location to the folder you need access to (e.g. cd
    - Type: takeown /F . /R /A /D Y > NUL
    - Press the Enter key and wait for the command to complete.
    - Type: icacls . /grant Users:(OI)(CI)(F) /L /T /Q
    - Press the Enter key.

    Just wanted to say this worked perfectly for me. I had a bunch of old
    folders on an old hard drive that I needed to regain permissions to. I
    plugged it into my Windows 7 x64 machine, ran this command, and it
    worked! :)

    Now the scary part is, if this can regain permissions to folders that
    users aren't supposed to have perms on, how can one truly prevent users
    from gaining access to a windows folder?
     
    fogjuice, May 27, 2009
    #28
  9. Jack K

    acesilver Guest

    easy fix for when I needed to delete a folder that I could not becaus
    of permission problems.

    This is for people who still need help with this, I'm kinda late o
    helping the original person but here it is...

    Run cmd prompt as administrator, then type in...
    net user administrator /active:ye

    that opens up a new admin account and gives you access to everything.
    was able to delete the folder then =) i hope this helps!:
     
    acesilver, Feb 25, 2010
    #29
  10. Jack K

    MowGreen Guest

    You forgot a *really important* step:

    net user administrator /active:no

    Leaving the Admin account active is an unnecessary security risk after
    the folders have been deleted. It's quicker than changing Perms or
    taking Ownership of the folders but leaving the Admin account active is
    not wise as *anything* that installs when it's active will have the same
    rights as the Admin on the system.


    MowGreen
    ================
    *-343-* FDNY
    Never Forgotten
    ================

    banthecheck.com
    "Security updates should *never* have *non-security content* prechecked
     
    MowGreen, Feb 25, 2010
    #30
  11. Jack K

    Bjorn Jensen Guest

    Hi

    Do your little guide also work 100% in Windows 7 ?
     
    Bjorn Jensen, Feb 27, 2010
    #31
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.