DEP options greyed out in 2008 bcdedit

Discussion in 'Windows Server' started by boe, Apr 26, 2008.

  1. boe

    boe Guest

    Hello,

    I was having issues with a program running in 2008 so I tried a bcdedit
    command that I found on the web but can't seem to find any more. When I go
    to Data Execution Prevention under system properties, advanced perfromance
    options - I can't check either option even though I'm logged in as
    administrator. Anyone know the right command to enable it as it was?

    Thanks
     
    boe, Apr 26, 2008
    #1
    1. Advertisements

  2. Hello boe,

    Check out this command line:
    bcdedit.exe /set {current} nx AlwaysOff turns off DEP

    bcdedit.exe /set {current} nx AlwaysOn turns on DEP

    Best regards

    Meinolf Weber
     
    Meinolf Weber, Apr 27, 2008
    #2
    1. Advertisements

  3. Hello boe,

    If it does not help, and it didn't during my testing with server 2008, use
    this one:

    bcdedit.exe /set nx OptOut

    Sorry for the other posting with the incorrect command, but this one enables
    my DEP and i can choose again the settings.

    Overview from BCEDIT /set
    http://msdn2.microsoft.com/en-us/library/aa906211.aspx

    Best regards

    Meinolf Weber
     
    Meinolf Weber, Apr 27, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.