"Dependency service or group failed to start" and unable to start Diagnostic Policy Service manually

Discussion in 'Windows Vista General Discussion' started by racingracing, Jan 4, 2009.

  1. racingracing

    racingracing Guest

    My access to internet failed since yesterday. I checked and all hardwar
    are working properly. I've done researches and so far, and still n
    luck, here's what I have done so far after the problem exist:

    1) tried to use scannow on cmd, no error found
    2) installed SP1 on my Vista as some people said it may correct th
    problem but it does not, and it also erased all my previous restor
    point that I could use and may have fixed the problem? :(
    3) replaced nlasvc.dll per some suggestion I found online, it's no
    working either
    4) When I opened IE and obviously it'll say connection problem. So
    clicked "Diagnose Connection Problems", it says "Network Diagnostic
    cannot run because Diagnostics Policy Service is not running". So
    opened the Service Manager and tried to start the Diagnostics Polic
    Service manually, it failed with mssg: "Error 5: Access is denied".
    5) Some peopel say it is the corruption in the TCP/IP Stack, so I trie
    command Prompt type : netsh winsock reset and reset, not working.

    Any suggestion is highly appreciated. I really hope to fix this withou
    having reinstall the OS :(

    Thanks!

    P.S. Just remembered something.... the only incident in before an
    after the problem is, the power failure in my house area, while m
    computer was plugged in and running without a battery inserted. I'm no
    sure if that accident shut down is the cause of this problem or not. :
     
    racingracing, Jan 4, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.