Desktop can't see laptop, Laptop can see Desktop (home premium network issues)

Discussion in 'Windows Vista Networking' started by tomjonesrocks, Jul 6, 2009.

  1. Anyone have any suggestions on how to troubleshoot a frustrating network
    issue I'm having?

    I have a setup with a desktop that goes straight into a router (then
    out to a DSL modem) via ethernet cable -- and a laptop that connects to
    the router wirelessly.

    Both computers have working internet. Everything seems to be working
    from the laptop to the desktop--I can browse files on the desktop and
    "see" the desktop's icon/machine name in the network panel from the
    laptop.

    From the desktop all I can see of the laptop is is a instance of a
    media player device--and even that comes and goes. I can't see the
    laptop's hard drives or shared folders nor a printer I want to connect
    to.

    From the desktop, I can ping the laptop and get a response back which
    my router company's (Zyxel) technical support says means the router is
    working fine.

    On both machines, I have network discovery, file sharing, public folder
    sharing, printer sharing, and media sharing "On". Both machines are in
    the same workgroup. What might I be missing?

    Suggestions appreciated, thanks...


    --
    tomjonesrocks

    - antec nine hundred case
    - thermaltake w0106ru 700w power supply
    - western digital caviar se16 wd3200aaks 320gb 7200 rpm sata hd
    - gigabyte ga-ma69gm-s2h am2 amd 690g hdmi micro atx amd motherboard
    - amd athlon 64 x2 4000+ brisbane 2.1ghz socket am2 65w processor
    model ado4000ddbox
    - ocz platinum revision 2 2gb (2 x 1gb) 240-pin ddr2 sdram ddr2 800
    (pc2 6400) dual channel kit desktop memory
    - lite-on sohw-1673s06c dvd-rw
     
    tomjonesrocks, Jul 6, 2009
    #1
    1. Advertisements

  2. tomjonesrocks

    Malke Guest

    Possibly you have a misconfigured firewall on the machine and/or don't have
    matching user accounts/passwords.

    Excellent, thorough, yet easy to understand article about File/Printer
    Sharing in Vista. Includes details about sharing printers as well as files
    and folders:

    http://technet.microsoft.com/en-us/library/bb727037.aspx

    Problems sharing files between computers on a network are generally caused
    by 1) a misconfigured firewall or overlooked firewall (including a stateful
    firewall in a VPN); or 2) inadvertently running two firewalls such as the
    built-in Windows Firewall and a third-party firewall; and/or 3) not having
    identical user accounts and passwords on all Workgroup machines; 4) trying
    to create shares where the operating system does not permit it.

    A. Configure firewalls on all machines to allow the Local Area Network (LAN)
    traffic as trusted. With Windows Firewall, this means allowing File/Printer
    Sharing on the Exceptions tab. If you aren't running a third-party firewall
    or have an antivirus/security program with its own firewall component, then
    you're fine. With third-party firewalls, I usually configure the LAN
    allowance with an IP range. Ex. would be 192.168.1.0-192.168.1.254.
    Obviously you would substitute your correct subnet. Refer to any third
    party security program's Help or user forums for how to properly configure
    its firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS;
    CONFIGURE THEM CORRECTLY.

    B. For ease of organization, put all computers in the same Workgroup. This
    is done from the System applet in Control Panel, Computer Name tab.

    C. Create matching user accounts and passwords on all machines. You do not
    need to be logged into the same account on all machines and the passwords
    assigned to each user account can be different; the accounts/passwords just
    need to exist and match on all machines. DO NOT NEGLECT TO CREATE
    PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
    to the Desktop (into one particular user's account) for convenience, you
    can do this:

    Vista - Start Orb>Search box>type: netplwiz [enter]
    Click on Continue (or supply an administrator's password) when prompted by
    UAC

    Uncheck the option "Users must enter a user name and password to use this
    computer". Select a user account to automatically log on by clicking on the
    desired account to highlight it and then hit OK. Enter the correct password
    for that user account (if there is one) when prompted. Leave it blank if
    there is no password (null).

    Malke
     
    Malke, Jul 6, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.