Device Mgr & Netwk Connections disappeared

Discussion in 'Windows Small Business Server' started by BA, May 19, 2007.

  1. BA

    BA Guest

    Folks:

    I am doing a changeover to a new physical layer at a customer site running 2
    servers (SBS 2003 & W2K Advanced), which requires that I go in to Network
    Connections, right click, properties and change the settings. For some
    strange reason, when I go into Network Connections, there are no interfaces
    defined--i.e., there is only blank space. I tried to access the NICs (there
    are 2) via Device Manager, but same thing--nothing shows up. The server is
    telling me there are no NICs installed, yet I still have network connectivity
    (works just fine), and ipconfig gives the correct info.

    I'm not sure why I can't see or manipulate either the network connections or
    device manager; I'm logging in w/ full admin rights. Nor do I have a clue how
    to restore these. I'm thinking about reapplying SP1 to see if that doea the
    trick.

    Anyone have any ideas on what I can do to resolve this? Or maybe a
    workaround that will allow me to change the network settings?

    TIA

    ba
     
    BA, May 19, 2007
    #1
    1. Advertisements

  2. Just a guess...

    Start | Control Panel | Administration Tools | Services

    Start up the "Plug and Play" service and set it to "Automatic". Then
    reboot.
     
    Merv Porter [SBS-MVP], May 19, 2007
    #2
    1. Advertisements

  3. BA

    BA Guest

    Checked it and P&P is already as you suggest. I checked the box "Allow
    Service to Interact w/ Desktop" but I doubt that had any effect; neither
    network connections nor device mgr as listed as a dependent service.

    Any other ideas?

    TIA...

    ba

     
    BA, May 19, 2007
    #3
  4. How about...

    (Rt. click) My Computer | Properties | Hardware | Device Manager | View |
    SHow Hidden Devices

    Also, check your NIC Bindings....

    Right click My Network Places...Properties. Highlight the Internal NIC. Then
    select Advanced...Advanced Settings from the top menu for that window.
    The Internal NIC should be displayed first followed by the External NIC.
    If not, move the Internal NIC to the top of the list.
    The Internal NIC should have File and Printer Sharing bound (check
    marked) to the TCP/IP Protocol.
    The Internal NIC should have Client for Microsoft Networks bound (check
    marked) to the TCP/IP Protocol.
    The External NIC should be bound to TCP/IP only (no other protocols or
    services).

    --
    Merv Porter [SBS-MVP]
    ============================

     
    Merv Porter [SBS-MVP], May 19, 2007
    #4
  5. all more than a bit odd but what happens if

    (cmd)
    set devmgr_show_nonpresent_devices=1
    start devmgmt.msc

    then in the devmgmt console, view, hidden.

    Such doesn't really explain why your NICs are not showing in the network
    properties but may at least show them in devmgmt, possibly allowing for
    removal and reinstallation. CAREFUL, DC's really don't like not having NICs.

    Or maybe just restart in DSRM first, possibly remove the NICs from here (if
    you can make them visible), restart again to DSRM and see if they reinstall
    normally.

    Another thing possibly worth trying is adding the MSLoopback adapter, maybe
    two instances of it to simulate internal/external networks. See if it shows
    up in your network connections list, again do the show hidden to hopefully
    see any physical devices, remove, DSRM, etc...

    Even if you can just get one MSLoopback visible in network connections and
    successfully run the 'Change Server IP' wiz and CEICW _as if_ this was a
    single NIC system, and assuming show hidden has some effect and the process
    eventually leads to visible physical devices, maybe...

     
    SuperGumby [SBS MVP], May 19, 2007
    #5
  6. BA

    BA Guest

    Therein is the problem--when I access those applets, nothing shows. Neither
    the internal or external NIC is displayed. Show Hidden Devices in dev. mgr.
    gives me nothing either. when I use the New Hardware Wizard to try to readd
    the NICs, it tells me there are no NICs installed--even tho there are 2 and
    both are working correctly. it's a lot like when the admin password is
    unknown, except that rather than giving me "access denied," I simply see
    nothing. blank space.

    do you think reapplying SP1 will restore anything that might be missing? I
    sure don't want to rebuild the server from scratch. are there any reg hacks I
    can check?

    TIA...

    ba

     
    BA, May 19, 2007
    #6
  7. I suspect 'show hidden' may not have much effect without the
    'show_nonpresent' bit.

     
    SuperGumby [SBS MVP], May 19, 2007
    #7
  8. BA

    BA Guest

    I'll agree that it's an odd one--never seen anything like this before. I
    tried everything you suggested, but no go--still can't see any devices
    (hidden or otherwise) and still nothing in network connections. I tried
    running Change Server IP Address yesterday (and again today), but the only
    interface it gives me is the internal, on the 192.16 network, and I don't
    want to change it and knock out everyone's internal access. I know the
    external interface is working fine--I'm remoted into the server as we speak.

    the really bizarre aspect is that everything is working exactly as it
    should; I just can't make any changes. and that's precisely what I want to
    do. arggghhh...

    any other ideas are greatly appreciated...

    ba

     
    BA, May 19, 2007
    #8
  9. half of what I suggested cannot be accomplished remotely, and I would advise
    shutting down all PC's beforehand.

     
    SuperGumby [SBS MVP], May 19, 2007
    #9
  10. BA

    BA Guest

    actually, most of what you suggest can be accomplished remotely, with the
    exception of running in recovery mode and removing the NICs--but the problem
    is that the system insists there are no NICs installed, even tho both of them
    are working as expected. I can't add a second instance of MSLoopbak, since
    there is nothing to bind to. I'm a little hesitant to try anything that will
    kill their access, but in any event, since the system insists there is no
    access (nor any NICs), it's a moot point.

    I did check the registry against a known good server, but this didn't really
    show anything out of the ordinary.

    I'm going to wait until I can go out to the site and reapply the 5 SPs to
    see if that restores any files that are either missing or otherwise
    inaccessible.

    thanks...

    ba

     
    BA, May 20, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.