DFS root could not show in MMC and root target could not be removed

Discussion in 'File Systems' started by Hii Sing Chung, Jan 8, 2006.

  1. I have 2 problems. There are 3 domain DFS roots, namely, dfsris, dfsdpt and
    dfsrpt. The first 2 can be shown in DFS mmc, but when I attempts to show the
    dfsrpt, it gave "the specified domain does not exist or could not be
    contacted".
    The 2nd problem is in the 'dfsdpt' dfs root, there is one root target hosted
    by a DC which was forcefully demoted. When I tried to remove the target, it
    gave "The indicated server share does not support the indicated DFS
    namespace" and then asked "Do you want to forcibly remove the DFS root?". I
    clicked 'Yes', it then gave an error "The system cannot find the file
    specified". The root target remains.

    I have tried the technet itsolutions,
    http://www.microsoft.com/technet/itsolutions/cits/mo/winsrvmg/fspog/fspog5.mspx,
    problem #6 but there isn't any registry key called DfsDnsConfig (as
    indicated in the article) on those servers.
     
    Hii Sing Chung, Jan 8, 2006
    #1
    1. Advertisements

  2. Basically this happens when the root referred is no longer available or
    doesn't know about the root. You should be able to delete the root from DC.
    You have the root in the DC - Delete the root which you want to get rid from
    the DC. If you don't have it in DC, then remove the root from DFS registry
    key.

    After removing from DC and machine, restart the dfs service and root would
    not show up anywhere.
     
    Alok Agarwal [MSFT], Jan 10, 2006
    #2
    1. Advertisements

  3. Jabez Gan [MVP], Jan 10, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.