DHCP Client service does not start because of dependency failure

Discussion in 'Windows Vista Networking' started by Lanny Lin, Nov 2, 2007.

  1. Lanny Lin

    Lanny Lin Guest

    My user's Dell M1330 laptop recently bought is not able to get connected to
    networks both with the NIC and the Wireless card. We know the router is not
    the problem because other Desktop (wired connection) and Laptop (wireless)
    can connect to the router just fine.

    The problem is basically because the laptop NIC is not getting an IP address
    assigned by DHCP server, and further investigating revealed that the DHCP
    Client service is not started (although it was set to automatically start).
    We couldn't manually start the service and got an 1608 error saying
    dependency group failed (without telling us which one failed). Looking in the
    dependency tab of the DHCP Client shows these are components the service
    depends on:

    Ancillary Function Driver for Winsock
    NetIO Legacy TDI Support Driver > TCP/IP Protocal Driver
    Network Store Interface Service> NSI proxy service

    We checked and know the NSI proxy service is running fine. We can ping
    127.0.01 and I think that means the TCP/IP Protocal Driver is working fine.
    So that leaves the AFD driver in question.

    So how can we find out if the AFD driver has been loaded correctly? Thanks
    for any help or pointer!

    Lanny Lin, Nov 2, 2007
    1. Advertisements

  2. Lanny Lin

    Lanny Lin Guest

    I finally figured it out.
    To test is AFD is loaded correctly, first start CMD as an administrator, and
    then type
    net start AFD

    As I suspected, the AFD driver couldn't be loaded. And I had to use
    sfc /scannow
    to repair the corrupted driver file. Once it's repaired, I started DHCP
    Client service just fine and I was able to get DHCP assigned IPs with no

    Hope this will help someone else who experience the same problem.

    Lanny Lin, Nov 3, 2007
    1. Advertisements

  3. Lanny Lin

    dack8472 Guest

    Hi, I'm having this problem- and when I tried what you said - it cam
    back with 'Acess is denied'' How can I have access denied?
    dack8472, Nov 10, 2007
  4. Lanny Lin

    Lanny Lin Guest

    You have to run CMD as an administrator.

    To do that, you type in CMD after you click the START button. Then right
    click on Command Prompt from the list and select Run as Administrator.
    Lanny Lin, Nov 10, 2007
  5. Lanny Lin

    digga19 Guest

    I did the same fix and the sfc scan came back that no errors wer
    Now what can I do???
    digga19, May 12, 2008
  6. Lanny Lin

    leigh.fawkes Guest

    Lanny mate, take a bow!
    Had this issue end of last year, there is NOTHING anywhere else to fix it.
    Since i first fixed it, you have literally saved me rebuilding 4 machines that my colleagues are like 'herp derp' and i just refer them to Mr. Lanny Lin!

    Thank you a million times!
    I work level 1 helpdesk. Your fix is now my favourite knowledge base article!!
    leigh.fawkes, Jun 28, 2012
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.