DHCP client service does not start

Discussion in 'Windows Vista Networking' started by Amit Sharma, Aug 6, 2007.

  1. Amit Sharma

    Amit Sharma Guest

    I have just installed Vista Business on one of my machine. After adding this
    machine to domain (Windows 2003 Server Std. with SP2), my DHCP client service
    stop running. I tried to run it manually but getting an error "Windows could
    not start the DHCP client service on Local Computer. Error 5: Accesss is
    Denied". This service is Log on as Local Service. I tried changing the Log on
    account as well but getting a different error message "Windows could not
    start the DHCP client service on Local Computer. Error 1079: The account
    specified for this service is different from the account specified for other
    services running in the same process." My other Windows XP machines are
    working perfectly fine on domain. Please help me as I almost get stuck with
    this issue.
     
    Amit Sharma, Aug 6, 2007
    #1
    1. Advertisements

  2. Amit Sharma

    lxRavenxl Guest

    I have the exact same problem. The diagnostic report says

    The following problem was reported:
    The DHCP client service is not running on this computer.
    This is required to connect to other computers and devices on the network.

    I tried to restart the service but no avail.

    I get choose another repair options message.
     
    lxRavenxl, Aug 17, 2007
    #2
    1. Advertisements

  3. Amit Sharma

    kasamarama Guest

    Yep, same here,

    Seems this problem is pretty common. The un-common bit is a fix or advice
    from someone who knows the fix.

    I can only offer a work-around for you guys in that setting a static ip
    address will get things working for you..

    I am doing just that but still prefer to use the dhcp if I can and therefore
    will keep looking for the answer.

    So come on Microsoft, sort this out!!
     
    kasamarama, Oct 4, 2007
    #3
  4. Amit Sharma

    shani20 Guest

    have you found the solution? My friend had the same problem and sh
    gave me the laptop to fix it. I looked and looked but couldn't find
    solution and I am about to suggest her to reformat the laptop but
    don't think she is keen to that idea

    Shannon:mad
     
    shani20, Mar 26, 2008
    #4
  5. Robert L. \(MS-MVP\), Mar 26, 2008
    #5
  6. Amit Sharma

    hammerhand Guest

    hey, i found a work around to fix this stupid problem:-
    1- first you have to login using any user with administrativ
    privileges.
    2- start---> Run---> regedit
    3- go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip.
    4- right-click on the Tcpip from the left tap menu and choos
    permission.
    5- Choose (Allow) for all listed groups and users, then press apply an
    ok.
    6- go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp.
    7- do the same as before.
    8- now plug your network cable or connect to the wireless, if u got a
    IP from the DHCP then it's done, if not you have to open the service
    from the administrative tools to run the DHCP clinet or stop and run th
    service again.

    *** YOU HAVE TO DO THIS EVERYTIME U LOG IN OR CONNECT TO THE
    NETWORK.
    *** THIS PROBLEM ASLO EXIST WITH WINDOWS 7 ULTIMATE.

    This problem might be related to the DHCP server, seems like up-gradin
    from windows 2000 advanced server to windows 2003 may cause this probem
    or maybe the group policy in the active directory
     
    hammerhand, Mar 28, 2009
    #6
  7. Amit Sharma

    samcarew Guest

    I tried the *netsh winsock reset catalog *and it seemed to fix my issue!
    Many thanks to delphin....
     
    samcarew, Oct 6, 2009
    #7
  8. Amit Sharma

    CrucialHoax Guest

    Why would you reformat the machine over a service issue? Doesn't see
    like a logical solution at all..

    Plus the solution is posted right above my post ;
     
    CrucialHoax, Oct 6, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.