DHCP gives client address but no gateway address

Discussion in 'Server Networking' started by mheymann, Jun 8, 2006.

  1. mheymann

    mheymann Guest

    Recently I deleted the DHCP scope on my Win 2003 SBS and recreated it
    I intially had some trouble but I got it working
    The problem is that I think there is still a problem with the DNS settings
    Below is a copy of the "ipconfig /all) fro a workstation
    My question is that under the NIC section (Token Ring adapter Local Area
    Connection 2:)
    there is no
    "Connection-specific DNS suffix"
    "Default Gateway" address or
    "DNS Server" address
    Is this a problem or is this ok and if it is a problem how can I fix it


    Windows 2000 IP Configuration
    Host Name . . . . . . . . . . . . : myclienthostname
    Primary DNS Suffix . . . . . . . : mydomain.local
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Token Ring adapter Local Area Connection 2:
    Connection-specific DNS Suffix . :(blank)
    Description . . . . . . . . . . . : IBM PCI Token-Ring Adapter
    Physical Address. . . . . . . . . : 00-06-29-17-D9-21
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.16.10
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :(blank)
    DHCP Server . . . . . . . . . . . : 192.168.16.3
    DNS Servers . . . . . . . . . . . :(blank)
    Lease Obtained. . . . . . . . . . : Wednesday, June 07, 2006 4:47:23 PM
    Lease Expires . . . . . . . . . . : Thursday, June 15, 2006 4:47:23 PM



    I think it is a problem with a configuration setting on the DNS server
    but I confess I really don't know what the problem is
     
    mheymann, Jun 8, 2006
    #1
    1. Advertisements

  2. mheymann

    Mike Lowery Guest

    Yes, this is a problem. At a minimum you need a default gateway specified if
    it's to connect to any other networks. A DNS server should also be specified in
    most cases. Both of these can be set by the DHCP server, you just haven't done
    it.
     
    Mike Lowery, Jun 8, 2006
    #2
    1. Advertisements

  3. mheymann

    mheymann Guest

    Well, Thank you for the conformation of its need the question of how is
    still out there
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.16.10
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :(blank)
    DHCP Server . . . . . . . . . . . : 192.168.16.3

    If you check out these settings you'll notice that the workstation is
    getting an IP address and
    a subnet mask from the DHCP server that is running on the WIN 2003 SBS
    but it is not getting a
    Gateway address. The settings on the network card specifiy that both
    are supposed
    to be suplied to the workstation via DHCP.

    The real question is how do I fix it
     
    mheymann, Jun 8, 2006
    #3
  4. mheymann

    seth Guest

    i'm going to assume you checked the obvious...dns server(s) and router have
    been configured in your scope?
     
    seth, Jun 8, 2006
    #4
  5. mheymann

    mheymann Guest

    Actually I aready got the answer from another source but thank you for
    your response

    ""
    Under the scope, r-click Scope Options -> Configure Options.

    Enable numbers 003 Router, 006 DNS Servers, and 044 Wins Servers, and for
    each of them use your SBS's Internal IP for the value. Enable 015 DNS
    Domain Name with yourdomain.local as the value (your actual DNS domain
    name). Enable 046 WINS/NBT Node Type with the value 0x8.
    ""
    Is the solution I was looking for
     
    mheymann, Jun 9, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.