DHCP server not responding

Discussion in 'DNS Server' started by helpwanted, Jul 30, 2009.

  1. helpwanted

    helpwanted Guest

    We have DHCP running on a Windows 2000 server. Other than servring the local
    office, it also serves several remote offices over the WAN via DHCP relay.
    Everything works fine. Recently, we are required to serve another remote
    office. For some reasons, the DHCP server does not respond to any requests
    from this remote office.
    I have used the Microsoft Network Monitor to capture some network traffic,
    which shows that the DHCP server does receive DHCP requests (Discover and
    Request) from the new office but for some reasons, it does not send an Ack
    back. The new scope is set up exactly the same way as the other offices.
    The routers at both ends are also configured the same way as for the other
    remote offices. There is no error message in the event log.
    The only difference between between this remote office and others is that it
    does not have the whole subnet, i.e., its netmask is 255.255.255.128 while
    all others have 255.255.255.0... I am not sure if this matters.
    Anyway, I am stuck. Any help?
    Thx.
     
    helpwanted, Jul 30, 2009
    #1
    1. Advertisements

  2. Hello helpwanted,

    Any firewall option blocking the traffice on the router between them?

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], Jul 30, 2009
    #2
    1. Advertisements


  3. I agree with Meinolf in his questioning concerning a possible firewall
    blocking traffic. Otherwise you would have seen some sort of traffic coming
    across in your capture.

    I wouldn't think the subnet matters, as long as you've configured the scope
    with that subnet and setup the agent properly to listen to requests, and of
    course the DHCP server is set properly in the agent, and it can communicate
    to the DHCP server with not firewall blocks.

    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Please reply back to the newsgroup or forum to benefit from collaboration
    among responding engineers, and to help others benefit from your resolution.

    Ace Fekay, MCT, MCTS Exchange, MCSE, MCSA 2003 & 2000, MCSA Messaging
    Microsoft Certified Trainer

    For urgent issues, please contact Microsoft PSS directly. Please check
    http://support.microsoft.com for regional support phone numbers.
     
    Ace Fekay [MCT], Jul 31, 2009
    #3
  4. helpwanted

    helpwanted Guest

    No firewall options in between just like the routers for the other remote
    offices.
    When creating the new scope, I simply cloned from the other existing scopes
    which are working very well. Is there any log files I should check...
    basically any other ideas?
    Thx.
     
    helpwanted, Aug 1, 2009
    #4
  5. Cloned? I assume you mean you manually created the scope mimicking the other
    scope settings and didn't use a tool to clone it.

    How many interfaces are on the DHCP server? I assume in your captures that
    if there are more than one interface, you've checked to make sure the ACKs
    weren't being sent over a different interface.

    As for monitoring, read the following. Let us know what you find.

    How to Monitor the DHCP Log FileThis article describes how you can monitor
    only certain events from the Dynamic Host Configuration Protocol (DHCP) log
    file in Microsoft Operations Manager ...
    http://support.microsoft.com/kb/298367

    Changes in Windows Server 2003 DHCP LoggingApr 7, 2003 ... This article
    describes the changes in Dynamic Host Configuration Protocol (DHCP) server
    logging in Windows Server 2003.
    http://support.microsoft.com/kb/328891

    Ace
     
    Ace Fekay [MCT], Aug 1, 2009
    #5
  6. helpwanted

    helpwanted Guest

    There is only one network interface in our server.

    We don't run MOM in our office.

    I looked more closely at the network traffic captured by Network Monitor. I
    noticed that when the server receives the Discover packet from the new
    office, it doesn't respond at all. But for all other offices, it responds
    with an Offer packet as expected (and then a Request packet and then an Ack).

    I am assuming even if the routers/switches discards the Offer packets, it
    should still show up in Network Monitor.

    When I check the DHCP log file, it doesn't even have anything reported about
    the Discover packet from the new office.

    Any help is very much appreciated?
     
    helpwanted, Aug 6, 2009
    #6
  7. Interesting. You're saying the captures indicate the Discover packet is
    reaching the server, so that verifies it's getting to the server, yet the
    DHCP logs don't even show it showing up? I believe I remember you saying
    there is no subnet mask or subnet ID mismatch for the scope and the subnet
    (the /25)?

    Try creating the scope as a /24, but exclude the range that;s not included
    wtih the /25 at the office, just for a test to see if it works. What the
    difference changing it at this point, since it's not working anyway?

    Ace
     
    Ace Fekay [MCT], Aug 7, 2009
    #7
  8. helpwanted

    helpwanted Guest

    IT WORKS! looks like dhcp doesn't know how to handle subnet mask. What is
    the point of entering the subnet mask when creating the scope!

    THANK YOU VERY MUCH FOR YOUR HELP...
     
    helpwanted, Aug 7, 2009
    #8
  9. No kidding... Wow. I can't explain it. I haven't had problems with subnet
    masks in a non-agent scenario, such as a small or medium office using a /27,
    etc, but for an agent... hmm.

    Oh well, glad it's working! And you're welcome!

    Just make sure you use exclusions for the IPs that are not on that net.

    Cheers!

    Ace
     
    Ace Fekay [MCT], Aug 8, 2009
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.