Different Warcraft 3 Frozen Throne Problem in Windows 7

Discussion in 'Windows Vista Games' started by jalf, Feb 14, 2009.

  1. jalf

    jalf Guest

    Okay, the problem is, after installing my Warcraft 3 Frozen Throne on m
    Windows 7 beta, 7000build. I can run War3.exe after the installation
    When I restarted my computer, the problem starts here

    Every time I open my War3, It minimizes on my task bar. When I click i
    again, it maximizes for around 1 second then minimizes again. I know it
    running fine because I can hear the sounds of the program and I can se
    the menu for 1 second.

    I'm wondering if this is fixable. I search the internet for simila
    problem but it looks like I'm the only one having this kind of problem.

    I tried Updating my Video Card driver, I think I have the latest.

    Thanks in advance whoever can fix this problem

    Tried system restore, no result.

    Reinstalling my War3, it works. But, whenever I restart my computer
    the problem appear again. I need to shutdown my computer

    Here is my Computer specification

    System Informatio
    Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7000
    (7000.winmain_win7beta.081212-1400
    Processor: Intel(R) Core(TM)2 Quad CPU Q9300 @ 2.50GHz (
    CPUs), ~2.3GH
    DirectX Version: DirectX 1
    Physical RAM: 3581M
    Virtual Memory: 2047M

    Video Informatio
    Video Card: NVIDIA NVIDIA GeForce 9600 GT (Prerelease - WDDM 1.1
    Video Memory: 2035 M
    Chip Type: GeForce 9600 G
    Driver Filename: nvd3dum.dll,nvwgf2um.dl
    Driver Version: 7.15.0011.7923 | 11/20/2008 21:25:0
    Disp Settings: Generic PnP Monitor | 1024 x 768 (32 bit) (75Hz

    Audio Informatio
    Audio Device: Speakers (High Definition Audio Device
    Driver Name: HdAudio.sy
    Driver Version: 6.01.7000.0000 | 12/13/2008 10:47:5
    Default Sound Playback: tru
    Default Voice Playback: tru
     
    jalf, Feb 14, 2009
    #1
    1. Advertisements

  2. jalf

    jalf Guest

    Done. I fixed it.

    The problem is, with the windows 7 desktop Composition

    Here's the solution.

    Go to the warcraft installation folder
    Select War3.exe then, right click it, properties

    Compatibility -> check -disable desktop composition.

    And no more, minimizing problem
     
    jalf, Feb 14, 2009
    #2
    1. Advertisements

  3. jalf

    Joe Guest

    Good find, did you send feedback to Microsoft?
     
    Joe, Feb 23, 2009
    #3
  4. jalf

    jalf Guest

    No. And I think, Microsoft intentionally added that option because, i
    can't be fixed on their side. So, I think, it's up to the game produce
    to add some compatibility in their program

    It's just a thought anyway
     
    jalf, Feb 23, 2009
    #4
  5. jalf

    Joe Guest

    Vista has the same "feature", Desktop Composition, but WC3:FT works just
    fine on Vista, so this is probably a bug introduced in Windows 7, could be
    based on your hardware or something else, but either way when you observe
    something click the send feedback link.

    Just my thought anyway.
     
    Joe, Feb 24, 2009
    #5
  6. jalf

    AOD Guest

    not necessarily. I run TFT in Vista and i have the same problem. The
    solutuion is the same turn off desktop composition.
     
    AOD, Mar 9, 2009
    #6
  7. jalf

    vntan Guest

    *bump
    guys please help me i got the same problem..
    it doesnt work with -"disable desktop composition

    -Is there anyone who solute the prob in another way
     
    vntan, Dec 26, 2009
    #7
  8. jalf

    karam Guest

    i need some help plz i have everything exactly like u all the compute
    information and stuff like windows ultimate and 32 bit and everythin
    but when i click on frozen throne it stops responding and it freezes
    ive tried running as adminstator and compatibilty windows xp(2) an
    windows xp(3) but no use it just stops responding when i try to open it
    plz help m
     
    karam, Feb 9, 2010
    #8
  9. Hi,
    I have a different problem with this game..I have installed succesfully Warcraft III Reign of Chaos and then i insert the Frozen Throne cd..After running the cd,it appears a menu,which says me Warcraft III Reign of Chaos required..!I dont understand the problem,because i have already installed succesfully the warcraftIII reign of chaos..
    I have Windows 7 32bit,please help me.
     
    Dimitris Dimitris, Apr 22, 2011
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.