Disconnections to shared folder on Vista Enterprise x86 SP1 server from XP SP2 Pro client

Discussion in 'Windows Vista General Discussion' started by Guest, Feb 4, 2009.

  1. Guest

    Guest Guest

    A drive mapping gets disconnected when a user logs onto their computer
    acting as the server and I cannot figure out why. Here are the facts:

    Client Windows XP Pro SP2, workgroup member, same subnet
    mapping drive T: using credentials VistaSvr\Administrator using explorer
    sharename connecting to \\VistaSvr\sharename$
    able to connect T: when Vista computer VistaSvr\Administrator is logged
    on, or if no one is logged on
    unable to connect when primary user of Vista computer is logged on using
    their domain account: domain\username
    domain\username is not an administrator
    existing working T: becomes unavailable when domain user logs onto Vista
    computer
    able to ping VistaSrv by name and IP from XP box
    XP explorer error message: "The mapped network drive could not be
    created because the following error has occurred: The specified server
    cannot perform the requested operation."
    XP cmd line error 58 when using this cmd: "net use T:
    \\VistaSvr\sharename$ /user:VistaSvr\Administrator *" and entering password
    when prompted
    Same error messages occur with alternate credentials such as
    domain\administrator

    Server Vista Enterprise SP1, joined to domain, same subnet
    no Vista group policies setup on WS2003 domain
    simple file sharing disabled
    VistaSvr\Administrator account is enabled, member of
    VistaSvr\Administrators
    firewall configured locally to allow file and print, IMCP v4
    network discovery on
    file sharing on
    share name is hidden ie \\VistaSvr\sharename$
    share permissions include full rights to groups VistaSvr\Authenticated
    Users, VistaSvr\Administrators, domain\Administrators
    default NTFS permissions for folder that is being shared,
    D:\Storage\Sharename gives all users access


    Note Google found this similar article:
    http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23755946.html
    but upgrading the client to XP SP3 is not an option in my case. I do not
    believe McAfee Virusscan Enterprise is causing the issue, but is installed
    on both systems (8.0 client, 8.7i server).
     
    Guest, Feb 4, 2009
    #1
    1. Advertisements

  2. Hi,

    Thank you for the post.

    Can you access the resource on Windows Vista directly when a domain user is
    logged on (not using the mapped drive or net use command)? For example, can
    you use the computer name or IP address to access the drive on Windows
    Vista?

    If it is convenient for you, please use another client to test the result.

    This issue can be related to firewalls or anti-virus programs. I suggest
    temporarily disable them on both computers.

    I look forward to hearing from you.

    Sincerely,
    Tim Quan
    Microsoft Online Community Support

    ==================================================
    Get notification to my posts through email? Please refer to
    http://msdn.microsoft.com/subscriptions/managednewsgroups/default.aspx#notif
    ications.

    With newsgroups, MSDN subscribers enjoy unlimited, free support as opposed
    to the limited number of phone-based technical support incidents. Complex
    issues or server-down situations are not recommended for the newsgroups.
    Issues of this nature are best handled working with a Microsoft Support
    Engineer using one of your phone-based incidents.
    ==================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Tim Quan [MSFT], Feb 6, 2009
    #2
    1. Advertisements

  3. Hi,

    How are things going? I have not heard back from you in a few days and
    wanted to check on the status of the issue. Please let me know how things
    turned out.

    It's my pleasure to be of assistance.

    Tim Quan - MSFT
     
    Tim Quan [MSFT], Feb 9, 2009
    #3
  4. Guest

    Guest Guest

    Tim, if I understand your test correctly you want me to open the share
    \\VistaSvr\sharename$
    on the computer \\VistaSvr with the user domain\username? I have the share
    permissions configured to only allow \\VistaSvr\Administrators access, so
    this initial test failed. I reconfigured the share to \\VistaSvr\sharename
    (dropping the $ to hide it), and added share permissions to allow the users
    domain\username and VistaSvr\Administrator access. The test to access the
    sharename locally now works.
    I now attempted to access the share from the XP SP2 client by issuing
    the command

    net use \\VistaSvr\sharename /user:VistaSvr\administrator *

    and this command now works!
    Next, I removed the access to the share for the user domain\username and
    rebooted both XP and Vista computers. I was still able to connect to the
    share using the above command.
    Final test, I removed the user VistaSvr\Administrator from the share
    permissions, leaving only permissions for the group VistaSvr\Administrators
    .. Since VistaSvr\Administrator is a member of the group
    VistaSvr\Administrators, I should still have access, and this test worked as
    well.

    At this time I am wondering if the XP computer has a bad key on the keyboard
    which caused incorrect password to be sent to the Vista computer. I will
    continue testing tomorrow to see if I can reproduce the access denied error
    message, and test the scenario by having the user log on and off with the
    drive mapped to see if it is disconnected or not.



     
    Guest, Feb 9, 2009
    #4
  5. Hi,

    Thank you for the reply.

    How are things going these days?

    If you need my further help, please let me know. It's my pleasure to be of
    assistance.

    Tim Quan - MSFT
     
    Tim Quan [MSFT], Feb 12, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.