Documents folder hidden in public folders, but cannot unhide

Discussion in 'Windows Vista File Management' started by colin.robbins, May 17, 2008.

  1. Hello, I have what appears to be an odd issue, and I can't fin
    reference to it on the web anywhere

    Under the Public folder on my Vista machine, I can see the folder
    Public Downloads, Public Music etc. BUT Public Documents is missing

    If I use the cmd shell, I get the same effect
    Directory of C:\Users\Publi
    11/05/2008 16:54 <DIR>
    11/05/2008 16:54 <DIR> .
    13/04/2008 08:37 <DIR> Download
    11/05/2008 16:54 3,403,458 Library.xm
    11/05/2008 17:13 <DIR> Musi
    15/02/2008 18:16 <DIR> Per
    12/02/2008 19:15 <DIR> Picture
    26/04/2008 08:25 <DIR> Recorded T
    05/04/2008 11:11 <DIR> Video

    HOWEVER the documents folder does exist. I can CD into it and see m
    files

    From within explorer, I can enter C:\Users\Public\Documents explicitl
    and get to the folder, but is does not show up unde
    C:\users\Public.

    Looking at the folder permissions, documents is marked as "hidden"
    If I use explorer to show hidden folders, it shows up just fine

    Why is is hidden
    How can I unhide it
    Unchecking "hide" in the folder propertied of the documents folder doe
    not work - it is greyed out

    This used to all work just fine, but then the folder suddenly took o
    this hidden nature

    This is a clean vista install, not an upgrade
    Any help most appreciated
     
    colin.robbins, May 17, 2008
    #1
    1. Advertisements

  2. In a Command Prompt window, in the 'C:\Users\Public' directory, type:

    attrib -h documents
     
    Keith Miller \(MVP\), May 17, 2008
    #2
    1. Advertisements

  3. Regrettable that does not work...

    C:\Users\Colin>cd c:\users\public
    c:\Users\Public>attrib -h documents
    *Not resetting system file - C:\Users\Public\Documents*
    c:\Users\Public>
     
    colin.robbins, May 18, 2008
    #3
  4. colin.robbins

    Malke Guest

    Did you do it at an elevated command prompt? If not, then I think you need
    to do so.

    Start Orb>Search box>type: cmd
    When cmd appears in the Results box above, right-click and Run As
    Administrator. Then try your attrib -h.

    Malke
     
    Malke, May 18, 2008
    #4
  5. Hmmm... Mine don't have the system attribute set, but try:

    attrib -h -s documents
     
    Keith Miller \(MVP\), May 19, 2008
    #5
  6. Thanks guys - the combination of "run as administrator" and the "-s
    flag solved the issue

    The folder is now shown as "documents" rather than "public documents
    is was before, but I can live with that

    Cheer

    Coli
     
    colin.robbins, May 20, 2008
    #6
  7. Glad that's solved.

    The name 'Public Documents' comes from the desktop.ini file (which is
    normally flagged as hidden and system). For Explorer to process the
    desktop.ini file, the folder must have its read-only or system attribute
    set. So use:

    attrib +r documents

    and if the desktop.ini file is still there, you will get the proper display
    name. If it was deleted, here are the contents:


    [.ShellClassInfo]
    [email protected]%SystemRoot%\system32\shell32.dll,-21801
    IconResource=%SystemRoot%\system32\shell32.dll,-235
     
    Keith Miller \(MVP\), May 22, 2008
    #7
  8. Eureka - the attrib +r documents has solved the problem fully

    Many thanks for your help
     
    colin.robbins, May 23, 2008
    #8
  9. You're welcome.
     
    Keith Miller \(MVP\), May 23, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.