Don't want to reuse tab

Discussion in 'Internet Explorer' started by Henry, Apr 13, 2007.

  1. Henry

    Henry Guest

    I'm looking for an IE7 shortcut. With previous IE versions (and this one)
    when I get an email with mltiple links, clicking on consecutive links will
    overwrite the current IE page with the contents from the new link. I used to
    hit [CTRL]N to open a new window, minimize that window, click the new link
    (allowing the first window's page to be overwritten) and continue this for as
    many links as I needed. I would like to take advantage of the tabs without
    using new windows ([CTRL]N). With IE7, to get the desired results, I need
    to...

    1. Click the first link

    2. ALT-D (select tab's url)

    3. CTRL-C (copy tab's url)

    4. CTRL-T (open new tab)

    5. CTRL-V, ENTER (paste url in new tab and load)

    6. CTRL-1 (return to tab 1)

    Now the next link click will open up a new link in a tab that's already been
    duplicated. That's too much work, and my programmable keyboard won't handle
    this task. Any MENSA candidates have any ideas? Does anyone know if this
    shortcut already exists? Does Microsoft have a "suggestion box"? Thanks,
    Henry
     
    Henry, Apr 13, 2007
    #1
    1. Advertisements

  2. Hello Henry,

    Sounds like a tedious workaround for a simple setting ;-)

    Deactivate
    Tools > Internet Options > Advanced > Reuse window for launching shortcuts

    Best regards,

    Viktor Krammer
     
    Viktor Krammer, Apr 13, 2007
    #2
    1. Advertisements

  3. Henry

    PA Bear Guest

    PA Bear, Apr 13, 2007
    #3
  4. Henry

    Mary Guest

    How about using right click on the link, open in new tab?
     
    Mary, Apr 13, 2007
    #4
  5. Henry

    Henry Guest

    Good shortcuts, thanks, but doesn't solve my problem.

     
    Henry, Apr 13, 2007
    #5
  6. Henry

    Henry Guest

    I was aware of this option, and yes, it would have been to easy. The setting
    you refer to says "Reuse window for launching shortcuts (when tabbed browsing
    is off)". But hey, I'll try almost anything. I unchecked, applied,
    rebooted, and still opened in same tab, same windows. Thanks for trying.
     
    Henry, Apr 13, 2007
    #6
  7. Henry

    Henry Guest

    Good thought, thanks Mary. The links are in OE emails. I don't get those
    options when right clicking on email links. I even tried CTRL-click and
    SHIFT-click. I'm starting to think this is going to be "feature" I used to
    appreciate, like XCOPY and file manager (ha ha).

     
    Henry, Apr 13, 2007
    #7
  8. Henry

    Don Varnau Guest

    Hi,
    Try these settings...
    * From IE> Tools> Internet Options> Advanced> Browsing> uncheck "Reuse
    windows for launching shortcuts."
    * Internet Options> General> Tabs> Settings...
    Always open pop-ups in a new tab
    Open links from other programs in a new tab

    Let me know if f those settings don't work. I have a more involved procedure
    that worked for me.

    Don
    [MS MVP- IE]
     
    Don Varnau, Apr 14, 2007
    #8

  9. That still requires him to put two and two together:

    Alt-d,Alt-Enter


    BTW there are many omissions on that page... <eg>


    ---

     
    Robert Aldwinckle, Apr 14, 2007
    #9
  10. Henry

    PA Bear Guest

    PA Bear, Apr 14, 2007
    #10
  11. Henry

    Henry Guest

    A lot better. That's half as many steps. Still need CTRL-1 to get back to
    first tab. Thanks

     
    Henry, Apr 14, 2007
    #11
  12. Henry

    Henry Guest

    I was holding my breath on that one. Changed settings, rebooted, and still
    opened up in same tab. Thanks for trying. Henry

     
    Henry, Apr 14, 2007
    #12

  13. No you don't. You could launch the new tab in the background.
    That should be the default unless you have changed the tab setting

    Always switch to new tabs when they are created

    In that case you need to press Alt-d,Alt-Shift-Enter


    HTH

    Robert
    ---

     
    Robert Aldwinckle, Apr 14, 2007
    #13
  14. Henry

    KCB Guest

    I just sent myself an email with 4 different web sites listed. IE
    opened each in a different tab. (IE was not open beforehand). I'll
    list my settings to compare to your own.

    Tabbed Browsing Settings:
    [x]Enabled Tabbed Browsing (requires restarting Internet Explorer)
    [ ]Warn me...
    [x]Always switch to new...
    [x]Enable Quick Tabs...
    [ ]Open only the first...
    [x]Open new tabs next...
    [x]Open home page...

    When a pop-up is encountered:
    ( )Let Internet Explorer...
    ( )Always open pop-ups...
    (o)Always open pop-ups in a new tab

    Open links from other programs in:
    ( )A new window
    (o)A new tab in the current window
    ( )The current tab or window

    I think that last one is the key to your misery. If some other settings
    are relevant, let me know.
     
    KCB, Apr 14, 2007
    #14
  15. Henry

    Don Varnau Guest

    Hi,
    This worked for me several months ago.

    1. Make IE the default browser (Add or remove programs> Set program access
    and defaults.)
    2. Uninstall IE7. Restart.
    3. Turn off automatic updates from Control Panel> Automatic updates.
    4. Find the file IE7-WindowsXP-x86-enu.exe or download and save that
    installer file from
    http://www.microsoft.com/windows/downloads/ie/getitnow.mspx
    5. Startup in Safe Mode with Networking. Install IE7 by running
    IE7-WindowsXP-x86-enu.exe
    315222 - A description of the Safe Mode Boot options in Windows XP:
    http://support.microsoft.com/default.aspx?scid=315222
    6. Probably irrelevant- I did not run the Malicious Software Removal when
    prompted.
    7. Tab settings:
    * Always open pop-ups in a new tab
    * Open links from other programs in a new tab
    8. If this gets Outlook Express to open tabs instead of windows, here's
    something I've observed... If you modify, in any way, the URL:HyperText
    Transfer Protocol file type, including checking/unchecking UseDDE, you will
    lose this behavior. It may be that experimenting with default browser
    settings will also mess things up.
    9. Re-enable Automatic Updates.

    Don
    [MS MVP- IE]

    Thanks,
     
    Don Varnau, Apr 14, 2007
    #15
  16. Henry

    Henry Guest

    New tabs do launch in the background, but Alt-d,Alt-Enter changes focus to
    new tab. Alt-d,Alt-Shift-Enter does duplicate tab in new tab in background.
    Less elegant than I had hoped for, but at least it works. Thanks. (sure do
    miss IE6)

     
    Henry, Apr 14, 2007
    #16
  17. Henry

    Henry Guest

    Wow! If this were a test box, I'd be happy to but this is my home "personal"
    computer and it's a tad flaky as it is (I already make ghost images as a
    precaution and pray I never have to use it, already had 2 disk crashes - box
    must be jinxed. This box already has 1 foot out door.). IE is default
    browser, never added anything, not even AOL. ALL IE sttings are probably
    99.8% default, haven't had a need to change - ditto for http file type
    settings. My XP box at work behaves EXACTLY like my home machine, BUT a test
    box with clean Vista install opens new tabs for each new link click...and I
    can't find any difference in settings. My transition to Vista may happen
    sooner than expected. Now if only I could get one of the keys from my
    Gateway Anykey programmable keyboard to emulate the Windows Flag key.....
    Thanks again Don

     
    Henry, Apr 14, 2007
    #17
  18. Henry

    Henry Guest

    These settings were so similar to mine, but ... duplicated. rebooted, no
    difference. The ironic thing is 2 of my XP boxes behave identical ("wrong"),
    yet box w/Vista acts correctly, and all 3 boxes' IE have same settings.

    Tabbed Browsing Settings:
    [x]Enabled Tabbed Browsing (requires restarting Internet Explorer)
    [x]Warn me...
    [ ]Always switch to new...
    [x]Enable Quick Tabs...
    [ ]Open only the first...
    [x]Open new tabs next...
    [ ]Open home page...

    When a pop-up is encountered:
    ( )Let Internet Explorer...
    (o)Always open pop-ups...
    ( )Always open pop-ups in a new tab

    Open links from other programs in:
    ( )A new window
    (o)A new tab in the current window
    ( )The current tab or window



     
    Henry, Apr 14, 2007
    #18
  19. Henry

    Henry Guest

    It definitely puzzles me too. I did follow your test though, I
    1 checked dword=1
    2 made 2 changes (open only the first page homepage when IE starts, and
    reuse tab (under advanced)) reopened regedit, dword still =1
    3 closed IE - reopened regedit, dword still =1
    4 checked IE behaviour - only first homepage did open (I have 2 pages (tabs)
    that normally open) reopened regedit, dword still =1
    5 rebooted - reopened regedit, dword still =1

    Am I still puzzled - yeah, but starting to give up hope. Home PC is XP SP2
    P3 w/.75GB memory, ATI Radeon All-in-Wonder card (great card) and HP director
    software that complains a little, but stable for most part. Work PC is XP
    SP2, 2.8 GHz P4, 1 GB mem. Extremely stable but also has this IE behaviour.
    Test box is Vista business, 2.8 GHz P4, 1 GB mem, tab behaviour works as we
    would expect it to work (correctly). NEW TWIST - Test box 2 is Vista
    Ultimate upgrade from XP SP2, 2.8 GHz P4, 1 GB mem, tab behaviour works
    correctly now, but pretty certain it worked wrong when it was XP. I'm really
    starting to wonder if it's all worthwhile.
    I do however really appreciate that you have taken your time to try to help
    .... If only there was an easy answer...
     
    Henry, Apr 15, 2007
    #19

  20. It really sounds like a security program blocking the Registry change it
    needs to make. A few, but not all, of the programs now doing this are:
    Ad-aware's Ad-Watch
    IBM Access Connections
    McAfee VirusScan and/or Antispyware
    Norton AV
    Spyware Blaster
    Spybot> Tools> IE Tweaks
    Spybot- Teatimer
    Spysweeper
    Spyware Doctor
    Windows Defender
    Zone Alarm (free) 6.5 Reported to be fixed in later versions.

    In the case of Zone Alarm 6.5 or Norton 2007 it actually has to be
    uninstalled. Make sure the Windows Firewall is turned on until you
    reinstall Zone Alarm.

    Boot into Safe Mode with Networking and try the change.
     
    Frank Saunders, MS-MVP OE/WM, Apr 15, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.