Drive mapping question

Discussion in 'Server Networking' started by Joe, May 30, 2008.

  1. Joe

    Joe Guest

    I have a CIFS volume that I am mapping to, but would like the drive to be
    available at boot time so that a service can use it. I know that drive
    mappings
    are user specific, but is there a way to mount the drive through a service
    and make it available to any or all users?

    So if a service ran as a specific user could I start the service as that
    user and
    the service would then be able to write to the disk without an logged in
    session?

    Any advice would be appreciated.
     
    Joe, May 30, 2008
    #1
    1. Advertisements

  2. In
    Have you tried a machine startup script placed in either the local Group
    Policy (accessible by start/Run, gpedit.msc) or in a GPO in an OU the
    machine is under? Remember, with GPOs there are four events that you can
    place a script, bat file, etc, to run. They are machine start, user logon,
    user logoff, and shutdown. Of course user logon and logoff is user based and
    only affects users. The startup and shutdown are machine only based and will
    affect the machine only.

    --
    Regards,
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Ace Fekay, MCSE 2003 & 2000, MCSA 2003 & 2000, MCSE+I, MCT,
    MVP Microsoft MVP - Directory Services
    Microsoft Certified Trainer

    For urgent issues, you may want to contact Microsoft PSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Infinite Diversities in Infinite Combinations
     
    Ace Fekay [MVP], May 31, 2008
    #2
    1. Advertisements

  3. Joe

    Joe Guest

    Ace,

    I haven't tried that, but I will. I have used AutoExNt and the drive maps
    but isn't
    accessible. I tried srvany with the same result. The drive was mapped but
    required a password after login. I know it's easily fixed with a login
    script, but
    I need it to be accessible outside of a login first and foremost.

    Thanks for the hint. I'll give it a try.
     
    Joe, May 31, 2008
    #3
  4. Joe

    Joe Guest

    Ace,

    Well, I tried that. The drive isn't available once it is mapped via the
    script.
    The drive seems to map without a problem, but no process can write
    data to the drive. It seems to be a username/password issue.

    I'm going to try to setup the storage so it doesn't require a
    username/password.

    Thanks.
     
    Joe, May 31, 2008
    #4
  5. In
    Thinking about it, when it runs the machine script, it uses the local
    account so when the user process runs, the mapped drive still has the local
    account credentials. Try it in both startup AND logon.

    Ace
     
    Ace Fekay [MVP], Jun 1, 2008
    #5
  6. Joe

    ThePro Guest

    With srvany, did you specify the login name/password in the script or batch
    file ?

    ThePro
     
    ThePro, Jun 2, 2008
    #6
  7. Joe

    Joe Guest

    When the script ran it specified a username and password. Running as
    Local System the drive was there on user logon, but needed a username
    password. When I ran the script as a user account, the user account can
    write to is, but the drive isn't available.

    If we break security and allow anonymous access I believe that it would
    work, but is not approved by security.

    I tried SRVANY using VBS script, batch file and anything else I could think
    of.

    I am still open to be able to MAP the CIFS share at boot time and it be
    available to all services/users on that server.

    Thanks.
     
    Joe, Jun 2, 2008
    #7
  8. In
    What are the permissions on CIFS share properties? What are the NTFS
    permissions?

    Ace
     
    Ace Fekay [MVP], Jun 2, 2008
    #8
  9. Joe

    Joe Guest

    The CIFS share requires a username / passsword to connect to it (authenticating
    to the NetApp). The NTFS permissions are Everyone Read/Write (for testing
    only).

    As I said when a user logs in the drive is mapped, but each user needs to
    provide
    the username / password credentials of the NetApp account to be able to use
    the
    drive.

    So, while the drive maps correctly the services can't write to it as it
    needs to
    provide credentials. I am 90% there, but the last 10% seems to be elluding
    me.

    Thanks.
     
    Joe, Jun 3, 2008
    #9
  10. In
    If you bump up the perms on the CIFS for testing purposes, what are the
    results?

    Ace
     
    Ace Fekay [MVP], Jun 8, 2008
    #10
  11. Joe

    Joe Guest

    Changing permissions doesn't help. The issue (I believe) is the logon required
    to the CIFS share. If it was a truly anonymous login then I believe that it
    would
    work without issue. However since a username and password are required
    to connect to it, then I believe it would work.

    Thanks for the help.
     
    Joe, Jun 9, 2008
    #11
  12. In
    No problem. What would happen if you allowed Everyone Read on it? I know you
    may not want to do that, but just curious.

    Ace
     
    Ace Fekay [MVP], Jun 10, 2008
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.