Drives magically write protect themselves

Discussion in 'Windows Vista File Management' started by JimmiG, Oct 24, 2008.

  1. JimmiG

    JimmiG Guest

    I recently upgraded from Vista 32-bit to Vista 64-bit. I did this
    reformatting my C drive then performing a clean install of Vista 64-bit.
    I now have a problem with my volume(s) becoming write protected. I have
    to fight a constant battle against Vista to keep the volumes writeable.

    I have two drives:
    WD SE16 640GB: Primary or C drive
    Samsung T166 500GB: Secondary or D drive (used mostly for storing
    downloads, music, video etc.)

    Under Disk Management, both my drives alternate between being shown as
    "Online" and "Write protected": They can be shown as Online and then
    seconds later I hit F5 and both drives are suddenly write protected.
    Then I hit F5 again and they're "Online". Sometimes one of the drives is
    "Online" while the other is "Write protected". It's like a lottery,
    every time I refresh, the drives show a different status. It's like
    they're rapidly and constantly changing status.

    My C drive always remains writeable despite this. I don't know why -
    maybe it's because the drive is in use by the paging file and windows
    system files so the change cannot be applied.

    My D: drive on the other hand will write protect itself shortly after I
    have booted the machine. When I try to rename, copy or delete files I
    just get a Windows message saying the drive is write protected and I
    should remove the write protection or use another drive. When this
    happens I run Diskpart, and the command "Attributes volume clear
    readonly" on the D volume. This makes the drive writeable, but after a
    while (somtimes seconds, sometimes hours) the drive magically write
    protects itself again. As long as I keep modifying files on the drive it
    remains unprotected even if it sais "Write protected" in the disk
    management console. But it seems if I leave it idle for a while it will
    magically write protect itself and I have to do the diskpart thing
    again.

    This is frustrating to say the least.

    My user account has administrative privileges. I have tried disabling
    UAC. I have checked for virueses and background programs and tasks. I
    have tried about four different versions of the AMD/ATI AHCI drivers. I
    have checked the BIOS setup for any options that might be write
    protecting the drive. I have checked for Write Protect jumpers on both
    drives. This error is totally insane and I never experienced it with
    Vista 32-bit. It only started happening once I had switched to Vista
    64-bit.

    System:
    Asus M3A32-MVP Delux AMD 790FX/SB600 mobo, Phenom X4 9650, 4x1GB
    Corsair XMS2, Radeon HD 4850, M-Audio Delta1010LT, WD SE16 640GB,
    Samsung T166 500GB, Lite-ON DVDRW (P-ATA)
     
    JimmiG, Oct 24, 2008
    #1
    1. Advertisements

  2. JimmiG

    Daniel Guest

    I'm still having the same problem. I was hoping that a Hotfix that
    automatically downloaded last week would fix it. I was one pertaining to
    Bitlocker.

    I was wondering if you found a solution for this. I can't find any
    solutions in the Microsoft Knowledge Base. Googling "Vista disk write
    protected" only finds a smattering of people various versions of the same
    problem.

    I am still wondering if it has something to do with Bitlocker. I do not
    have it installed/activated. I don't even know where or how to check. I
    suspect Bitlocker because it seems to effect people who brought drives over
    from XP and have new installs of Vista Ultimate 64-bit.

    Anyway, I am going to look at the Disk Management Tool when I get home today
    to see if it rapidly switches like you describe.

    This has not caused a problem... yet. When it happens, I can save a working
    file to the C: drive, restart, then move the file to where I initially wanted
    to save it (on the previously write-protected disk).

    Also, does this seem to happen more when you "wake up" your computer from
    sleep mode?

    Also, do you have a USB stick being used as a "ReadyBoost" drive?
     
    Daniel, Nov 14, 2008
    #2
    1. Advertisements

  3. JimmiG

    RonK Guest

    I 'm having the same problem in the Beta Release of Windows 7 Ultimate 64-bit
    so it seems the problem with volumes write-protecting themselves has not been
    resolved. Actually, I'm not sure if it's a Windows generated fault or not.
    I too am running AMD/ATI AHCI so maybe it has something to do with that. My
    volumes appear to write-protect themselves after a reboot only, not after a
    wake up event and not randomly while the computer is running. I've created a
    batch file with the command...

    diskpart /s [scriptfilename].txt

    and in the script file I have these commands...

    select disk [disk number]
    select volume [volume letter]
    attributes volume clear readonly
    exit

    So at least I've made it easier to write enable the volume everytime the
    problem occurs but it's not a solution to the problem.
     
    RonK, Apr 23, 2009
    #3
  4. JimmiG

    Malke Guest

    Malke, Apr 23, 2009
    #4
  5. JimmiG

    JimmiG Guest

    I did manage to solve the problem eventually. In my case it was a matter
    of updating to version 2.5.1540.48 of the AMD AHCI driver. This driver
    was not available on Asus's homepage (I have an Asus mobo), but MSI (if
    I remember correctly) had the more recent version on the support page
    for one of their 790/SB600 based boards. If you have the SB7xx
    southbridge I think you need to use the 3.x version of the AHCI driver.
     
    JimmiG, Apr 23, 2009
    #5
  6. JimmiG

    Daniel Guest

    That's great! I'm glad you were able to solve the problem. I'm not exactly
    sure what AHCI is but I'm going to do some searching around and try to solve
    the problem on my computer. I built this computer at the end of 2007 so I
    probably have a lot of hardware drivers I need to update. Like most people,
    I just keep the GPU driver up-to-date... for playing games.

    I have a Gigabyte mobo with an Intel processor and an NVIDIA GPU. Someone
    else on this forum suggested that it might only be a problem on AMD/ATI
    computers but I can attest that that is not the case.

    For me, the problem seems to be very random. It seems to happen most every
    time I wake my computer from sleeping to the point that I never use this most
    convenient feature.

    Again, thanks for your information.
     
    Daniel, Apr 26, 2009
    #6
  7. JimmiG

    Demetrium

    Joined:
    May 31, 2009
    Messages:
    1
    Likes Received:
    0
    It's definitely not confined to AMD, I'm having this exact same problem on my PC. Here's my specs:

    Intel Core 2 Duo E6700 LGA775
    EVGA nForce 680i SLI Motherboard

    It only happens on my 500GB Western Digital USB hard-drive. I've tried everything...changing disk policy to performance instead of removal, making sure all permissions were okay, etc.

    A reboot always fixes this issue, and the drive seems to work fine for literally days then all of sudden becomes write-protected and stalls all my torrent downloads, ETC. Very annoying,
     
    Demetrium, May 31, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.