DVD Audio DTS / DD 5.1 output via SPDIF in MCE2005

Discussion in 'Windows Media Center' started by Plasma, Apr 23, 2005.

  1. Plasma

    Plasma Guest

    Hi,
    I am wanting to output the DTS and DD 5.1 streams to my AV amp using the
    SPDIF digital out on my Media Center. I have normal audio working via the
    SPDIF but the amp says its only receiving 2 channel stereo via the digital
    in. It works with my stand alone DVD player so I know its something in
    MCE2005. Is there another check box I need to tick? .. Also I tried adding a
    lead between the SPDIF out on the DVD Rom and the SPDIF in on the sound card.
    Still no joy ..... if I set the audio on a dvd to play the DTS track I get
    nothing at all out of the AV AMP until I switch it back to normal audio ....

    Kind Regards

    Plasma
     
    Plasma, Apr 23, 2005
    #1
    1. Advertisements

  2. Plasma

    Plasma Guest

    BTW I have a Creative SB Audigy [1040] Sound card!

    Plasma
     
    Plasma, Apr 23, 2005
    #2
    1. Advertisements

  3. You'll need to purchase a DVD decoder that supports Dolby Digital.

    I bought the cheapest version of the nVidia decoder and it does not emit DD
    5.1. However, their more expensive one does.

    http://www.nvidia.com/object/dvd_decoder.html
     
    Michael Earls, Apr 23, 2005
    #3
  4. Plasma

    Stephen Neal Guest

    I have my MCE 2005 installation with an external Audigy 2NX working fine,
    carrying DD5.1 and DTS audio via SPDIF for decoding in my amp.

    I am running the NVidia MPEG2 decoders - and there is an option in these for
    passthrough / external decoding / SPDIF output etc. There are also options
    for this in the SETTINGS in MCE 2005 ISTR, as well as the Soundblaster
    control panels, and even the Windows sound control panel (or is it the
    advanced bit of the volume control?)

    Wherever I saw the option for pass-through, SPDIF output, external decoding
    etc. anywhere in any control panel, setup screen or application, I chose it.
    No idea if all were vital for MCE - but I thought it wouldn't hurt!

    When I trialled the Cyberlink Power DVD MPEG2 decoders (to try and get Orb
    working properly) it reverted to PCM audio output via SPDIF, and when I
    re-installed the Nvidia decoder, I had to re-select passthrough etc. - so it
    is worth looking at the MCE DVD AUDIO settings and your MPEG2 decoder
    settings. (If you are running NVidia then right click on the taskbar NVidia
    logo when you are running MPEG2 video - running in a window makes this easy)

    Steve
     
    Stephen Neal, Apr 23, 2005
    #4
  5. Plasma

    Plasma Guest

    Thank you both for your replies, turns out after a bit of googling that the
    SB Audigy doesn't support DD 5.1 / DTS ... so I took the SP Audigy 2 ZS out
    of my other PC and replaced it .. bobs yer uncle all working now, not tested
    DTS but DD 5.1 is working so I guess the other will too!

    Plasma
     
    Plasma, Apr 23, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.