DVD-RW displays CD files & directories but not DVD files & directo

Discussion in 'Windows Vista Hardware' started by MikeD, Jun 4, 2007.

  1. MikeD

    MikeD Guest

    I have a "Lite-On DVDRW LH-20A1H ATA Device" (as reported by Device Manager)
    that will display the contents of CDs but not DVDs. The drive has the latest
    firmware upgrade. OS is Vista Home Premium 32-bit. Here's the scenario:

    I can pop in a DVD-ROM and Autoplay will launch asking if I want to run (in
    this case) Setup.exe or open to explore files. If I choose the latter, or
    close Autoplay and attempt to access the DVD drive via Windows Explorer, no
    files are shown and the disk properties show that it is 100% full. Oddly,
    the disk label *is* read. If I choose the former, it eventually gives me a
    "the language is not supported on your system" error and Setup.exe ends.
    Also, sometimes if I play around (looking at the menu options Properties,
    Configure, etc.), I'll get a BSOD.

    I have successfully read CD contents and installed programs from CD.

    I've tried the registry edits shown in:
    http://support.microsoft.com/kb/929461/en-us
    I've tried uninstalling and reinstalling the drivers (default Microsoft
    drivers).

    Can anyone offer any suggestions of what else to try (apologies in advance
    if this has already been asked and answered, but my search did not yield a
    solution)?
     
    MikeD, Jun 4, 2007
    #1
    1. Advertisements

  2. MikeD

    freddy Guest

    MikeD,

    Have you checked to see whether the DVD Region is set to 1? Double click
    Computer and right click the drive and select Properties. Look in the DVD
    Region tab to verify the setting. That's all I have. Anyone else?
     
    freddy, Jun 5, 2007
    #2
    1. Advertisements

  3. MikeD

    MikeD Guest

    Have you checked to see whether the DVD Region is set to 1? Double click
    freddy, thanks for offering a possible solution but I don't think that's it.
    The DVD/CDRW drive in my laptop shows the same region ("Not Selected") as
    the one I'm having trouble with, but my laptop can read and display the files
    and directories from the same disks that the desktop cannot. Any other
    ideas/suggestions?
     
    MikeD, Jun 5, 2007
    #3
  4. MikeD

    MikeD Guest

    freddy, thanks for responding, but I don't think that's it. My desktop has
    the same current region ("Not Selected") as my laptop, and the laptop
    DVD/CDRW drive can read the same disks that the desktop cannot. Any other
    thoughts? Anyone?
     
    MikeD, Jun 6, 2007
    #4
  5. MikeD

    MikeD Guest

    (Apologies for the double-post. As can be seen by the timestamps, I came
    back several hours later and didn't see the first, so thinking it hadn't
    posted successfully I made the second.)
     
    MikeD, Jun 8, 2007
    #5
  6. MikeD

    MikeD Guest

    Have you checked to see whether the DVD Region is set to 1? Double click
    More info: I finally resorted to what I consider a last resort - surgery. I
    swapped the drive in question out of the Vista machine and put it into an XP
    machine, and the XP machine was able to read the contents of DVD's just fine.
    So, it's apparently a Vista issue.

    freddy, I think during the transfer the region got set to "1" from "Not
    Selected", but that hasn't changed anything - the Vista machine still will
    not display the contents of a DVD but will display the contents of a CD. I'm
    sure this is a switch buried somewhere in the registry, but I haven't a clue
    where to find it.

    Also worth mentioning - AutoPlay handles DVD's as I would expect;
    executables can be selected to run, movies will play, etc., except for the
    option to "open folder to view files". This fact makes me feel a little
    better, as it would seem that I can at least use the drive, but I still want
    to be able to browse the contents.
     
    MikeD, Jun 8, 2007
    #6
  7. MikeD

    freddy Guest

    MikeD,

    Your guess as to the cause is as good as mine. One approach to solving this
    issue is to use google to search the Internet. It's likely this problem has
    been commented on out there, and some solution posted. Searching on terms
    that produce results are key to finding such posts. Maybe someone here has
    an idea. Anyone?
     
    freddy, Jun 9, 2007
    #7
  8. MikeD

    freddy Guest

    freddy, Jun 9, 2007
    #8
  9. MikeD

    freddy Guest

    freddy, Jun 9, 2007
    #9
  10. MikeD

    MikeD Guest

    After quite a bit of troubleshooting, I've got more information regarding
    this problem. To recap: I have a DVD-RW drive in my Vista Home Premium
    (32-bit) system that can display the contents of CD-ROMs in Windows Explorer
    without a problem but will not show the contents of DVD-ROM discs. It will
    read the disc's label and icon, and I can run AutoPlay and it will give me
    the option to (for instance) run a Setup program, but at some point Vista
    will BSOD with error 0x000000E3, complaining that a device "tried to release
    a resource that it did not own".

    Stuff I've tried:
    I swapped the drive in question (Lite-On) into my older, XP machine, and it
    worked perfectly.
    I swapped the drive from my older, XP machine (Plextor) into the Vista
    machine and it exhibited the same symptoms as the original drive.

    These two items suggest two points of commonality: Vista and the new PC's
    motherboard. Having seen a number of threads in this forum detailing
    problems with DVD drives, my primary suspect is Vista.

    I have also read and tried the following KB articles, none of which either
    apply or helped:

    http://support.microsoft.com/kb/939052/
    http://support.microsoft.com/kb/929461/
    http://support.microsoft.com/kb/316529/
    http://support.microsoft.com/kb/320553/
    http://support.microsoft.com/kb/321641/

    I've had Device Manager attempt to update the drivers for my DVD drive, the
    IDE controllers, and the storage controllers.

    I've deleted C:\windows\inf\INFCACHE.1 based on the experience from someone
    else on this forum.

    As evidenced by the presence of this post, nothing thus far has worked. If
    anyone could provide any useful information you will go a long way to
    improving the mental health of one stressed out adopter of technology that is
    perhaps not ready for prime time. Not to mention preserving a forehead and
    desk. Thanks in advance!
     
    MikeD, Jul 4, 2007
    #10
  11. I had a similar situation with Ultimate. First, during the install
    Vista booted the CD off the DVD then complained it needed drivers and
    wouldn't install (well, duh - you just booted off it). I put in an old
    Creative DVD unit and installed Vista. I put the new unit back in and
    Vista said it installed drivers when I logged in. I saw the device in
    explorer but none of the files on it would display. My solution was to
    buy a DVD/CD unit that said it would work with Vista (I used a Sony) and
    replace my brand new Pioneer and now Vista is happy. It's said that
    Vista is having so much trouble with something so basic as a DVD/CD
    drive but for some reason it is being stupid when it comes to DVD/CD drives.
     
    Brett I. Holcomb, Jul 4, 2007
    #11
  12. MikeD

    Peter Foldes Guest

    Peter Foldes, Jul 5, 2007
    #12
  13. MikeD

    MikeD Guest

    Peter, thanks for responding, but you'll note that that was the first KB I
    had listed, so I've already tried it to no avail.

    Brett - I don't want to resolve this problem by throwing more money at it.
    Let Congress do that! Using that method, I'd have to replace my motherboard,
    too, and while I'm at it, why don't I just replace my whole brand-new PC?
    Sorry if that sounds terse, but I'd be more inclined to replace Vista than
    any hardware at this juncture. There *has* to be a software fix - if the
    drive works in XP, why doesn't/shouldn't it work in Vista?

    Anybody else? Anyone have any thoughts on the BSOD error message ("tried to
    release a resource that it did not own")?
     
    MikeD, Jul 6, 2007
    #13
  14. MikeD

    MikeD Guest

    After more research, I'm developing a theory as to what's going on, but
    without in-depth knowledge of the inner workings of computers and Vista, this
    is more a hunch than a theory.

    The theory is that there's a bug in the IDE controller/driver in Vista when
    the only IDE drive is an optical one (i.e. hard drives are SATA, not IDE).

    There's a couple of ways to test this theory: go out an buy a SATA optical
    drive or an IDE hard drive (with no guarantee of success), or ask the
    community if they have any rigs that disprove this theory. So, my question
    now is:

    Does anyone running Vista (Home Premium 32-bit, if it matters) have SATA
    hard drives (only) and an IDE DVD drive, and if so, are you having problems
    reading DVD-format disks?

    I've included my re-hash of the problem below. Thanks for any input you can
    offer, it is truly appreciated.
     
    MikeD, Jul 9, 2007
    #14
  15. MikeD

    Cal Bear '66 Guest

    I have a system with 2 SATA hard drives and one IDE DVD reader/writer -- NO
    problems with movie DVDs or other pre-recorded DVDs.
     
    Cal Bear '66, Jul 9, 2007
    #15
  16. MikeD

    liquiddan Guest

    I am also having a problem reading files from dvd's but not cd's, similar
    issue but not able to run application install from dvd's. Have you had any
    luck resolving MikeD?
     
    liquiddan, Nov 9, 2007
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.