Dynamic DNS updates

Discussion in 'DNS Server' started by Mikoyan, Aug 17, 2009.

  1. Mikoyan

    Mikoyan Guest

    Hi on my newly setup W2K3 DNS server I am trying to enable dynamic DNS
    updates. However I get this error in Event Viewer:
    Help and Support suggests the following to fix the problem:
    Only trouble is I don't know how to do this. Please could someone give me a
    very easy to follow guide to creating the required (A) resource record. It
    might be best to assume I know nothing!

    Thanks, Anastas
     
    Mikoyan, Aug 17, 2009
    #1
    1. Advertisements

  2. The message, "DNS_EVENT_ZONE_BAD_PRIMARY_SERVER" indicates that the SOA name
    is missing in the zone properties. Open DNS, right click the zone name,
    choose properties, Nameservers tab. Do you see your DNS server listed in
    here? If not, add it by FQDN and IP address.

    Also, to make sure there is no configuration issues present that would have
    caused this, please post an unedited ipconfig /all of this machine, please.

    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Please reply back to the newsgroup or forum to benefit from collaboration
    among responding engineers, and to help others benefit from your resolution.

    Ace Fekay, MCT, MCTS Exchange, MCSE, MCSA 2003 & 2000, MCSA Messaging
    Microsoft Certified Trainer

    For urgent issues, please contact Microsoft PSS directly. Please check
    http://support.microsoft.com for regional support phone numbers.
     
    Ace Fekay [MCT], Aug 17, 2009
    #2
    1. Advertisements

  3. Mikoyan

    Mikoyan Guest

    Hi Ace result of ipconfig /all:

    Microsoft Windows [Version 5.2.3790]
    (C) Copyright 1985-2003 Microsoft Corp.

    C:\Documents and Settings\Administrator>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : computer1
    Primary Dns Suffix . . . . . . . : domain1.local
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : domain1.local

    Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel 21140-Based PCI Fast Ethernet
    Adapt
    er (Generic) #2
    Physical Address. . . . . . . . . : 00-03-xx-xx-xx-xx
    DHCP Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

    Ethernet adapter MyISP:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel 21140-Based PCI Fast Ethernet
    Adapt
    er (Generic)
    Physical Address. . . . . . . . . : 00-03-xx-xx-xx-xx
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.4
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    Lease Obtained. . . . . . . . . . : 17 August 2009 18:20:17
    Lease Expires . . . . . . . . . . : 17 August 2009 19:20:17

    and under the Name Servers tab in domain1.local properties I see:

    Server FQDN IP Address
    computer1 Unknown
    computer1.domain1.local [192.168.1.4] [192.168.0.1]


    Thanks, Anastas
     
    Mikoyan, Aug 17, 2009
    #3
  4. Hello Mikoyan,

    Is your server domain controller? Your problems belong to the multihoming,
    using RRAS on it and having DHCP enabled on one NIC. So remove the RRAS from
    the server, especially if the server is DC and use only fixed ip address
    on the server. Unused NICs disable or check the server vendor webpage if
    they offer a teaming software to use both NICs either for load balancing
    or failover.

    Best regards

    Meinolf Weber


     
    Meinolf Weber [MVP-DS], Aug 17, 2009
    #4
  5. Mikoyan

    Mikoyan Guest

    Hi Meinolf, the server is not a domain controller. I will try disabling one
    of the NICs.

    Thanks, Anastas
     
    Mikoyan, Aug 17, 2009
    #5
  6. Hi Anastas,

    I see a couple things wrong, besides the multihoming issue that Meinolf
    indicated. Just to touch base on multihoming, it is not recommended to
    multihome or install RRAS on a DC or a DNS server, whether the DNS server is
    a DC or not. This is because the DNS server tries to register itself for SOA
    purposes.

    Another big issue in the ipconfig is that you told the server to use your
    router as a DNS server, therefore it can never register with your DNS
    server. This is the address I'm referring to in your ipconfig:
    That needs to be changed to 192.168.1.4 on both interfaces. Matter of fact,
    the other interface doesn't even have a DNS address listed.

    Between the multihoming, and not specifying to use itself as its DNS server,
    is what's causing the issue. This is because it is asking 192.168.1.1 to
    register into a zone called domain1.local, however 192.168.1.1 is a router,
    not a DNS server.

    You may ask, "This is a DNS server, so why doesn't it use itself?" Even a
    DNS server needs to be configured to use a DNS server to send queries,
    registration, etc, to. The DNS Server Service is not a resolver service. The
    machine has it's own resolver service that you need to tell the resolver
    service what DNS server to use. If you want it to use itself, simply enter
    its own IP address in the NIC properties.

    Therefore, the steps to take to fix it:

    1. As Meinolf recommended, disable RRAS. That can be done by clicking on
    Start, Administrative Tools, Routing and Remote Access, in the RRAS console,
    right click the server name, choose Disable. Also check in the Services
    console to insure that the RRAS service is disabled.
    2. Disable the outside NIC. Configure the inside NIC with 192.168.1.4 as the
    DNS server (itself), and configure 192.168.1.1 as the gateway. Or you can
    team the NICs. Consult the NIC's documentation on how to do that. Each brand
    name NIC has their own procedure for this. Or just wait for another time to
    do this and get this working for now.
    3. Restart the machine.
    4. Check DNS for registration. Check the zone properties, Nameserver tab to
    show only "computer1domain1.local" 192.168.1.4. If the 'unknown' and both
    IPs still show, delete them and manually add computer1.domain1.local and
    192.168.1.4.

    Ace
     
    Ace Fekay [MCT], Aug 17, 2009
    #6
  7. Mikoyan

    Mikoyan Guest

    Thanks Ace,

    I Followed what you said, everything works now.

    The instructions were, as requested, very clear and comprehensive. Thanks
    again.

    Regards, Mikoyan
     
    Mikoyan, Aug 18, 2009
    #7
  8. You are welcome, Mikoyan! Glad to be of help.

    Ace
     
    Ace Fekay [MCT], Aug 18, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.