Edit permissions for Fonts folder

Discussion in 'Windows Vista Security' started by Chufflebean, Jul 7, 2008.

  1. Chufflebean

    Chufflebean Guest

    I'm trying to delete a bunch of extraneous fonts, but Windows won't let me
    delete them because of Permissions. Currently I'm having to open the
    properties of each font individually, change the owner to me, close the
    properties, reopen them, and give myself the right permissions. There must be
    a faster way! I wanted to apply these permission settings to the whole Fonts
    folder, but when I right-click Fonts and choose properties, there is no
    "security" tab.
     
    Chufflebean, Jul 7, 2008
    #1
    1. Advertisements

  2. Chufflebean

    Engel Guest

    Engel, Jul 7, 2008
    #2
    1. Advertisements

  3. you could try opening a commend window in administrator mode,
    navigating to the c:\windows\fonts folder and deleting from there.
     
    Michael Walraven, Jul 7, 2008
    #3
  4. Chufflebean

    Kerry Brown Guest

  5. Chufflebean

    Chufflebean Guest

    None of these suggestions solved my problem (Unlocker couldn't find a locking
    handle for the fonts folder, and didn't appear on the context menu for any of
    the fonts in it, and trying to delete the fonts from a command prompt just
    gave me an "access denied" message).

    However, while in the command prompt, I noticed something interesting. I
    know very VERY little about doing stuff with the cmd prompt, but I do know
    that typing "dir" will list the contents of the folder you're in. I did that
    while in the Windows folder, and "Fonts" did not appear on the list.

    This makes me wonder if the fonts are REALLY stored elsewhere--somewhere
    that I could access and apply security settings in the normal way.

    Any thoughts?
     
    Chufflebean, Jul 11, 2008
    #5
  6. Chufflebean

    Nonny Guest

    Go in there again. This time instead of doing a "dir", do a "cd
    fonts".

    It's there.
     
    Nonny, Jul 11, 2008
    #6
  7. Chufflebean

    Chufflebean Guest

    Well, I tried one more thing...while trying to fix another problem, I ran
    across this blog post about fixing problems with permissions using SubInAcl
    (http://blogs.msdn.com/astebner/archive/2006/09/04/739820.aspx).

    I ran it. It came up with some errors, but it ran. I'm not sure if it's what
    solved the problem, or if it was a delayed response to some of the other
    things I tried, but ever since running it, I've had permission to delete the
    fonts.

    Now, however, I get messages telling me I can't delete some of them because
    they're being used by another program!! Even when I have no other programs
    running!! If anyone can shed some light on that, I'd be much obliged.
     
    Chufflebean, Jul 11, 2008
    #7
  8. Those are SYSTEM FONTS.

    Leave them alone.
     
    John Amendall, Jul 11, 2008
    #8
  9. Chufflebean

    Nonny Guest

    Those are system fonts.

    What is it with your quest to delete fonts? Is it an
    obsessive-compulsive thing about getting rid of everything you don't
    use? Are you extremely short on drive space?

    What?
     
    Nonny, Jul 11, 2008
    #9
  10. Chufflebean

    Chufflebean Guest

    Yeah, it's definitely an obsessive-compulsive thing. I figure if Windows
    really needs to display something in Korean, I can reinstall the font, and in
    the meantime, it can stay out of my way.

    Thanks for your concerns about my mental health! :D
     
    Chufflebean, Jul 12, 2008
    #10
  11. Chufflebean

    Kerry Brown Guest


    Do you have UAC turned off? If you do try turning it back on then changing
    the permissions. The other option would be to use icacls from an elevated
    command prompt.
     
    Kerry Brown, Jul 12, 2008
    #11
  12. Try dir /a instead.

     
    FromTheRafters, Jul 12, 2008
    #12
  13. Chufflebean

    Aravind Guest

    Hi All,
    Windows 2008 has come up with a new concept where C:\WIndows folder is given

    By default only the TrusedInstaller group is having Full Control permission
    for any file under C:\Windows. Even the Administrator is denied of Full
    Control permission for security reasons.

    To edit any of the file say for example(C:\Windows\Inf\sceregvl.inf file)
    1. U need to take the ownership of the file logging in as Administrator
    2. Grant Administrator full control.
    3. Edit the file

    Please find the code that u need to execute
    Step1 : C:\Windows\inf>takeown /f sceregvl.inf
    O/P : SUCCESS: The file (or folder): "C:\Windows\inf\sceregvl.inf" now
    owned by user "WIN2008-DC-74-9\Administrator".

    Step2 : C:\Windows\inf>icacls sceregvl.inf /grant Administrators:(F)
    O/P : processed file: sceregvl.inf
    Successfully processed 1 files; Failed processing 0 files


    Hope this solves ur problem :)

    Regards
    Aravind
     
    Aravind, Aug 7, 2008
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.