Email Rules Forwarding and Fax Forwarding Not Working

Discussion in 'Windows Small Business Server' started by Tom Schwartz, Sep 19, 2006.

  1. Tom Schwartz

    Tom Schwartz Guest

    I have never been able to get Outlook Rules to forward email correctly to
    another mailbox or deliver new email to an external address for a receipent.
    Additionlly the built in Inbound Fax Forwarding Wizard will not correctly
    Route a new fax to an email address. What can I check to make sure this is
    installed correctly?

    I have used the Fax Wizard and it seems to do the setup fine, delivers a
    copy of the fax to everything except an email receipient.

    Thanks in Advance
     
    Tom Schwartz, Sep 19, 2006
    #1
    1. Advertisements

  2. Tom Schwartz

    chace zhang Guest

    Hi,

    Thank you for posting here.

    In Exchange 2003, "Allow automatic forward" is disabled by default.
    Therefore, Auto Forward Rule created in Outlook client side to forward mail
    will not work. To resolve this issue, enable "Allow automatic forward" by
    following the step below:

    1. On the SBS server, start Exchange System Manager.

    2. Double-click Global Settings, and then click Internet Message Formats.

    3. In the right pane, double-click the "Default" item.

    4. In the Properties dialog box, click the Advanced tab, and then click to
    select the "Allow automatic forward" option.

    Reference:

    266166 Automatic replies and automatic forwards to Internet recipients are
    disabled in Exchange 2000 Server and in Exchange Server 2003
    http://support.microsoft.com/?id=266166

    If the information above doesn't help, please check the following:

    1. Does the issue occur to all users?

    2. Log on to another workstation as the "problematic" user, create an
    Outlook profile and see if you can reproduce the problem.

    3. Download MDBVU32 at:

    Exchange Server Information Store Viewer (MDBVU32)
    http://www.microsoft.com/downloads/details.aspx?familyid=3d1c7482-4c6e-4ec5-
    983e-127100d71376&displaylang=en

    And delete rules by following the KB artcle below:

    320022 XCLN: How to Use the Mdbvu32 Utility to Remove Inbox Rules
    http://support.microsoft.com/?id=320022

    And then re-create the rule, does it help?

    Additional information that may help:

    281926 How to Configure a Mailbox to Forward Mail to a Mail-Enabled Contact
    http://support.microsoft.com/?id=281926

    317652 How to Override Blocked Auto-Forwarding for Select Users
    http://support.microsoft.com/?id=317652


    Regarding inbound fax can not route to mailbox issue,

    I. Based on my research, to resolve this issue, please run the following
    command-line to register these files:

    regsvr32 "C:\PROGRAM FILES\COMMON FILES\MICROSFT SHARED\CDO\cdoex.dll"
    regsvr32 "C:\PROGRAM FILES\EXCHSRVR\BIN\cdo.dll"

    Then try again to check if the issue can be reproduced.

    II. If the issue still persists, please use the following steps to
    confirm the Fax service has been configured correctly.

    1) Open Server Management
    2) Right-click on Fax (Local) container
    3) Select "Properties"
    4) Select "Receipts" tab

    Message Box - check the option "Enable Message Boxes as receipts"
    SMTP E-mail
    "Enable SMTP Receipts e-mail receipts delivery" is enabled
    "From e-mail address" should be listed as

    Authentication - should be Anonymous access
    Check the option in "Use these SMTP Settings for the Route through
    E-mail incoming routing method"

    Restarted the Shared Fax Service if any changes.

    2. Verify the Exchange Server Virtual SMTP Server is configured to listen
    on 'all unassigned'.

    3. please refer to the below steps to Re-register fxsroute.dll (regsvr32
    fxsroute.dll):

    A. Locate the fxsroute.dll from the CD3\SBS\CLIENTAPPS\FAXCLIENT folder.

    B. Copy this file to the %systemroot%\system32 folder on the SBS Server.

    C. Click Start, click Run, type cmd in the Open box, and then click OK.

    D. At the MS-DOS prompt, type cd c:\windows\system32, and then press
    ENTER.

    E. At the next prompt, type regsvr32 /u fxsroute.dll, and then press
    ENTER.

    F. After you receive the following message, type exit at the prompt, and
    then press ENTER:

    Dll register server in fxsroute.dll succeeded.

    G. Restart your computer.

    4. Open Exchange System Manager, expand Servers\your
    server\Protocols\SMTP, right-click Default SMTP Virtual Server and click
    Properties. On the Access tab, click the Connection button under
    "Connection control". If it is set to "Only the list below", select "All
    except the list below" and list only the IP addresses of computers for
    which you specifically want to deny connections. Stop and start the SMTP
    virtual server, check if the issue still occurs.

    Hope this helps, if you have any other concerns on this issue, please feel
    free to let me know. I'm looking forward to your update.


    Have a nice day


    Best Regards,

    Chace Zhang (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.

    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.


    --------------------
    | Thread-Topic: Email Rules Forwarding and Fax Forwarding Not Working
    | thread-index: AcbbefHGTdE/rX9hTTiLqypUXBqNtA==
    | X-WBNR-Posting-Host: 74.238.159.6
    | From: =?Utf-8?B?VG9tIFNjaHdhcnR6?= <Tom
    >
    | Subject: Email Rules Forwarding and Fax Forwarding Not Working
    | Date: Mon, 18 Sep 2006 16:27:02 -0700
    | Lines: 10
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGXA01.phx.gbl
    | Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.server.sbs:298483
    | NNTP-Posting-Host: TK2MSFTNGXA01.phx.gbl 10.40.2.250
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | I have never been able to get Outlook Rules to forward email correctly to
    | another mailbox or deliver new email to an external address for a
    receipent.
    | Additionlly the built in Inbound Fax Forwarding Wizard will not correctly
    | Route a new fax to an email address. What can I check to make sure this
    is
    | installed correctly?
    |
    | I have used the Fax Wizard and it seems to do the setup fine, delivers a
    | copy of the fax to everything except an email receipient.
    |
    | Thanks in Advance
    |
     
    chace zhang, Sep 19, 2006
    #2
    1. Advertisements

  3. Tom Schwartz

    Tom Schwartz Guest

    Okay, halfway home. Enabling the "Allow automatic forward" option fixed the
    email forwarding issues.

    I am stuck on step 3e in the registration of the fxsroute.dll. I can see
    that the installed (non-working) fxsroute.dll (43K) is different then the one
    straight off the cdrom (31K). However when I try and replace the existing
    fxsroute.dll(43K) with the older one off the cdrom(31k), the system after
    about 5 seconds replaces my new fxsroute.dll(31K) with a copy of the old
    one(43K). How can I make this change permanant or turn off the replacement
    engine that keeps replacing my broken dll?

    Thanks
     
    Tom Schwartz, Sep 20, 2006
    #3
  4. Tom Schwartz

    Tom Schwartz Guest

    Halfway there. Email is working fine after enabling it! :_0

    Fax still not working but I am having trouble executing step 3E.

    Clearly the installed FXSROUTE.DLL (Version 5/12/2005 5.2.3790.1830) is
    different than the one off the Install CDROM (Version 8/18/2001 5.2.1776.0).
    However, when I execute the regsvr32 /u fxsroute.dll command I get the
    following error message.

    "fxsroute.dll was loaded, but the dllunregisterserver entry point was not
    found. This file can not be registered"

    Also, whenever I copy the CDROM version (older file) over the installed
    (newer )version, the system undoes my replacement about 5 seconds after the
    replacement completes, return the fxsroute.dll file in the
    c:\windows\system32 directory back to the 5/12/2005 version.

    Thanks for your help

    Tom
     
    Tom Schwartz, Sep 20, 2006
    #4
  5. Tom Schwartz

    chace zhang Guest

    Hi Tom,

    Thanks for your update.

    Based on my deep research, we can use the following steps to try to
    Re-register fxsroute.dll:

    A. Run "cmd" (without the quotation marks) on the command prompt on the
    SBS Server, and then input: net stop spooler

    B. Regsvr32 /u /s fxsroute.dll

    C. Regsvr32 /s fxsroute.dll

    D. net start spooler

    Please search fxsroute.dll on your SBS Server, are there any other files?
    You can delete them, I suggest you keep a copy of this file. After that
    register it again.

    If the issue persists, please open the properties page of Fax container in
    the Server Management and go to "receipts tab",

    1. Please confirm that "Enable Message Boxes as receipts" is checked

    2. Please confirm "Enable SMTP Receipts e-mail receipts delivery" is checked

    3. "From e-mail address" box should be listed as
    . If it is
    , please modify it.

    4. Click the Authentication, the authentication method should be
    ''Anonymous access''. If it is set to '' Integrated Windows'', please
    modify it.

    After above settings, please restart the Fax service in the service console
    (services.msc) and test your issue again.

    Open Exchange System Manager, expand Servers\your server\Protocols\SMTP,
    right-click Default SMTP Virtual Server and click Properties. On the Access
    tab, click the Connection button under "Connection control". If it is set
    to "Only the list below", select "All except the list below" and list only
    the IP addresses of computers for which you specifically want to deny
    connections. Stop and start the SMTP virtual server, check if the issue
    still occurs.

    Hope this helps, if you have any other concerns on this issue, please feel
    free to let me know.
    Have a nice day!

    Best Regards,

    Chace Zhang (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.

    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | Thread-Topic: Email Rules Forwarding and Fax Forwarding Not Working
    | thread-index: AcbcV8kHALzE7VkSQDKZ68vLhDFXtg==
    | X-WBNR-Posting-Host: 66.156.93.167
    | From: =?Utf-8?B?VG9tIFNjaHdhcnR6?= <>
    | References: <>
    <>
    | Subject: RE: Email Rules Forwarding and Fax Forwarding Not Working
    | Date: Tue, 19 Sep 2006 18:55:01 -0700
    | Lines: 221
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGXA01.phx.gbl
    | Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.server.sbs:298773
    | NNTP-Posting-Host: TK2MSFTNGXA01.phx.gbl 10.40.2.250
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | Halfway there. Email is working fine after enabling it! :_0
    |
    | Fax still not working but I am having trouble executing step 3E.
    |
    | Clearly the installed FXSROUTE.DLL (Version 5/12/2005 5.2.3790.1830) is
    | different than the one off the Install CDROM (Version 8/18/2001
    5.2.1776.0).
    | However, when I execute the regsvr32 /u fxsroute.dll command I get the
    | following error message.
    |
    | "fxsroute.dll was loaded, but the dllunregisterserver entry point was not
    | found. This file can not be registered"
    |
    | Also, whenever I copy the CDROM version (older file) over the installed
    | (newer )version, the system undoes my replacement about 5 seconds after
    the
    | replacement completes, return the fxsroute.dll file in the
    | c:\windows\system32 directory back to the 5/12/2005 version.
    |
    | Thanks for your help
    |
    | Tom
    |
    | "chace zhang" wrote:
    |
    | > Hi,
    | >
    | > Thank you for posting here.
    | >
    | > In Exchange 2003, "Allow automatic forward" is disabled by default.
    | > Therefore, Auto Forward Rule created in Outlook client side to forward
    mail
    | > will not work. To resolve this issue, enable "Allow automatic forward"
    by
    | > following the step below:
    | >
    | > 1. On the SBS server, start Exchange System Manager.
    | >
    | > 2. Double-click Global Settings, and then click Internet Message
    Formats.
    | >
    | > 3. In the right pane, double-click the "Default" item.
    | >
    | > 4. In the Properties dialog box, click the Advanced tab, and then click
    to
    | > select the "Allow automatic forward" option.
    | >
    | > Reference:
    | >
    | > 266166 Automatic replies and automatic forwards to Internet recipients
    are
    | > disabled in Exchange 2000 Server and in Exchange Server 2003
    | > http://support.microsoft.com/?id=266166
    | >
    | > If the information above doesn't help, please check the following:
    | >
    | > 1. Does the issue occur to all users?
    | >
    | > 2. Log on to another workstation as the "problematic" user, create an
    | > Outlook profile and see if you can reproduce the problem.
    | >
    | > 3. Download MDBVU32 at:
    | >
    | > Exchange Server Information Store Viewer (MDBVU32)
    | >
    http://www.microsoft.com/downloads/details.aspx?familyid=3d1c7482-4c6e-4ec5-
    | > 983e-127100d71376&displaylang=en
    | >
    | > And delete rules by following the KB artcle below:
    | >
    | > 320022 XCLN: How to Use the Mdbvu32 Utility to Remove Inbox Rules
    | > http://support.microsoft.com/?id=320022
    | >
    | > And then re-create the rule, does it help?
    | >
    | > Additional information that may help:
    | >
    | > 281926 How to Configure a Mailbox to Forward Mail to a Mail-Enabled
    Contact
    | > http://support.microsoft.com/?id=281926
    | >
    | > 317652 How to Override Blocked Auto-Forwarding for Select Users
    | > http://support.microsoft.com/?id=317652
    | >
    | >
    | > Regarding inbound fax can not route to mailbox issue,
    | >
    | > I. Based on my research, to resolve this issue, please run the
    following
    | > command-line to register these files:
    | >
    | > regsvr32 "C:\PROGRAM FILES\COMMON FILES\MICROSFT SHARED\CDO\cdoex.dll"
    | > regsvr32 "C:\PROGRAM FILES\EXCHSRVR\BIN\cdo.dll"
    | >
    | > Then try again to check if the issue can be reproduced.
    | >
    | > II. If the issue still persists, please use the following steps to
    | > confirm the Fax service has been configured correctly.
    | >
    | > 1) Open Server Management
    | > 2) Right-click on Fax (Local) container
    | > 3) Select "Properties"
    | > 4) Select "Receipts" tab
    | >
    | > Message Box - check the option "Enable Message Boxes as receipts"
    | > SMTP E-mail
    | > "Enable SMTP Receipts e-mail receipts delivery" is enabled
    | > "From e-mail address" should be listed as
    | >
    | > Authentication - should be Anonymous access
    | > Check the option in "Use these SMTP Settings for the Route through
    | > E-mail incoming routing method"
    | >
    | > Restarted the Shared Fax Service if any changes.
    | >
    | > 2. Verify the Exchange Server Virtual SMTP Server is configured to
    listen
    | > on 'all unassigned'.
    | >
    | > 3. please refer to the below steps to Re-register fxsroute.dll
    (regsvr32
    | > fxsroute.dll):
    | >
    | > A. Locate the fxsroute.dll from the CD3\SBS\CLIENTAPPS\FAXCLIENT
    folder.
    | >
    | > B. Copy this file to the %systemroot%\system32 folder on the SBS
    Server.
    | >
    | > C. Click Start, click Run, type cmd in the Open box, and then click
    OK.
    | >
    | > D. At the MS-DOS prompt, type cd c:\windows\system32, and then press
    | > ENTER.
    | >
    | > E. At the next prompt, type regsvr32 /u fxsroute.dll, and then press
    | > ENTER.
    | >
    | > F. After you receive the following message, type exit at the prompt,
    and
    | > then press ENTER:
    | >
    | > Dll register server in fxsroute.dll succeeded.
    | >
    | > G. Restart your computer.
    | >
    | > 4. Open Exchange System Manager, expand Servers\your
    | > server\Protocols\SMTP, right-click Default SMTP Virtual Server and
    click
    | > Properties. On the Access tab, click the Connection button under
    | > "Connection control". If it is set to "Only the list below", select
    "All
    | > except the list below" and list only the IP addresses of computers for
    | > which you specifically want to deny connections. Stop and start the
    SMTP
    | > virtual server, check if the issue still occurs.
    | >
    | > Hope this helps, if you have any other concerns on this issue, please
    feel
    | > free to let me know. I'm looking forward to your update.
    | >
    | >
    | > Have a nice day
    | >
    | >
    | > Best Regards,
    | >
    | > Chace Zhang (MSFT)
    | >
    | > Microsoft CSS Online Newsgroup Support
    | >
    | > Get Secure! - www.microsoft.com/security
    | >
    | > =====================================================
    | > This newsgroup only focuses on SBS technical issues. If you have issues
    | > regarding other Microsoft products, you'd better post in the
    corresponding
    | > newsgroups so that they can be resolved in an efficient and timely
    manner.
    | > You can locate the newsgroup here:
    | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | >
    | > When opening a new thread via the web interface, we recommend you check
    the
    | > "Notify me of replies" box to receive e-mail notifications when there
    are
    | > any updates in your thread. When responding to posts via your
    newsreader,
    | > please "Reply to Group" so that others may learn and benefit from your
    | > issue.
    | >
    | > Microsoft engineers can only focus on one issue per thread. Although we
    | > provide other information for your reference, we recommend you post
    | > different incidents in different threads to keep the thread clean. In
    doing
    | > so, it will ensure your issues are resolved in a timely manner.
    | >
    | > For urgent issues, you may want to contact Microsoft CSS directly.
    Please
    | > check http://support.microsoft.com for regional support phone numbers.
    | >
    | > Any input or comments in this thread are highly appreciated.
    | >
    | > =====================================================
    | >
    | > This posting is provided "AS IS" with no warranties, and confers no
    rights.
    | >
    | >
    | > --------------------
    | > | Thread-Topic: Email Rules Forwarding and Fax Forwarding Not Working
    | > | thread-index: AcbbefHGTdE/rX9hTTiLqypUXBqNtA==
    | > | X-WBNR-Posting-Host: 74.238.159.6
    | > | From: =?Utf-8?B?VG9tIFNjaHdhcnR6?= <Tom
    | > >
    | > | Subject: Email Rules Forwarding and Fax Forwarding Not Working
    | > | Date: Mon, 18 Sep 2006 16:27:02 -0700
    | > | Lines: 10
    | > | Message-ID: <>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain;
    | > | charset="Utf-8"
    | > | Content-Transfer-Encoding: 7bit
    | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | Content-Class: urn:content-classes:message
    | > | Importance: normal
    | > | Priority: normal
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | > | Newsgroups: microsoft.public.windows.server.sbs
    | > | Path: TK2MSFTNGXA01.phx.gbl
    | > | Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.server.sbs:298483
    | > | NNTP-Posting-Host: TK2MSFTNGXA01.phx.gbl 10.40.2.250
    | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > |
    | > | I have never been able to get Outlook Rules to forward email
    correctly to
    | > | another mailbox or deliver new email to an external address for a
    | > receipent.
    | > | Additionlly the built in Inbound Fax Forwarding Wizard will not
    correctly
    | > | Route a new fax to an email address. What can I check to make sure
    this
    | > is
    | > | installed correctly?
    | > |
    | > | I have used the Fax Wizard and it seems to do the setup fine,
    delivers a
    | > | copy of the fax to everything except an email receipient.
    | > |
    | > | Thanks in Advance
    | > |
    | >
    | >
    |
     
    chace zhang, Sep 20, 2006
    #5
  6. Tom Schwartz

    Tom Schwartz Guest

    using the net stop spooler command (stops the print spooler) executes fine
    however it does nothing to keep the non-working dll from reappearing and
    overwriting the version I am trying to copy into place. The only other
    copies of the non-working (43K) version of the DLL were in the Trash Can and
    I deleted those.

    Next step?

    Tom
     
    Tom Schwartz, Sep 20, 2006
    #6
  7. Tom Schwartz

    chace zhang Guest

    Hi,

    Thank you for your update.

    I have tested on my side, the same result, I think this is a expect result,
    after register the dll file, it automatic update to a higher version.
    Please confirm after the steps, does the fax route to mailbox functional?


    If the issuer persists, let's move on to try following steps in my previous
    reply:

    Step 1:

    If the issue persists, please open the properties page of Fax container in
    the Server Management and go to "receipts tab",

    1. Please confirm that "Enable Message Boxes as receipts" is checked

    2. Please confirm "Enable SMTP Receipts e-mail receipts delivery" is checked

    3. "From e-mail address" box should be listed as
    . If it is
    , please modify it.

    4. Click the Authentication, the authentication method should be
    ''Anonymous access''. If it is set to '' Integrated Windows'', please
    modify it.

    After above settings, please restart the Fax service in the service console
    (services.msc) and test your issue again.

    Open Exchange System Manager, expand Servers\your server\Protocols\SMTP,
    right-click Default SMTP Virtual Server and click Properties. On the Access
    tab, click the Connection button under "Connection control". If it is set
    to "Only the list below", select "All except the list below" and list only
    the IP addresses of computers for which you specifically want to deny
    connections. Stop and start the SMTP virtual server, check if the issue
    still occurs.


    Step 2: Reinstall fax components

    The detailed steps to completely reinstall FAX component is listed below

    1. Rename the keys and files below to *.old

    1) HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fax

    2) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Fax

    3) C:\Program Files\Microsoft Windows Small Business Server\fax

    4) The ''SBSMIS-FAX.log'' file under ''C:\Program Files\Microsoft
    Integration\Windows Small Business Server 2003\Logs''.

    5) The ''SBSMSI-faxcfg.log'' file under ''C:\Program Files\Microsoft
    Integration\Windows Small Business Server 2003\Logs''.

    6) The ''faxsetup.log'' file under ''C:\WINDOWS\''.


    2. Access Add/Remove Programs, Add/Remove Windows Components, uncheck ''Fax
    Services'' to uninstall it.

    3. Once it is uninstalled, access Add/Remove Programs to reinstall it.

    4. Then, access ''Add/Remove Programs again'', this time, we will click
    ''Change/Remove'' on the ''Windows Small Business Server 2003'' item:

    1) Click ''Next'' on the ''Microsoft Windows Small Business Server Setup''
    page.

    2) Click ''Next'' on the ''Windows Configuration'' page.

    Note: It states that ''This will take approximately 30 minutes'', it is
    referring to the total time it will take in the first SBS component
    installation. For the task such as remove a specific component, it will
    just take couple of minutes.

    3) Now, in the ''Component Selection'' page, choose ''Remove'' before the
    ''Fax Services'' item.

    4) Click ''Next'', and then click ''Next'' again to confirm ''Component
    Summary''. You will be prompted to insert the SBS 2K3 setup Disc 1.


    5. Once the removal process is completed, access ''Windows Small Business
    Server setup'' again in ''Add/Remove Programs'', proceed to the ''Component
    Selection'' page, and then choose ''Install'' for the ''Fax Services'' item.


    Hope this helps, if you have any other concerns on this issue, please feel
    free to let me know.


    Best Regards,

    Chace Zhang (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.

    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.


    --------------------
    | Thread-Topic: Email Rules Forwarding and Fax Forwarding Not Working
    | thread-index: Acbcn09SOrfgfZafQaOBXtjGVvYRbQ==
    | X-WBNR-Posting-Host: 66.156.93.167
    | From: =?Utf-8?B?VG9tIFNjaHdhcnR6?= <>
    | References: <>
    <>
    <>
    <>
    | Subject: RE: Email Rules Forwarding and Fax Forwarding Not Working
    | Date: Wed, 20 Sep 2006 03:27:01 -0700
    | Lines: 312
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGXA01.phx.gbl
    | Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.server.sbs:298844
    | NNTP-Posting-Host: TK2MSFTNGXA01.phx.gbl 10.40.2.250
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | using the net stop spooler command (stops the print spooler) executes
    fine
    | however it does nothing to keep the non-working dll from reappearing and
    | overwriting the version I am trying to copy into place. The only other
    | copies of the non-working (43K) version of the DLL were in the Trash Can
    and
    | I deleted those.
    |
    | Next step?
    |
    | Tom
    |
    | "chace zhang" wrote:
    |
    | > Hi Tom,
    | >
    | > Thanks for your update.
    | >
    | > Based on my deep research, we can use the following steps to try to
    | > Re-register fxsroute.dll:
    | >
    | > A. Run "cmd" (without the quotation marks) on the command prompt on
    the
    | > SBS Server, and then input: net stop spooler
    | >
    | > B. Regsvr32 /u /s fxsroute.dll
    | >
    | > C. Regsvr32 /s fxsroute.dll
    | >
    | > D. net start spooler
    | >
    | > Please search fxsroute.dll on your SBS Server, are there any other
    files?
    | > You can delete them, I suggest you keep a copy of this file. After that
    | > register it again.
    | >
    | > If the issue persists, please open the properties page of Fax container
    in
    | > the Server Management and go to "receipts tab",
    | >
    | > 1. Please confirm that "Enable Message Boxes as receipts" is checked
    | >
    | > 2. Please confirm "Enable SMTP Receipts e-mail receipts delivery" is
    checked
    | >
    | > 3. "From e-mail address" box should be listed as
    | > . If it is
    | > , please modify it.
    | >
    | > 4. Click the Authentication, the authentication method should be
    | > ''Anonymous access''. If it is set to '' Integrated Windows'', please
    | > modify it.
    | >
    | > After above settings, please restart the Fax service in the service
    console
    | > (services.msc) and test your issue again.
    | >
    | > Open Exchange System Manager, expand Servers\your
    server\Protocols\SMTP,
    | > right-click Default SMTP Virtual Server and click Properties. On the
    Access
    | > tab, click the Connection button under "Connection control". If it is
    set
    | > to "Only the list below", select "All except the list below" and list
    only
    | > the IP addresses of computers for which you specifically want to deny
    | > connections. Stop and start the SMTP virtual server, check if the issue
    | > still occurs.
    | >
    | > Hope this helps, if you have any other concerns on this issue, please
    feel
    | > free to let me know.
    | > Have a nice day!
    | >
    | > Best Regards,
    | >
    | > Chace Zhang (MSFT)
    | >
    | > Microsoft CSS Online Newsgroup Support
    | >
    | > Get Secure! - www.microsoft.com/security
    | >
    | > =====================================================
    | > This newsgroup only focuses on SBS technical issues. If you have issues
    | > regarding other Microsoft products, you'd better post in the
    corresponding
    | > newsgroups so that they can be resolved in an efficient and timely
    manner.
    | > You can locate the newsgroup here:
    | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | >
    | > When opening a new thread via the web interface, we recommend you check
    the
    | > "Notify me of replies" box to receive e-mail notifications when there
    are
    | > any updates in your thread. When responding to posts via your
    newsreader,
    | > please "Reply to Group" so that others may learn and benefit from your
    | > issue.
    | >
    | > Microsoft engineers can only focus on one issue per thread. Although we
    | > provide other information for your reference, we recommend you post
    | > different incidents in different threads to keep the thread clean. In
    doing
    | > so, it will ensure your issues are resolved in a timely manner.
    | >
    | > For urgent issues, you may want to contact Microsoft CSS directly.
    Please
    | > check http://support.microsoft.com for regional support phone numbers.
    | >
    | > Any input or comments in this thread are highly appreciated.
    | >
    | > =====================================================
    | >
    | > This posting is provided "AS IS" with no warranties, and confers no
    rights.
    | >
    | > --------------------
    | > | Thread-Topic: Email Rules Forwarding and Fax Forwarding Not Working
    | > | thread-index: AcbcV8kHALzE7VkSQDKZ68vLhDFXtg==
    | > | X-WBNR-Posting-Host: 66.156.93.167
    | > | From: =?Utf-8?B?VG9tIFNjaHdhcnR6?=
    <>
    | > | References: <>
    | > <>
    | > | Subject: RE: Email Rules Forwarding and Fax Forwarding Not Working
    | > | Date: Tue, 19 Sep 2006 18:55:01 -0700
    | > | Lines: 221
    | > | Message-ID: <>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain;
    | > | charset="Utf-8"
    | > | Content-Transfer-Encoding: 7bit
    | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | Content-Class: urn:content-classes:message
    | > | Importance: normal
    | > | Priority: normal
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | > | Newsgroups: microsoft.public.windows.server.sbs
    | > | Path: TK2MSFTNGXA01.phx.gbl
    | > | Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.server.sbs:298773
    | > | NNTP-Posting-Host: TK2MSFTNGXA01.phx.gbl 10.40.2.250
    | > | X-Tomcat-NG: microsoft.public.windows.server.sbs
    | > |
    | > | Halfway there. Email is working fine after enabling it! :_0
    | > |
    | > | Fax still not working but I am having trouble executing step 3E.
    | > |
    | > | Clearly the installed FXSROUTE.DLL (Version 5/12/2005 5.2.3790.1830)
    is
    | > | different than the one off the Install CDROM (Version 8/18/2001
    | > 5.2.1776.0).
    | > | However, when I execute the regsvr32 /u fxsroute.dll command I get
    the
    | > | following error message.
    | > |
    | > | "fxsroute.dll was loaded, but the dllunregisterserver entry point was
    not
    | > | found. This file can not be registered"
    | > |
    | > | Also, whenever I copy the CDROM version (older file) over the
    installed
    | > | (newer )version, the system undoes my replacement about 5 seconds
    after
    | > the
    | > | replacement completes, return the fxsroute.dll file in the
    | > | c:\windows\system32 directory back to the 5/12/2005 version.
    | > |
    | > | Thanks for your help
    | > |
    | > | Tom
    | > |
    | > | "chace zhang" wrote:
    | > |
    | > | > Hi,
    | > | >
    | > | > Thank you for posting here.
    | > | >
    | > | > In Exchange 2003, "Allow automatic forward" is disabled by default.
    | > | > Therefore, Auto Forward Rule created in Outlook client side to
    forward
    | > mail
    | > | > will not work. To resolve this issue, enable "Allow automatic
    forward"
    | > by
    | > | > following the step below:
    | > | >
    | > | > 1. On the SBS server, start Exchange System Manager.
    | > | >
    | > | > 2. Double-click Global Settings, and then click Internet Message
    | > Formats.
    | > | >
    | > | > 3. In the right pane, double-click the "Default" item.
    | > | >
    | > | > 4. In the Properties dialog box, click the Advanced tab, and then
    click
    | > to
    | > | > select the "Allow automatic forward" option.
    | > | >
    | > | > Reference:
    | > | >
    | > | > 266166 Automatic replies and automatic forwards to Internet
    recipients
    | > are
    | > | > disabled in Exchange 2000 Server and in Exchange Server 2003
    | > | > http://support.microsoft.com/?id=266166
    | > | >
    | > | > If the information above doesn't help, please check the following:
    | > | >
    | > | > 1. Does the issue occur to all users?
    | > | >
    | > | > 2. Log on to another workstation as the "problematic" user, create
    an
    | > | > Outlook profile and see if you can reproduce the problem.
    | > | >
    | > | > 3. Download MDBVU32 at:
    | > | >
    | > | > Exchange Server Information Store Viewer (MDBVU32)
    | > | >
    | >
    http://www.microsoft.com/downloads/details.aspx?familyid=3d1c7482-4c6e-4ec5-
    | > | > 983e-127100d71376&displaylang=en
    | > | >
    | > | > And delete rules by following the KB artcle below:
    | > | >
    | > | > 320022 XCLN: How to Use the Mdbvu32 Utility to Remove Inbox Rules
    | > | > http://support.microsoft.com/?id=320022
    | > | >
    | > | > And then re-create the rule, does it help?
    | > | >
    | > | > Additional information that may help:
    | > | >
    | > | > 281926 How to Configure a Mailbox to Forward Mail to a Mail-Enabled
    | > Contact
    | > | > http://support.microsoft.com/?id=281926
    | > | >
    | > | > 317652 How to Override Blocked Auto-Forwarding for Select Users
    | > | > http://support.microsoft.com/?id=317652
    | > | >
    | > | >
    | > | > Regarding inbound fax can not route to mailbox issue,
    | > | >
    | > | > I. Based on my research, to resolve this issue, please run the
    | > following
    | > | > command-line to register these files:
    | > | >
    | > | > regsvr32 "C:\PROGRAM FILES\COMMON FILES\MICROSFT
    SHARED\CDO\cdoex.dll"
    | > | > regsvr32 "C:\PROGRAM FILES\EXCHSRVR\BIN\cdo.dll"
    | > | >
    | > | > Then try again to check if the issue can be reproduced.
    | > | >
    | > | > II. If the issue still persists, please use the following steps
    to
    | > | > confirm the Fax service has been configured correctly.
    | > | >
    | > | > 1) Open Server Management
    | > | > 2) Right-click on Fax (Local) container
    | > | > 3) Select "Properties"
    | > | > 4) Select "Receipts" tab
    | > | >
    | > | > Message Box - check the option "Enable Message Boxes as receipts"
    | > | > SMTP E-mail
    | > | > "Enable SMTP Receipts e-mail receipts delivery" is enabled
    | > | > "From e-mail address" should be listed as
    | > | >
    | > | > Authentication - should be Anonymous access
    | > | > Check the option in "Use these SMTP Settings for the Route
    through
    | > | > E-mail incoming routing method"
    | > | >
    | > | > Restarted the Shared Fax Service if any changes.
    | > | >
    | > | > 2. Verify the Exchange Server Virtual SMTP Server is configured to
    | > listen
    | > | > on 'all unassigned'.
    | > | >
    | > | > 3. please refer to the below steps to Re-register fxsroute.dll
    | > (regsvr32
    | > | > fxsroute.dll):
    | > | >
    | > | > A. Locate the fxsroute.dll from the CD3\SBS\CLIENTAPPS\FAXCLIENT
    | > folder.
    | > | >
    | > | > B. Copy this file to the %systemroot%\system32 folder on the SBS
    | > Server.
    | > | >
    | > | > C. Click Start, click Run, type cmd in the Open box, and then
    click
    | > OK.
    | > | >
    | > | > D. At the MS-DOS prompt, type cd c:\windows\system32, and then
    press
    | > | > ENTER.
    | > | >
    | > | > E. At the next prompt, type regsvr32 /u fxsroute.dll, and then
    press
    | > | > ENTER.
    | > | >
    | > | > F. After you receive the following message, type exit at the
    prompt,
    | > and
    | > | > then press ENTER:
    | > | >
    | > | > Dll register server in fxsroute.dll succeeded.
    | > | >
    | > | > G. Restart your computer.
    | > | >
    | > | > 4. Open Exchange System Manager, expand Servers\your
    | > | > server\Protocols\SMTP, right-click Default SMTP Virtual Server and
    | > click
    | > | > Properties. On the Access tab, click the Connection button under
    | > | > "Connection control". If it is set to "Only the list below", select
    | > "All
    | > | > except the list below" and list only the IP addresses of computers
    for
    | > | > which you specifically want to deny connections. Stop and start the
    | > SMTP
    | > | > virtual server, check if the issue still occurs.
    | > | >
    | > | > Hope this helps, if you have any other concerns on this issue,
    please
    | > feel
    | > | > free to let me know. I'm looking forward to your update.
    | > | >
    | > | >
    | > | > Have a nice day
    | > | >
    | > | >
    | > | > Best Regards,
    | > | >
    | > | > Chace Zhang (MSFT)
    | > | >
    | > | > Microsoft CSS Online Newsgroup Support
    | > | >
    | > | > Get Secure! - www.microsoft.com/security
    | > | >
    | > | > =====================================================
    | > | > This newsgroup only focuses on SBS technical issues. If you have
    issues
    | > | > regarding other Microsoft products, you'd better post in the
    | > corresponding
    | > | > newsgroups so that they can be resolved in an efficient and timely
    | > manner.
    | > | > You can locate the newsgroup here:
    | > | > http://www.microsoft.com/communities/newsgroups/en-us/default.aspx
    | > | >
    | > | > When opening a new thread via the web interface, we recommend you
    check
    | > the
    | > | > "Notify me of replies" box to receive e-mail notifications when
    there
    | > are
    | > | > any updates in your thread. When responding to posts via your
    | > newsreader,
    | > | > please "Reply to Group" so that others may learn and benefit from
    your
    |
     
    chace zhang, Sep 21, 2006
    #7
  8. Tom Schwartz

    Tom Schwartz Guest

    Followed your procedure to:

    "Select all unassigned " Stop and start the SMTP virtual server, check if
    the issue
    still occurs.

    PROBLEM SOLVED. Thanks for the help
     
    Tom Schwartz, Sep 21, 2006
    #8
  9. Tom Schwartz

    chace zhang Guest

    Hi,

    Thanks for your update.
    I'm glad to hear this issue was resolved,currently I'm going to archive
    this post. If you have additional technical questions, please do not
    hesitate to post in this forum. I look forward to working with you again.

    Best Regards,

    Chace Zhang (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.

    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
    | Thread-Topic: Email Rules Forwarding and Fax Forwarding Not Working
    | thread-index: Acbdgr4ZrzXRPGk+QYeMFU2gdqAWrw==
    | X-WBNR-Posting-Host: 66.156.93.167
    | From: =?Utf-8?B?VG9tIFNjaHdhcnR6?= <>
    | References: <>
    | Subject: RE: Email Rules Forwarding and Fax Forwarding Not Working
    | Date: Thu, 21 Sep 2006 06:35:03 -0700
    | Lines: 20
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
    | Newsgroups: microsoft.public.windows.server.sbs
    | Path: TK2MSFTNGXA01.phx.gbl
    | Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.windows.server.sbs:299176
    | NNTP-Posting-Host: TK2MSFTNGXA01.phx.gbl 10.40.2.250
    | X-Tomcat-NG: microsoft.public.windows.server.sbs
    |
    | Followed your procedure to:
    |
    | "Select all unassigned " Stop and start the SMTP virtual server, check
    if
    | the issue
    | still occurs.
    |
    | PROBLEM SOLVED. Thanks for the help
    |
    | "Tom Schwartz" wrote:
    |
    | > I have never been able to get Outlook Rules to forward email correctly
    to
    | > another mailbox or deliver new email to an external address for a
    receipent.
    | > Additionlly the built in Inbound Fax Forwarding Wizard will not
    correctly
    | > Route a new fax to an email address. What can I check to make sure
    this is
    | > installed correctly?
    | >
    | > I have used the Fax Wizard and it seems to do the setup fine, delivers
    a
    | > copy of the fax to everything except an email receipient.
    | >
    | > Thanks in Advance
    |
     
    chace zhang, Sep 22, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.