Enable Journal Wrap Automatic Restore

Discussion in 'File Systems' started by David, Jun 24, 2005.

  1. David

    David Guest

    I'm trying to enable Enable Journal Wrap Automatic Restore. I go to the
    registry and chnage the value to 1 and nothing happens after 5 minutes. I
    even have tried restarting the ntfrs service. I keep getting this error in
    the FRS log...

    The File Replication Service has detected that the replica set "DOMAIN
    SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.

    Replica set name is : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"
    Replica root path is : "c:\winnt\sysvol\domain"
    Replica root volume is : "\\.\C:"
    A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to
    read from the NTFS USN journal is not found. This can occur because of one
    of the following reasons.

    [1] Volume "\\.\C:" has been formatted.
    [2] The NTFS USN journal on volume "\\.\C:" has been deleted.
    [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can
    truncate the journal if it finds corrupt entries at the end of the journal.
    [4] File Replication Service was not running on this computer for a long
    time.
    [5] File Replication Service could not keep up with the rate of Disk IO
    activity on "\\.\C:".
    Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1
    will cause the following recovery steps to be taken to automatically recover
    from this error state.
    [1] At the first poll, which will occur in 5 minutes, this computer will be
    deleted from the replica set. If you do not want to wait 5 minutes, then run
    "net stop ntfrs" followed by "net start ntfrs" to restart the File
    Replication Service.
    [2] At the poll following the deletion this computer will be re-added to
    the replica set. The re-addition will trigger a full tree sync for the
    replica set.

    WARNING: During the recovery process data in the replica tree may be
    unavailable. You should reset the registry parameter described above to 0 to
    prevent automatic recovery from making the data unexpectedly unavailable if
    this error condition occurs again.

    To change this registry parameter, run regedit.

    Click on Start, Run and type regedit.

    Expand HKEY_LOCAL_MACHINE.
    Click down the key path:
    "System\CurrentControlSet\Services\NtFrs\Parameters"
    Double click on the value name
    "Enable Journal Wrap Automatic Restore"
    and update the value.

    If the value name is not present you may add it with the New->DWORD Value
    function under the Edit Menu item. Type the value name exactly as shown
    above.
     
    David, Jun 24, 2005
    #1
    1. Advertisements

  2. Why do you want to enable Journal Wrap Automatic restore?

    The preferred way is to use the Burflags registry key nowadays:

    HKLM\ SYSTEM\ CurrentControlSet\ Services\ NtFrs\ Parameters\
    Backup/Restore\ Process at Startup
    BurFlags

    You should stop NtFrs, set Burflags to D2 and start NtFrs
     
    Paul Williams [MVP], Jun 25, 2005
    #2
    1. Advertisements

  3. David

    David Guest

    I had to enable it (secondary domain controler) because it wasn't
    replicating with the primary domain controler. After setting it to 1, and
    letting it sit for a while it removed itself from replication, then began to
    replicate now. I then set it back to 0 and all is well now.
     
    David, Jun 27, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.