Environment of Generic Service Resources in a W2K-Cluster

Discussion in 'Clustering' started by Michael Noeth, Apr 13, 2005.

  1. Hi,
    On a customers W2K-cluster we have a generic service which is running
    under a domain user's account "cluster_2". For this user a special
    environment is set, containing different pathes necessary for the
    service to work. Starting the service in the Service Manager Console, it
    receives the environment specified for the user "cluster_2" and is
    working ok.

    On the cluster nodes, the cluster service is running under the account
    "cluster_svc". Now when we integrate this resource into the cluster as
    generic service and start it in the cluster administrator, it fails to
    run because the service receives the environment of the later user
    "cluster_svc" and not the one of "cluster_2" assigned in "Services".
    After that the registry key
    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<MyServiceExample>"
    receives an additional value "Environment" which contains the
    environment data of the "cluster_svc"-user. Up to now I never saw that
    the service resources in a cluster inherit the environment of the
    account of clusterservice. Can anyone give a hint ?

    Thanks,
    Michael
     
    Michael Noeth, Apr 13, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.