Err Message: Registry Editing has been disabled by your administra

Discussion in 'Windows Vista File Management' started by Danny, Feb 27, 2007.

  1. Danny

    Danny Guest

    First off, I am the admin on my PC, it is not networked, and I am running
    Vista Home Premium. I have tried right clicking both reg editing apps to
    change permission, but all permission options are grayed out. I also had
    this problem with task manager (which I was able to fix).

    I did have an infection which has been cleaned (and my sister is now banned
    from my computer) but all fixes I have found online have yielded no success.
    I am still locked out of regedit.exe.

    What methods can I use to reenable it?

    Thanks in advance!
     
    Danny, Feb 27, 2007
    #1
    1. Advertisements

  2. What happens if you right click the regedit.exe file and select the Run as
    Administrator option?
     
    Ronnie Vernon MVP, Mar 1, 2007
    #2
    1. Advertisements

  3. Danny

    Danny Guest

    Same error message.

     
    Danny, Mar 1, 2007
    #3
  4. Try creating a new account with Administrator permissions. Log in to that
    account. Try to run regedit from there. If you can, keep going, otherwise
    post back.

    In regedit, click HKEY_USERS in the left-hand pane to hi-lite it, then, in
    the menu bar, click 'File' -> 'Load Hive'. Navigate to the userprofile
    folder for your problem account & select the NTUSER.DAT file. When
    prompted to name the hive, use any text you want, 'Temp' is fine.

    In your newly added hive, navigate to:

    HKEY_USERS\Temp\Software\Microsoft\Windows\CurrentVersion\Policies\System

    In the right-hand pane, delete the value named: DisableRegistryTools

    In the left-hand pane, hi-lite the 'Temp' key. Now click click 'File' ->
    'Unload Hive'. Close regedit, log off & log back in under your normal
    account, You should be able to run 'regedit' now.
     
    Keith Miller MVP, Mar 2, 2007
    #4
  5. Hi Danny,

    Here is another way to fix the problem.

    Download regedit_enable.vbs from my site below:
    http://www.winhelponline.com/fixes/regedit_enable.vbs

    Save the file to Desktop. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

    In the Command Prompt window, do the following:

    Type "cd /d %userprofile%\desktop" and press ENTER
    Type "wscript.exe regedit_enable.vbs" and press ENTER

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    First off, I am the admin on my PC, it is not networked, and I am running
    Vista Home Premium. I have tried right clicking both reg editing apps to
    change permission, but all permission options are grayed out. I also had
    this problem with task manager (which I was able to fix).

    I did have an infection which has been cleaned (and my sister is now banned
    from my computer) but all fixes I have found online have yielded no success.
    I am still locked out of regedit.exe.

    What methods can I use to reenable it?

    Thanks in advance!
     
    Ramesh, MS-MVP, Mar 2, 2007
    #5
  6. Danny

    Danny Guest

    Fixed, I am back to messing things up royally!

    Thanks for all of the helpful replies!
     
    Danny, Mar 2, 2007
    #6
  7. You're welcome!

    --
    Regards,

    Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
    Windows® Troubleshooting http://www.winhelponline.com


    Fixed, I am back to messing things up royally!

    Thanks for all of the helpful replies!
     
    Ramesh, MS-MVP, Mar 3, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.