Error: 0x80070424

Discussion in 'Windows Update' started by kbabe, Aug 10, 2004.

  1. kbabe

    kbabe Guest

    i am trying to run the windows update, however whenever i try and download
    them i get an error message saying that the page can not be displayed and in
    the upper right corner it says "error: 0x80070424". does anyone know how to
    solve this problem?
     
    kbabe, Aug 10, 2004
    #1
    1. Advertisements

  2. Hi

    Install this one ans see if it helps:

    Update for Background Intelligent Transfer Service (BITS) 2.0
    and WinHTTP 5.1 (KB842773)
    http://www.microsoft.com/downloads/...5c-41f2-4c58-aeac-783919ccfacf&DisplayLang=en
     
    Torgeir Bakken \(MVP\), Aug 10, 2004
    #2
    1. Advertisements

  3. kbabe

    kbabe Guest

    I tried to install the the suggested file, but it told me that the service
    pack but it said: 'the service pack version of this system is newer than the
    update you are applying. there is no need to install this update.'

    I currently have sp2 on my system. any other ideas as to how i might be able
    to get my updates working. nothing on the updates page will work, such as the
    installation history or the updates. any help would be appreciated.
     
    kbabe, Aug 11, 2004
    #3
  4. Hi

    OK, error 0x80070424 indicates that the BITS service does not
    exist (or is messed up).

    This command line should reinstall the BITS service, run it e.g.
    from Start/Run (line will wrap in the newsreader!):

    %SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall
    132 %SystemRoot%\inf\qmgr.inf


    If it asks for your OS/SP CD-ROM to get some files, just point it to the
    folder C:\Windows\System32 (or wherever WinXP is installed to)


    If it still doesn't work, reinstall the AutoUpdate service as well:

    This command line should reinstall the AutoUpdate service, run it e.g.
    from Start/Run (line will wrap in the newsreader!):

    %SystemRoot%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall
    132 %SystemRoot%\inf\au.inf


    Please post any result back here, good or bad :)
     
    Torgeir Bakken \(MVP\), Aug 11, 2004
    #4
  5. Hi

    Check if the "Automatic Updates" and the BITS service are enabled
    and are possible to start.

    Start/Run --> services.msc

    Then find "Automatic Updates" in the list, and double click on it.

    Change Startup type Automatic if it is not, and press Apply.

    If the service status is "Stopped", press the Start button.


    Do the same for the service "Background Intelligent Transfer Service".
     
    Torgeir Bakken \(MVP\), Aug 13, 2004
    #5
  6. kbabe

    Colleen Guest

    Hi, I am having the same problem.

    When I check the services, Automatic updates was there, but it was disabled
    and wouldn't allow me to re-enable it. When I rebooted the service is now
    deleted. How do I get it back?
     
    Colleen, Aug 20, 2004
    #6
  7. kbabe

    ETreder Guest

    Having same problem; have downloaded and installed BITS service and confirmed
    that is enabled and started; Automatic Updates are turned on in Control
    Panel, but do not show up in Services. Tried running command lines that you
    suggested, but got "installation error" messages. HELP !!!
     
    ETreder, Aug 21, 2004
    #7
  8. kbabe

    ETreder Guest

    That worked; problem solved; thanks for the help.
     
    ETreder, Aug 26, 2004
    #8
  9. Hi

    And from an recent post by Mark Brown [MSFT], you could try this:


    Action:
    ==========================
    Accessing Windows Updates Site

    Result:
    ==========================
    0x80070424

    Cause:
    ==========================
    Certain required DLL files unregistered

    Resolution:
    ==========================
    Action Plan
    **********
    1. open "wordpad"
    2. copy this text (below) into the "wordpad"
    3. save the "wordpad" file as "IEreg.bat" to your desktop and then "double
    click" to launch
    ******************************

    cd /d %SystemRoot%\system32
    regsvr32 comcat.dll /s
    regsvr32 shdoc401.dll /s
    regsvr32 shdoc401.dll /i /s
    regsvr32 asctrls.ocx /s
    regsvr32 oleaut32.dll /s
    regsvr32 shdocvw.dll /I /s
    regsvr32 shdocvw.dll /s
    regsvr32 browseui.dll /s
    regsvr32 browseui.dll /I /s
    regsvr32 msrating.dll /s
    regsvr32 mlang.dll /s
    regsvr32 hlink.dll /s
    regsvr32 mshtmled.dll /s
    regsvr32 urlmon.dll /s
    regsvr32 plugin.ocx /s
    regsvr32 sendmail.dll /s
    regsvr32 scrobj.dll /s
    regsvr32 mmefxe.ocx /s
    regsvr32 corpol.dll /s
    regsvr32 jscript.dll /s
    regsvr32 msxml.dll /s
    regsvr32 imgutil.dll /s
    regsvr32 thumbvw.dll /s
    regsvr32 cryptext.dll /s
    regsvr32 rsabase.dll /s
    regsvr32 inseng.dll /s
    regsvr32 iesetup.dll /i /s
    regsvr32 cryptdlg.dll /s
    regsvr32 actxprxy.dll /s
    regsvr32 dispex.dll /s
    regsvr32 occache.dll /s
    regsvr32 occache.dll /i /s
    regsvr32 iepeers.dll /s
    regsvr32 urlmon.dll /i /s
    regsvr32 cdfview.dll /s
    regsvr32 webcheck.dll /s
    regsvr32 mobsync.dll /s
    regsvr32 pngfilt.dll /s
    regsvr32 licmgr10.dll /s
    regsvr32 icmfilter.dll /s
    regsvr32 hhctrl.ocx /s
    regsvr32 inetcfg.dll /s
    regsvr32 tdc.ocx /s
    regsvr32 MSR2C.DLL /s
    regsvr32 msident.dll /s
    regsvr32 msieftp.dll /s
    regsvr32 xmsconf.ocx /s
    regsvr32 ils.dll /s
    regsvr32 msoeacct.dll /s
    regsvr32 inetcomm.dll /s
    regsvr32 msdxm.ocx /s
    regsvr32 dxmasf.dll /s
    regsvr32 l3codecx.ax /s
    regsvr32 acelpdec.ax /s
    regsvr32 mpg4ds32.ax /s
    regsvr32 voxmsdec.ax /s
    regsvr32 danim.dll /s
    regsvr32 Daxctle.ocx /s
    regsvr32 lmrt.dll /s
    regsvr32 datime.dll /s
    regsvr32 dxtrans.dll /s
    regsvr32 dxtmsft.dll /s
    regsvr32 WEBPOST.DLL /s
    regsvr32 WPWIZDLL.DLL /s
    regsvr32 POSTWPP.DLL /s
    regsvr32 CRSWPP.DLL /s
    regsvr32 FTPWPP.DLL /s
    regsvr32 FPWPP.DLL /s
    regsvr32 WUAPI.DLL /s
    regsvr32 WUAUENG.DLL /s
    regsvr32 ATL.DLL /s
    regsvr32 WUCLTUI.DLL /s
    regsvr32 WUPS.DLL /s
    regsvr32 WUWEB.DLL /s
    regsvr32 wshom.ocx /s
    regsvr32 wshext.dll /s
    regsvr32 vbscript.dll /s
    regsvr32 scrrun.dll mstinit.exe /setup /s
    regsvr32 msnsspc.dll /SspcCreateSspiReg /s
    regsvr32 msapsspc.dll /SspcCreateSspiReg /s
    exit

    ******************************
     
    Torgeir Bakken \(MVP\), Sep 14, 2004
    #9
  10.  
    mightymaneugene, Sep 15, 2004
    #10
  11. ....

    Torgeir,

    Have you tried this, e.g. without the /s switches?
    I tried to point out these last three entries previously,
    being curious and dubious about the syntax.
    Do you understand what is being attempted with that syntax?
    My guess would be that the /s switch would be just obscuring
    any errors and none of those modules would be reinitialized at all.

    E.g. I could understand this syntax for the last ones:

    regsvr32 /n /i:SspcCreateSspiReg msnsspc.dll /s
    regsvr32 /n /i:SspcCreateSspiReg msapsspc.dll /s

    but I haven't a clue what would be intended by the first.
    My best guess would be that it should be two commands
    both of which are corrupted by being mixed in one line.
    E.g. a normal re-initialization of scrrun.dll and a line
    which is given in KB279830 and is some obscure maintenance
    tool for a one-time conversion of "jobs" started by the Task Scheduler?


    ;o

    Robert
    ---
     
    Robert Aldwinckle, Sep 15, 2004
    #11
  12. did ALL that..............still no good...help

     
    Olivia Higgins, Oct 20, 2004
    #12
  13. BRILLIANT - WORKED LIKE A CHARM!!!!! I WISHED I HAD FOUND THIS MESSAGE A
    COUPLE OF WEEKS AGO. YOU Know your stuff!!!!
     
    coachmichelle, Dec 3, 2004
    #13
  14. i had this error back in october and discovered that it was part of a virus
    of the BOXED family. i downloaded the free anti-virus software called Antivir
    Guard. the updated version of this program did the trick for me. look up the
    virus and you'll understand what it does. therfore you'll be better able to
    deal with it.
     
    Olivia Higgins, Dec 6, 2004
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.