error 0x80072EE7 and no solution from support center working

Discussion in 'Windows Update' started by techf1080, Aug 1, 2006.

  1. techf1080

    techf1080 Guest

    Hi there, I have all my computer on my network, bell sympatico high speed, I
    use a router linksys wrt54g, it started yesterday evening, I get this error
    on all my computer that im trying to update( im in a store, customer a paying
    for the update and setup ). I tried to register all services regsvr32
    jscript.dll
    regsvr32 wuapi.dll
    regsvr32 wuaueng.dll
    regsvr32 wuaueng1.dll
    regsvr32 wucltui.dll
    regsvr32 wups.dll -------- this one wont register on all computer
    regsvr32 wups2.dll
    regsvr32 wuweb.dll


    I tried all the operations
    You may receive an "Error 0x80072EE2," "Error 0x80072EE7," "Error
    0x80072EFD," "Error 0x80072F76," or "Error 0x80072F78" error message when
    you try to use the Windows Update Web site or the Microsoft Update Web site
    http://support.microsoft.com/?kbid=836941


    When searching for available updates on the Update site, you see the
    0x80072EE7 error
    http://update.microsoft.com/windowsupdate/v6/showarticle.aspx?articleid=22&ln=en&IsMu=False

    You may receive an error message when you search for available updates on
    the Windows Update Web site or on the Microsoft Update Web site
    http://support.microsoft.com/?kbid=883821


    I need HELP PLZZZZZZZz im lost and dont know what else to do or try

    Thank you for your help everyone
     
    techf1080, Aug 1, 2006
    #1
    1. Advertisements

  2. techf1080

    ECSTech Guest

    Me too! I have (4) computers on Bellsouth DSL with Linksys RV082 Router. (3)
    of the computers stopped being able to: 1) Log into some https:// sites like
    EBay, and 2) Perform Windows Update.

    This started about (2) weeks ago and I've been racking my brains and
    internet searches to fix it. I have also talked to other people with the same
    problems.

    Nothing works!!!
     
    ECSTech, Aug 1, 2006
    #2
    1. Advertisements

  3. With a DSL connection, you should adjust the properties of the Windows
    network connection that connects to your router (whether it be ethernet or
    wireless) so that the Max MTU setting in Windows is no greater than 1492,
    rather than the default 1500.

    You can do this with DrTCP from http://www.broadbandreports.com/drtcp

    Make sure you select the correct Adapter in the drop-down before setting the
    MaxMTU.

    Do this for all your PCs connected via DSL, whether through the router or
    not.

    If the above does not fix your https problem, you might need to mend
    Windows's Cryptographic services. Download Dial-a-fix from
    http://wiki.djlizard.net/Dial-a-fix_beta and use its option to repair Crypto
    services. Then restart Windows.
     
    Robin Walker [MVP], Aug 1, 2006
    #3
  4. This router has firewall options to block ActiveX and so on. Make sure the
    internal firewall feature is disabled.
    Check that the PCs are not subject to any web proxying, either in
    themselves, or in the store, or by the ISP.
     
    Robin Walker [MVP], Aug 1, 2006
    #4
  5. HI, I too had a Linksys Router same model, i reset my MTU settings to
    1400..For me that fixed it.
     
    Florida Gal :), Aug 2, 2006
    #5
  6. techf1080

    ECSTech Guest

    Robin,

    What a lifesaver you are!. the "You can do this with DrTCP from
    http://www.broadbandreports.com/drtcp" worked just fine setting the MTU to
    1492.

    That's so strange. Why is MTU set by default to 1500 if it doesn't work?

    Thanks again.
     
    ECSTech, Aug 2, 2006
    #6
  7. A complete explanation would fill a university lecture. But ...

    1500 bytes max data per packet is the default for ethernet connections, and
    as far as your Windows is concerned it is talking to an ethernet, whether a
    wired one, or a wireless link pretending to be an ethernet. 1500 would work
    just fine within your LAN, not touching the DSL link.

    But data packets on the DSL link between your router and your ISP are
    encapsulated in another protocol which steals 8 bytes from each available
    packet, leaving only 1492 for your data. Had your Windows PC been connected
    directly to a plain DSL modem (rather than a DSL modem + router), then
    Windows would do the encapsulation itself (as part of the DSL pseudo
    dial-up), and would know about only having 1492 bytes per packet, and behave
    accordingly.

    But your Windows is connected to a router, and the encapsulation is being
    done inside the router, so Windows has no way of knowing about it, and it
    assumes the default 1500 for ethernet. The effect of sending a too-long
    packet is either (a) that your router drops the packet on the floor and
    normally sends back an ICMP packet warning the sender that at least one
    packet was too long, or (b) the router arbitrarily splits the packet into
    two (which causes poor performance over DSL). Windows has a recovery
    mechanism and is supposed to back off and retry with smaller packet sizes
    (MTU), until they start working. Various things can go wrong with this.
    Some users have ultra-paranoid firewall settings, and thus block the
    returning ICMP packet that was meant to help Windows reduce the MTU
    promptly. If the transmission was encrypted (https), then the MTU discovery
    by Windows is likely to have generated so many retries that the stream
    cannot be unencrypted successfully, or the arbitrary splitting of packets
    into two can invalidate the security checks.

    Most of the time, Windows can auto-discover the MaxMTU and recover (though
    maybe with a considerable performance penalty). Sometimes, the MTU
    discovery algorithms fail, as in your case. So telling Windows in advance
    only to use 1492 bytes per packet means that everything works first time,
    the DSL link is used at maximum efficiency, and there is no performance
    penalty associated with splitting packets into two.

    If that sounded confusing, it's because I am trying to summarise something
    complicated too much for easy reading.

    Cable users need not worry about this: cable normally uses MaxMTU 1500.
     
    Robin Walker [MVP], Aug 2, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.