Error 1083 on starting either Windows update or BITS in Win XP SP2

Discussion in 'Windows Update' started by Brett Davidson, Jan 11, 2006.

  1. net start wuauserv

    System error 1083 has occurred.

    The executable program that this service is configured to run in does not
    implem
    ent the service.

    Get same error for BITS.

    Contents of windowsupdate.log are below...

    2006-01-11 23:20:18 2704 a94 Misc =========== Logging initialized (build:
    5.8.0.2469, tz: +1300) ===========
    2006-01-11 23:20:18 2704 a94 Misc = Process: C:\Program Files\Internet
    Explorer\IEXPLORE.EXE
    2006-01-11 23:20:18 2704 a94 Misc = Module: C:\WINDOWS\system32\wuapi.dll
    2006-01-11 23:20:18 2704 a94 COMAPI FATAL: Unable to connect to the service
    (hr=8007043B)
    2006-01-11 23:20:18 2704 a94 COMAPI WARNING: Unable to establish connection
    to the service. (hr=8007043B)
    2006-01-11 23:21:14 2704 a94 Misc =========== Logging initialized (build:
    5.8.0.2469, tz: +1300) ===========
    2006-01-11 23:21:14 2704 a94 Misc = Process: C:\Program Files\Internet
    Explorer\IEXPLORE.EXE
    2006-01-11 23:21:14 2704 a94 Misc = Module: C:\WINDOWS\system32\wuweb.dll
    2006-01-11 23:21:14 2704 a94 Setup *********** Setup: Checking whether
    self-update is required ***********
    2006-01-11 23:21:14 2704 a94 Setup * Inf file:
    C:\WINDOWS\SoftwareDistribution\WebSetup\wusetup.inf
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\cdm.dll: target version = 5.8.0.2469, required version =
    5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\iuengine.dll: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wuapi.dll: target version = 5.8.0.2469, required version
    = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wuauclt.exe: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wuauclt1.exe: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wuaucpl.cpl: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wuaueng.dll: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wuaueng1.dll: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wucltui.dll: target version = 5.8.0.2469, required
    version = 5.8.0.2469
    2006-01-11 23:21:14 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wups.dll: target version = 5.8.0.2469, required version =
    5.8.0.2469
    2006-01-11 23:21:15 2704 a94 Setup Update NOT required for
    C:\WINDOWS\system32\wups2.dll: target version = 5.8.0.2469, required version
    = 5.8.0.2469
    2006-01-11 23:21:15 2704 a94 Setup * IsUpdateRequired = No
    2006-01-11 23:21:38 2704 a94 COMAPI -------------
    2006-01-11 23:21:38 2704 a94 COMAPI -- START -- COMAPI: Search [ClientId =
    WindowsUpdate]
    2006-01-11 23:21:38 2704 a94 COMAPI ---------
    2006-01-11 23:21:38 2704 a94 COMAPI - Online = Yes; Ignore download
    priority = No
    2006-01-11 23:21:38 2704 a94 COMAPI - Criteria = "IsInstalled=0 and
    IsHidden=1"
    2006-01-11 23:21:38 2704 a94 COMAPI - ServiceID =
    {9482F4B4-E343-43B6-B170-9A65BC822C77}
    2006-01-11 23:21:38 2704 a94 COMAPI FATAL: Unable to connect to the service
    (hr=8007043B)
    2006-01-11 23:21:38 2704 a94 COMAPI WARNING: Unable to establish connection
    to the service. (hr=8007043B)
    2006-01-11 23:21:38 2704 a94 COMAPI - WARNING: Exit code = 0x8007043B
    2006-01-11 23:21:38 2704 a94 COMAPI ---------
    2006-01-11 23:21:38 2704 a94 COMAPI -- END -- COMAPI: Search [ClientId =
    <NULL>]
    2006-01-11 23:21:38 2704 a94 COMAPI -------------
    2006-01-11 23:21:38 2704 a94 COMAPI FATAL: Unable to initiate asynchronous
    search, hr=8007043B

    Have tried the procedures here...
    http://update.microsoft.com/windowsupdate/v6/showarticle.aspx?articleid=19&ln=en

    and here ... http://www.fermu.com/content/view/140/37/lang,us/

    and have reinstalled the wuauserv service to no avail.

    Any clues?
     
    Brett Davidson, Jan 11, 2006
    #1
    1. Advertisements


  2. I think that this is yet another case of inadequate information in the log
    but let's try something different. Does that ServiceID= mean anything
    in your registry? E.g. open regedit and do a find (e.g. press Ctrl-f)
    for {9482F4B4-E343-43B6-B170-9A65BC822C77}

    Hmm... not likely, I suspect. FWIW I just did a search in my WU log
    for a similar (COMAPI) message and found one for a different GUID

    <example>
    2006-01-06 21:12:17 3812 ccc COMAPI - Added service, URL = http://update.microsoft.com/microsoftupdate/
    2006-01-06 21:12:17 3812 ccc COMAPI ----------- COMAPI: IUpdateServiceManager::RegisterServiceWithAU -----------
    2006-01-06 21:12:17 3812 ccc COMAPI - ServiceId = {7971f918-a847-4430-9279-4a52d1efe18d}
    </example>

    So, I tried doing a RegEdit find for that and didn't get anywhere.

    And findstr (searching for the equivalent string as doublebyte characters)
    only found Layout.ini and muweb.dll

    Aha. That Layout.ini contains a clue. The ServiceId _minus the braces_
    is a subdirectory in SoftwareDistribution. Do a tree of that and see
    your ServiceId (minus the braces) there too. Strangely muweb.dll
    (which will be not be relevant in your case) was nowhere to be found
    in that directory.


    I would try activating verbose logging (or use FileMon and
    RegMon) to supplement this log. <w>


    Good luck

    Robert Aldwinckle
    ---

     
    Robert Aldwinckle, Jan 22, 2006
    #2
    1. Advertisements

  3. Thanks, I think! ;-)

    You were correct - I couldn't match any of those guids in the registry wtih
    the log.

    One thing I had tried was to blat the Software Distribution directory
    (harmless to do as it gets cleared upon a successful patch update anyway) and
    try again. Did not work this time but I have known this to work when patches
    fail on some production machines I look after.



     
    Brett Davidson, Jan 22, 2006
    #3
  4. Brett Davidson

    MowGreen Guest

    Brett,

    In order to "blat" the Software Distribution folder one must first stop
    the Automatic Updates service.

    MowGreen [MVP 2003-2006]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============


     
    MowGreen, Jan 30, 2006
    #4
  5. Brett Davidson

    Brett Guest

    Um, if you had read the thread before jumping in you might well have noticed
    that the original issue is that the Automatic update service never gets
    started in the first place.

    However, I did resolve the issue with another reinstall AND more
    importantly, resolved the real issue which was an intermittent single-bit
    memory failure.

    Thanks for your help Robert!

     
    Brett, Jan 31, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.