Error 1719 Windows Installer Service Cannot be accessed

Discussion in 'Windows Server' started by Glen Moffitt, Jun 12, 2005.

  1. Glen Moffitt

    Glen Moffitt Guest

    Running windows 2003 server sp1 on hp p4 laptop. Wiped the box and
    installed 2003 server, sp1, etc. Installed Office 2002 sp1 Visual Studio
    ..Net, etc, I use this for field work and dev work with MS SQL. Everything
    runs rather well, except now I'm in this hell-hole of the Error 1719
    "Windows Installer Service Cannot be Accessed". Can't install hp printer
    drivers from HP, can't install Sun Java client (Java 2 Runtime Environment
    for running a remote training service).

    Been through the various MS trouble docs, including KB315346 (re-registering
    the msiexec, also renaming and reinstalling the msiexec), I've also
    reinstalled server 2003 sp1. Made sure the Windows Installer Service is
    running. Still same error.

    Any ideas for this would be greatly appreciated. Thx.
     
    Glen Moffitt, Jun 12, 2005
    #1
    1. Advertisements

  2. Glen Moffitt

    NunoCosta Guest

    First, try the old faithful reboot; this error may be the result of an RPC
    error. If a reboot does not clear the RPC error, you have bigger problems
    than installing MSI packages!

    Reregister the Windows Installer service by typing "msiexec /unregister" and
    then "msiexec /regserver" at the command line.

    The System account should have "Full Control" permissions to the
    HKEY_CLASSES_ROOT hive of the registry.

    Ensure the Windows Installer service is not disabled by typing "NET STOP
    MSISERVER" and "NET START MSISERVER" at the command line.

    I know your system is w2k3 butt...

    Did you try this? http://support.microsoft.com/?kbid=315353
    And this? http://support.microsoft.com/?kbid=324906
     
    NunoCosta, Jun 12, 2005
    #2
    1. Advertisements

  3. Glen Moffitt

    bill_the_cat Guest

    Thanks for the suggestions..tried it all, still no luck. Permissions are all
    there, etc. Running everything as local Administrator. May try removing
    Office and reinstalling or repair of server 2003 tonight and then see if
    problem persists. I had this issue also with server 2000, right after
    install of os, could install other stuff, up until I installed Office. Thks.
     
    bill_the_cat, Jun 13, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.