Error Code: 0x643 when installing Visual Studio 2005 Professional

Discussion in 'Windows Update' started by tedh, Mar 22, 2007.

  1. tedh

    tedh Guest

    I am running a standalone Windows 2003 server and Visual Studio 2005
    Professional. When I try to run Windows Update to install SP1 for Visual
    Studio I get the message Error Code: 0x643.

    The SP1 updates are successfully downloaded and the initialization process
    runs successfully and after this the message comes up.

    Can you please advise re steps to take to resolve?

    Thanks
     
    tedh, Mar 22, 2007
    #1
    1. Advertisements

  2. tedh

    Paul Guest

    Paul, Mar 28, 2007
    #2
    1. Advertisements

  3. tedh

    Paul Guest

    One other thing: I did NOT run Windows Update, but I downloaded the SP from
    MSDN and then ran it from my hard drive. I don't know if this made the
    difference. Let me know if this helps...
     
    Paul, Mar 28, 2007
    #3
  4. tedh

    Art Guest

    I have the identical problem on two Win 2003 Servers & am looking for a
    resolution.
     
    Art, Mar 28, 2007
    #4
  5. tedh

    Paul Guest

    I am running Windows Server 2003 SP1 and Visual Studio Professional and had
    the same problem and error message that you are experiencing and this fixed
    the issue for me. I did the following:

    1. Click Start, click Run, type control admintools, and then click OK.
    2. Double-click Local Security Policy.
    3. Click Software Restriction Policies.

    Note If no software restrictions are listed, right-click Software
    Restriction Policies, and then click Create New Policy.
    4. Under Object Type, double-click Enforcement.
    5. Click All users except local administrators, and then click OK.

    I then changed
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
    PolicyScope, and then change the setting from 0 to 1.

    6. Restarted the computer.
     
    Paul, Mar 28, 2007
    #5
  6. tedh

    Art Guest

    Thank you Paul. Your procedures worked for both Win2003 Servers that I
    updated.

    Note that one server DID NOT have "Local Security Policy" within Control
    AdminTools but I was able to find the shortcut on the other server
    "c:\windows\system32\secpol.msc /s" and I ran it from Start/Run.

    Thanks again.

    Art
     
    Art, Mar 28, 2007
    #6
  7. tedh

    tedh Guest

    Hi Paul,

    Thanks for the reply. I carried out the instructions in the KB article but
    when I ran windows update I got the same results as previously.

    The initialization process runs successfully and the hard drive light is
    very active for about 10 minutes afterwards and then Windows Update reports
    that the installation failed and when reviewing the installation history and
    clicking on the error status it reports error 0x643.

    Regards
    Ted
     
    tedh, Mar 28, 2007
    #7
  8. tedh

    NikB Guest

    Simple solution to problem I was researching for a day or so.
    Step 5 was all I needed to change and no reboot.

    (Full error code is 0x80070643
    Visual Studio 2005 Service Pack 1, SP1 )

    Nik
     
    NikB, Jan 24, 2008
    #8
  9. tedh

    ltreachler Guest

    This procedure worked perfectly for myself. I was having problems installing
    Visual Studio 2005 SP1 (i.e. getting the 10 minute wait and then the install
    error 0x643) on a Windows 2003 Server SP1 w/1 Gig of RAM. Thanks Paul.
     
    ltreachler, Nov 5, 2008
    #9
  10. tedh

    Dwayne Guest

    Finally worked for me too:
    - just did Step 5 with no reboot
    - registry wal already a 1 (no change needed)
    - downloaded SP to desktop & ran it
     
    Dwayne, Dec 2, 2008
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.