Error code 643

Discussion in 'Windows Vista Performance' started by Bruce UK, Jul 11, 2007.

  1. Bruce UK

    Bruce UK Guest

    I have received this error code when trying to install Security Update for
    Microsoft .NET Framework, Version 1.1 Service pack 1 (KB929729) on a Vista
    Home premium machine, does anyone have any ideas on how to resolve this?

    Thanks

    Bruce.
     
    Bruce UK, Jul 11, 2007
    #1
    1. Advertisements

  2. Bruce UK

    farbuncle Guest

    I also have this problem as does thousands of others. Its all over the
    internet. The only thing missing is a MS expert with the answer. Bill is due
    back in a week or so.
     
    farbuncle, Jul 13, 2007
    #2
    1. Advertisements

  3. Bruce UK

    epauley Guest

    I too am getting code 643 error message. I attempted the suggested fix -
    linked to the code 643 message in windows update but it didn't work.
     
    epauley, Jul 13, 2007
    #3
  4. Bruce UK

    SARAT Guest

    Hi

    I'm also getting same Error. I tried to reinstall the installation after
    doing the following task. Still it didn't worked for me

    "Remove the temporary files that Windows uses to identify updates for your
    computer. To remove the temporary files, stop the Windows Update service,
    delete the temporary update files, restart the Windows Update service, and
    then try to check for Windows updates again."

    Can any one help me to resovle this problem?

    Thanks
     
    SARAT, Jul 13, 2007
    #4
  5. Bruce UK

    epauley Guest

    That's the same procedure I followed - nothing - still the same code 643
    response.
     
    epauley, Jul 13, 2007
    #5
  6. Bruce UK

    epauley Guest

    Well, is there a tech or members who can help?

     
    epauley, Jul 13, 2007
    #6
  7. Bruce UK

    chris Guest

    this is really silly, because i am having the same problem as all of you
    (code 643) and I cannot figure out how to resolve it. I'm not sure if this
    problem is specific to Windows Vista, but I have had nothing but problems
    since upgrading. I do not recommend it to anyone and am looking to go back
    to the old windows. If anyone finds a solution, please let us all know!
     
    chris, Jul 14, 2007
    #7
  8. Bruce UK

    epauley Guest

    This beyond silly and PAR for Microsoft who can never their get their act
    together! Very frustrating! Sorry for the rant but someone from MS could chip
    in here and assist - but that would suggest a customer friendly company,
    which NOT MICROSOFT!
     
    epauley, Jul 14, 2007
    #8
  9. Bruce UK

    msharptx Guest

    Same annoying problem, hope MS can pull their head out.
     
    msharptx, Jul 14, 2007
    #9
  10. MrSlartybartfast, Jul 15, 2007
    #10
  11. Bruce UK

    DanR Guest

    This worked for me. It's from a post by Chris Rowat at:
    http://forums.microsoft.com/msdn/sh...tid=1852213&sb=0&d=1&at=7&ft=11&tf=0&pageid=2
    Running the "Cleanup Utility" did not actually get rid of .net1.1 but
    apparently this is part of the fix. Before running the cleanup utility I
    tried to remove net1.1 but nothing really happened. It remained in the
    add/remove programs. After running the cleanup utility and then trying to
    remove .net1.1 gave me this error:
    "This action is only valid for products that are currently installed." So
    apparently the utility did something. I also emptied my temp folder before
    the re-install. When you re-install SP1 you may get a message saying it's
    already installed. I chose the reinstall option at this point.
    Below is a paste from the above link...

    I would like to make a retraction on some previous comments...

    After careful review, .NET 1.1 has been ammended to work correctly with
    Vista.

    I think this may solve the issue for those who are affected:

    Download and run the Windows Installer Cleanup Utility, and remove the .NET
    framework 1.1 from the machine.

    Download .NET framework 1.1 from the Microsoft website and install it

    Reboot your machine, then install .NET 1.1 SP1 from the Microsoft website
    and reboot your computer again. Then try to take the update once again.



    Please let me know if this works, I have tried it on 2 machines and it seems
    to work okay, allowing the update to be installed.



    Windows Installer Cleanup Utility

    http://download.microsoft.com/download/e/9/d/e9d80355-7ab4-45b8-80e8-983a48d5e1bd/msicuu2.exe

    ..NET Framework 1.1

    http://www.microsoft.com/downloads/...E3-F589-4842-8157-034D1E7CF3A3&displaylang=en

    ..NET 1.1 SP1

    http://www.microsoft.com/downloads/...4F-088E-40B2-BBDB-A83353618B38&displaylang=en
     
    DanR, Jul 16, 2007
    #11
  12. Bruce UK

    jusled Guest

    Thank you... this took some time, but it worked. Finally a fix to this
    problem that was bugging me for days.
     
    jusled, Jul 18, 2007
    #12
  13. Bruce UK

    Rgryn Guest

    Thank you...
    You solved the issue.
    It drove me nuts... and now it is gone
    Robert
     
    Rgryn, Aug 2, 2007
    #13
  14. Bruce UK

    joej0311 Guest

    If anyone is still following this thread, I have a problem. I downloaded the
    cleanup utility and ran the installer. It appears to install correctly but
    then I can't find the executable to actually run the utility. I have
    searched my drive for msicuu.exe and several variations of that name and
    nothing appears. Any help would be appreciated.
     
    joej0311, Nov 28, 2007
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.