Error Code 643

Discussion in 'Windows Vista Performance' started by How2, Jul 18, 2007.

  1. How2

    How2 Guest

    This error code relates to a "security update for Microsoft.NET framework
    version 1.1 Service Pack 1. My Windows Vista has tried many times to
    download this update and each time it has failed and reports error code 643.

    What is the solution to this problem?
     
    How2, Jul 18, 2007
    #1
    1. Advertisements

  2. How2

    Bob J Guest

    Error code643 - A network adapter at the server failed.

    You do not have a problem on your PC p
    What the error says is that MS had a fault at their end and the update was
    not uploaded.
    Manually download the update.
    --
    Regards
    Bob J
    If advise given from anyone, solves problem or not, or if solved from
    another source,post back & let us know.
    Then we all benefit.
     
    Bob J, Jul 19, 2007
    #2
    1. Advertisements

  3. How2

    Ron Morin Guest

    Bob, I have same problem. I downloaded the update manually as you suggested
    and started the install. It started he execution but seems to have finished
    within 20 seconds with no messages. How do I know if it did the job. I have
    2 .NET Framework items in my installed control panel. One is version 1.1 and
    version 3. Version 3 shows no date and if I highlight it it does not bring up
    the uninstall opton whereas if I highlight version 1.1 it does. I have
    attempted to uninstall version 1.1 and it goes through the motion but it
    never disappears from the installed program list. Versions 1.1 and 3.0 have
    always been there from the start. This was a Vista Business Upgrade to an XP
    SP2 fully up to date with security updates. Ron
     
    Ron Morin, Jul 21, 2007
    #3
  4. How2

    Bob J Guest

    Check in you Update History and if the update is logged them no problem.
    Remember it is an update not a replacement so the version No. does not
    change.
    --
    Regards
    Bob J
    If advise given from anyone, solves problem or not, or if solved from
    another source,post back & let us know.
    Then we all benefit.
     
    Bob J, Jul 21, 2007
    #4
  5. How2

    Ron Morin Guest

    Bob, I checked the update log and nothing shows for this update 929729 other
    than previous failure to install thru the normal Windows Update. I reran the
    manually downloaded file from earlier tonight and again just a flicker of the
    screen and no entries on Event log or in Update History. Ron
     
    Ron Morin, Jul 21, 2007
    #5
  6. How2

    Bob J Guest

    Try the fix in the KB link below, it does not mention any specific update but
    it may do the trick. Use the entry relating to update not being installed.
    http://support.microsoft.com/kb/902992/en-us
    --
    Regards
    Bob J
    If advise given from anyone, solves problem or not, or if solved from
    another source,post back & let us know.
    Then we all benefit.
     
    Bob J, Jul 21, 2007
    #6
  7. How2

    DebbieC Guest

    I got this fix from Microsoft support. It works, I did it. I did tell them
    that the problem seems to be Microsofts because there are too many of us
    experiencing the same problem.

    To troubleshoot this issue, I suggest we first perform these steps:

    Step 1: Download Microsoft Windows Installer CleanUp utility
    ====================================
    1. Visit:
    http://download.microsoft.com/download/E/9/D/E9D80355-7AB4-45B8-80E8-983A48D5E1BD/msicuu2.exe
    2. Save the file to your computer.
    3. Right click "msicuu2.exe", click "Run as administrator" and follow the
    wizard to install this tool on your computer.

    Step 2: Remove .NET Framework
    ========================
    1. Click Start ->All Programs->Windows Installer Clean Up, click Allow.
    2. See if you can find .Net Framework software. If so, remove them.

    After that, please restart the computer and perform the following
    suggestions to reinstall .NET framework 1.1 and the updates for it.

    Step 3: Install .NET Framework 1.1 Redistributable Package and related updates
    ==================================================
    1. Please download the Microsoft .NET Framework Version 1.1 Redistributable
    Package from the following link and save it to the C drive (C:\)

    1) Microsoft .NET Framework Version 1.1 Redistributable Package

    http://download.microsoft.com/download/a/a/c/aac39226-8825-44ce-90e3-bf8203e74006/dotnetfx.exe

    2) Microsoft .NET Framework 1.1 Service Pack 1

    http://download.microsoft.com/downl...-bdb8-c4e00af5b94b/NDP1.1sp1-KB867460-X86.exe

    3) Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1
    (KB928366)

    http://www.download.windowsupdate.c..._20112ef50011e0de2c0e3378139245d81a178b15.exe

    4) .NET Framework 1.1 Service Pack 1 SYSTEM.WEB.DLL and MSCOREE.DLL Security
    Update for Windows Vista (KB929729)

    http://download.microsoft.com/downl...-92fb-60beff5502e9/NDP1.1sp1-KB929729-X86.exe
     
    DebbieC, Aug 17, 2007
    #7
  8. How2

    Brew Seeker Guest

    Thanks for doing the research. After a lot of trial & error, I stumble
    upon your post here, and it fixed the problem. :D
     
    Brew Seeker, Dec 22, 2007
    #8
  9. Thanks Brew and all the posters since July. I just got it now and although
    you have an answer, I've wasted an afternoon trying to fix it and am tapped
    out. I tjhink I will wait till the Jan pack and see if Microsoft thinks it
    is important and cares enough to fix it.
    Thanks again
    VC
     
    Vista Challenged, Jan 7, 2008
    #9
  10. How2

    NateEaton Guest

    Thanks, DebbieC, for posting this solution. It worked for me, but onl
    after I forced Windows Update to check for updates did the .Net 1.
    update disappear from the list
     
    NateEaton, Jul 18, 2008
    #10
  11. How2

    fogdog54 Guest

    G'day DebbieC, :

    I successfully used the excellent fix you posted for this problem, so
    big thank you to yourself and the Vistahead forum, from one happ
    bunny!!!! ;
     
    fogdog54, Jul 21, 2008
    #11
  12. How2

    Nonny Guest

    While it was nice of you to thank her, she won't know you did.

    You are using a forum that gleans most of its posts from other
    sources, and most of the posts you see - Debbie's is one example -
    come from people who never visit Vistaheads and aren't registered
    there (notice all the n/a in number of posts).

    In Help and Support, search for "USENET".

    It will show you how to setup Windows Mail to do these groups in a
    much easier and satisfying way.
     
    Nonny, Jul 21, 2008
    #12
  13. How2

    covingtonium Guest

    Ok. I am EXTREMELY frustrated about this. I get error code 643. It i
    because I try to use Windows auto update and it says there are tw
    updates available. When I try to install them, it will not instal
    them. The two updates are: Security Update for Microsoft XML Cor
    Services 4.0 Service Pack 2 for x64 based systems (KB954430) and then
    Update for Microsoft XML Core Services 4.0 Service Pack 2
    (KB941833). The first one is important, the second recommended.
    Now,.....I tried following the instructions about downloading th
    msicuu2 file and right clicking run as administrator. After downloadin
    it and right clicking, I get a window that says
    Window Script Host with a big red x and then:
    Script
    C:\Users|COVING~1\AppData\Local\Temp\IXP000.TMP\StartMsi.vb
    Line: 1
    Char:
    Error: The file or directory is corrupted and unreadabl
    Code: 8007057
    Source: nul

    So, that shoots that down. Now, I followed the advice of anothe
    thread and tried to manually uninstall the .net framework programs tha
    I had installed. I went to control panel, remove programs, and righ
    clicked and uninstalled microsoft .net 1.1 software. Then, I followe
    the recommendations and downloaded new .net software, but when I try t
    install it, I get the next cute little window (extreme bitterness her
    people)
    Microsoft .NET Framework 1.

    Info 9006. This patch cannot be installed because it require
    Microsoft .NET Framework 1.1 Service Pack 1 (SP1). No Microsoft .NE
    Framework 1.1 SP can be detected on this computer. Please se
    'Description of the security update for the .NET Framework 1.1 Servic
    Pack 1 for Windows XP and Windows 2000: July 10, 2007
    (http://support.microsoft.com/?kbid=928366) for more details.

    I am at my wits end. I hate computers now, forever. All I was tryin
    to do was play some computer games on my nice new fast Gateway PC.
    should have never even tried
     
    covingtonium, Feb 4, 2009
    #13
  14. How2

    DonaldMII Guest

    I am getting the same error code when I try to install Microsoft .NE
    Framework 3.5 KB951847 Tried the suggested fix above, but it had n
    effect. Any Ideas?

    DonaldMI
     
    DonaldMII, Feb 8, 2009
    #14
  15. How2

    TracyC Guest

    I'd like to know the same thing as none of the things here have helpe
    at all
     
    TracyC, Aug 2, 2009
    #15
  16. How2

    Gomezy3k Guest

    Is this stupid update necessary? Why should I have to jump throug
    hoops to install something that should work right from the start. I
    Windows cannot get their crap together, it is not my fault. Apple i
    looking better and better
     
    Gomezy3k, Nov 11, 2009
    #16
  17. How2

    Flavius Guest

    Flavius, Nov 11, 2009
    #17
  18. How2

    pauljadd Guest

    None of these options worked and I am now getting frustrated and angry
    Someone please help
     
    pauljadd, Nov 16, 2009
    #18
  19. How2

    Flavius Guest

    Is this also problem with KB95430?If yes follow below

    1.Run cmd.exe with administrative previlliges (right click on cmd.ex
    as administrator
    se
    here:http://www.vistax64.com/tutorials/181765-elevated-command-prompt.htm
    2.At the command prompt, type *ren %windir%\System32\msxml4.dl
    msxml4.old*, and then press ENTER

    Note After you press ENTER, you may receive the following erro
    message
    Cannot find the file specified
    Ignore this message, and go to step 3

    3. At the command prompt, type exit, and then press ENTER.
    4.Download & install manually hotfix from here 'MS08-069&#58
    Description of the security update for XML Core Services 4.0&#58
    November 11, 2008' (http://support.microsoft.com/?kbid=954430

    If your problem address to any update for NET Framework 1.1 or 3.
    then solution is another

    1.Download NET Framework Cleanup Tool from here 'Aaron Stebner's WebLo
    : .NET Framework Cleanup Tool User's Guide
    (http://blogs.msdn.com/astebner/pages/8904493.aspx

    and using this tool remove NET Framework which one you have problem
    2.Install .NET Framework Redistributable Package and related update
     
    Flavius, Nov 16, 2009
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.