[Error number: 0x8DDD0018]

Discussion in 'Windows Update' started by Redactor, May 19, 2005.

  1. Redactor

    Redactor Guest

    Windows Update cannot continue because a required service application is
    disabled. Windows Update requires the following services:
    Automatic Updates
    Background Intelligent Transfer Service (BITS)
    Event Log

    Ran services.msc and found that all three were listed as automatic startup
    type, but BITS was not running. Tried to start BITS and got popup error
    message: "Windows could not start Background Intelligent Transfer Service on
    Local Computer. For more information review the System Event Log. If this is
    a non-Microsoft service . . . blah, blah, blah"

    1. Can't find System Event Log. Where is it located? Tried Windows &
    System32 folders.
    2. What file(s) comprise BITS and where is it/are they located?
    3. What steps must I take to get BITS running again?

    Thanks for any help you can provide on this knotty issue.
    Redactor
     
    Redactor, May 19, 2005
    #1
    1. Advertisements

  2. Redactor

    Perlfan Guest

    Hi,

    the EventLog can be viewed with the EventViewer.
    It is somewhere deep in the control-panel, but since my Windows speaks
    German I cannot tell you the exact English names.

    In German it is
    Systemsteuerung->Verwaltung and there is a Ereignisanzeige
    this would translate to
    Control-Panel->Administration->EventViewer
    But I think it is not called "Administration" in the English version.

    But you can also get it from a DOS-Box by entering the command

    %SystemRoot%\system32\eventvwr.msc /s

    or use Start->Run and enter
    %SystemRoot%\system32\eventvwr.msc /s
    there.

    perlfan
     
    Perlfan, May 19, 2005
    #2
    1. Advertisements

  3. Hi Redactor,

    1) Open the Event Viewer (eventvwr.msc) and click on System in the left
    pane.

    2) Bitsprx2.dll (Windows\System32), Bitsprx3.dll (Windows\System32),
    Qmgr.dll (Windows\System32 and Windows\System32\bits) and Qmgrprxy.dll
    (Windows\System32)

    3) Run services.msc and ensure that the Workstation service is started. If
    it is started, then check the Properties>Log On tab for Background
    Intelligent Transfer Service and ensure that Local System account is
    selected under "Log on as". In addition, In the Hardware Profile field, if
    the Service status is Disabled for your Hardware Profile, click to
    highlight the Hardware Profile in this field, click on the Enable button and
    then click on Apply. Now, click on the General tab and click on Start under
    Service Status.



    Regards,
     
    Patti MacLeod, May 19, 2005
    #3
  4. Redactor

    Redactor Guest

    Hello, Patti --

    Thanks for the clear directions. I followed them step-by-step, and the end
    result is: No dice. Same error message at attempted startup.

    I confirmed that the files are in the right place and all other necessary
    services are runninng, but I still can't get BITS to start.

    Any other suggestions?
    Redactor
     
    Redactor, May 20, 2005
    #4
  5. In the System Event log, check for errors that have Service Control Manager
    as Source. If there are errors for Service Control Manager, double-click on
    the Error line. In the Description field, if there is mention of the
    Background Intelligent Transfer Service, take note of what exactly is stated
    in the Description field, along with the EventID number. Post that
    information in a reply.



    Regards,
     
    Patti MacLeod, May 20, 2005
    #5
  6. Redactor

    Redactor Guest

    Patti --

    Checked event log & found the following error message:
    "The Background Intelligent Transfer Service terminated with the
    service-specific error 2147942402 (0x80070002)."

    There are also several other services that try and fail to start, though
    they have had no discernible effect on the way I use the computer. These
    include:
    Aspi32, PfModNT, COM+ System Application. Also the ntiowp boot start or
    system start driver failed.

    Looks like I've got a sick system, though the only symptom that I normally
    see is failure of the update service.

    Bob
     
    Redactor, May 21, 2005
    #6
  7. I just returned home from work, so I'm going to concentrate on only the BITS
    problem for now........gonna hit the hay soon :)

    Try the following, provided by Narayana Mahankali [MSFT] in an October 2004
    thread regarding similar error codes when attempting to start BITS:

    Open a command prompt window, and key in (or copy/paste):
    rd /q /s "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloa­­der"
    hit ENTER
    Now, in the same command prompt window, key in:
    net start BITS
    and hit ENTER



    Regards,
     
    Patti MacLeod, May 21, 2005
    #7
  8. Redactor

    Redactor Guest

    Patti --
    "Just returned home . . . hit the hay . . ."?! What part of the world do you
    live in?

    Anyhow, followed your instructions again. Here's the sequence:

    Opened a command prompt and typed in the stuff listed below. The following
    message appeared:

    A Service specific error ocurred: 2147942402.
    More help is available by typing NET HELPMSG 3547.

    I did that, and the following message came up:

    A service specific error has occurred: ***.
    EXPLANATION
    A service-specific error ocurred.
    ACTION
    Refer the the HELP or documentation for this service to determine the problem.

    Not very helpful, eh??

    I don't suppose I have access to the help or dox for this service, huh?

    'Till next time --
    Redactor

     
    Redactor, May 21, 2005
    #8
  9. LOL! I live in Ontario, Canada. My job entails rotating shiftwork, and I
    normally work the afternoon and night shifts (I trade off as many day shifts
    as possible, as I absolutely LOATHE them). I am currently working
    nightshift.

    Have a look at this posting by Torgeir Bakken (MVP):
    http://groups-beta.google.com/group/microsoft.public.windowsxp.general/msg/86b6445202cc356e
    The service specific error is slightly different from the one that you're
    receiving.

    Further information about BITS can be found here:
    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/bits/bits/about_bits.asp

    Here is a thread regarding the PfModNT service that you might find helpful:
    http://groups-beta.google.com/group...read/thread/3b47febd31984813/8608600febe522e6

    The ASPI32 service does not exist in a standard XP installation. Aspi32 was,
    and perhaps is still, used by some CD burning programs. Check the
    documentation for CD burning software that you have installed to see if
    there is anything relating to ASPI32 in the Troubleshooting section.

    For the COM+ System Application error, perhaps this will help:
    How do I clean up a damaged COM+ catalog in Windows 2000?
    http://www.jsifaq.com/subN/tip6900/rh6951.htm
    (also applicable to WINXP)

    I know zip about the NT IO driver named ntiowp.sys, and wasn't able to dig
    up much about it :-(



    Regards,

    --
    Patti MacLeod
    Microsoft MVP - Windows Shell/User

     
    Patti MacLeod, May 21, 2005
    #9
  10. Redactor

    Redactor Guest

    Patti --

    Thanks for the detailed info.

    As I was searching to see if you had responded to my last post, I stumbled
    upon another thread that addresses this very issue: How to Fix Windows Update
    (BITS) posted by Mike on 5/21/05. I followed the steps. After completing the
    last step, despite the fact that BITS still wouldn't start, I went to Windows
    Update. It seemed to work until it got to the download window, when the
    entire process froze. So, I figured, "still not working."

    Returning to the Windows Update discussions to search for your latest
    missive, I then stumbled upon a thread titled "Windows installer 3.1 will not
    come in." This is the update that I had just tried to download, so I opened
    that thread to find that many people have had trouble downloading and/or
    installing this update.

    So at this point, I don't know whether I'm in business and there's a MS
    problem with the specific installer 3.1 or whether I've made some progress,
    but still have a problem.

    In any case, thanks for your interest and help.

    Redactor

     
    Redactor, May 22, 2005
    #10
  11. Redactor

    TR Guest

    Did you ever get this solved?
    I have been going through the same problem, with no solutions.
    I have been able to dwnload updates manually.

     
    TR, Aug 27, 2005
    #11
  12. See if this helps:
    http://www.fermu.com/content/view/181/37/lang,us/

    --
    www.fermu.com



     
    José Gallardo, Aug 27, 2005
    #12
  13. Hi TR,

    I happened upon this possible solution, posted by David_C, just recently:
    http://groups.google.com/group/microsoft.public.windowsupdate/msg/bf93b75bec6b9bc4

    Hope that helps!



    Regards,

    --
    Patti MacLeod
    Microsoft MVP - Windows Shell/User

     
    Patti MacLeod, Aug 27, 2005
    #13
  14. Redactor

    TR Guest

    Patti You are GREAT!!
    This worked. After 3 months of fooling with different suggestions, you have
    cured my update problem.
    Just one more question, can I delete the BIT fix file, or should I leave it.
    Thanke again,

    TR

     
    TR, Aug 27, 2005
    #14
  15. You're very welcome! :)

    Just out of curiosity, since David_C thinks that the problem may have been
    due to the uninstall routine of an AV program, had you uninstalled an AV
    program or, perhaps, another maintenance-type program (Norton Systemworks,
    for example) prior to the onset of the problem that you were experiencing?

    It would do no harm to delete the BITS fix file that you created, but you
    may want to store it somewhere for future reference.



    Regards,

    --
    Patti MacLeod
    Microsoft MVP - Windows Shell/User

     
    Patti MacLeod, Aug 27, 2005
    #15
  16. Redactor

    TR Guest

    Actually we had just purchased a new computer. I unistaled Norton and
    installed McAfee. I can't remember how long after that the problem started.
    It was within days, at most 2 weeks.

     
    TR, Aug 27, 2005
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.