Error number: 0x8DDD0018

Discussion in 'Windows Update' started by E-Double, Apr 11, 2006.

  1. E-Double

    E-Double Guest

    When attempting to run Windows Update the following message appears: 'Error
    number: 0x8DDD0018.' This message states that the Automatic Updates, BITS,
    and Event Log services must be started, but they are all started and
    WinUpdates still fails. Zone Alarm has been installed, but no events blocking
    updates show in the logs. TIA for any help on this one...
     
    E-Double, Apr 11, 2006
    #1
    1. Advertisements

  2. E-Double

    Sundown Guest

    I'm also having the exact same problem. I've followed all of the
    instructions to no avail.

    Little help? Anyone?
     
    Sundown, Apr 11, 2006
    #2
    1. Advertisements

  3. E-Double

    E-Double Guest

    I still can't find anything further on this. Do you have ZoneAlarm or another
    firewall installed ? Did you disable any other services ? Also, my MS Office
    Update seems to work fine -just the Windows Update, which originally worked
    okay when Windows was first installed, fails with the above-mentioned error.
     
    E-Double, Apr 12, 2006
    #3
  4. E-Double

    E-Double Guest

    found another post on here that suggested running this command from a command
    prompt:


    regsvr32.exe wuaueng.dll

    and after running this and setting all of the above-mentioned services to
    start automatically the WU worked okay for me. hope this helps ...

    e.
     
    E-Double, Apr 12, 2006
    #4
  5. E-Double

    Tyger Guest

    this works!:
    run this command from a command
    prompt:


    regsvr32.exe wuaueng.dll

    and after running this and setting all of the above-mentioned services to
    start automatically the WU worked okay for me.
     
    Tyger, May 6, 2006
    #5
  6. E-Double

    elpiyin Guest

    thank you!!!!!!! :D

     
    elpiyin, May 8, 2006
    #6
  7. E-Double

    crossmr Guest

    Thank you for this. This problem has been driving me nuts for 4 days, and
    Microsoft has been completely useless with the support.
     
    crossmr, Jun 5, 2006
    #7
  8. E-Double

    Carlos Guest

    I was having exactly the same problem. Thanks a lot!!
    Does anyone what the source of this problem is?

     
    Carlos, Jul 14, 2006
    #8
  9. E-Double

    bpatton88 Guest

    worked for me too, thank you so much


     
    bpatton88, Jul 27, 2006
    #9
  10. E-Double

    RCB Guest

    Thank you so much. This solved my problem also. MS needs to add this
    solution.
     
    RCB, Sep 28, 2006
    #10
  11. E-Double

    Michael Guest

    this did not resolve my issue with my Windows 2000 and 2003 servers.


     
    Michael, Oct 5, 2006
    #11
  12. E-Double

    MillaUrbana Guest

    Worked fine. Fine.
     
    MillaUrbana, Oct 22, 2006
    #12
  13. E-Double

    icemchn Guest

    Worked perfectly! Thx!
     
    icemchn, Nov 10, 2006
    #13
  14. E-Double

    Shannon Guest

     
    Shannon, Mar 5, 2007
    #14
  15. E-Double

    Shannon Guest

    that worked! Thanks!
     
    Shannon, Mar 5, 2007
    #15
  16. E-Double

    Cbuck Guest

    Hi, I came up this AM with same problem. All services were running though
    AutoUpdate was set to manual. Without changing the "manual", I ran the
    regsvr32.exe wuaueng.dll and that was all needed to get to the updates.
    Thanks for the info!
     
    Cbuck, Sep 24, 2007
    #16
  17. E-Double

    d.w Guest

    thank you so much!!


     
    d.w, Dec 22, 2007
    #17
  18. E-Double

    Ciythog Guest

    Thank you so much ive been fighting with this for days. Woot it works now
     
    Ciythog, Mar 6, 2008
    #18
  19. E-Double

    Dups Guest

    This fixed my issue as well. (Windows XP SP2)

    Thanks
     
    Dups, Apr 7, 2008
    #19
  20. E-Double

    pepe Guest

    .... i don't know why but it is not working for me... it will write that
    regsvr32 was successful but the update page i still working... i think that
    the reason of my problem with the Error number: 0x8DDD0018 is because i had
    virus - the Virtumonde trojan horse - and i had to delete some of (maybe)
    important files from windows folder... so it is not still working for
    me...pls help :(
     
    pepe, Jun 15, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.