Error: This file does not have a program associated with it...

Discussion in 'Windows Live Mail' started by doug65536, Sep 21, 2008.

  1. doug65536

    doug65536 Guest

    I downloaded and installed powerpoint viewer on my brothers computer.

    Windows XP SP3 32-bit + all updates installed.

    It is running windows live mail build 12.0.1606.

    It is running Powerpoint Viewer version 12.0.6211.1000

    When I attempt to open a powerpoint attachment, I get the following

    Do you want to open the file?
    Name: whatever.pps
    Type: Microsoft Powerpoint Slide Show
    Always ask checked

    I click Open...

    I get an MB_OK + MB_ICONSTOP messagebox with a path to the file in the
    internet cache in the title, and the following message:

    "This file does not have a program associated with it for performing this
    action. Create an association in the Folder Options control panel."

    HOWEVER, if I save the file to the hard disk and double-click it in
    explorer, it opens perfectly. I have checked the file types tab in explorer's
    folder options, and it is correct. There is definitely a bug in WLM because I
    did some web searching and found that many people are having the same issues
    with several different file types in Windows Live Mail.

    doug65536, Sep 21, 2008
    1. Advertisements

  2. doug65536

    doug65536 Guest

    I found the solution... it looks like WLM is hardwired to use the "open" verb
    using ShellExecute. Powerpoint viewer does not register an "open" verb, so it
    fails to launch. Changing the registry to have an "open" verb instead of a
    "show" verb solved the problem.

    Too bad they dumbed down the file types dialog in explorer, I would have
    been able to solve the problem easily. It's like I always say: making it easy
    for a dummy makes it hard for an expert.

    Bug: WLM does not use the default verb when launching an attachment!!!
    doug65536, Sep 21, 2008
    1. Advertisements

  3. doug65536

    ju.c Guest

    Thanks for the info.


    ju.c, Sep 21, 2008
  4. The same bug (feature?) occurs in Outlook Express since XP SP2. It was
    a change included in the security enhancements of SP2.

    See the Identifying Attachment File Types and Setting File Associations
    section of
    Decoding Internet Attachments - A Tutorial
    Michael Santovec, Sep 22, 2008
  5. doug65536

    GTG Guest

    GTG, Oct 16, 2008
  6. doug65536

    GTG Guest

    Pls enlighten me where in the registry this change needs to be made. Thx.
    GTG, Oct 16, 2008
  7. doug65536

    ju.c Guest

    In the registry, change "show" to "open"







    Notice that there are three words to change!

    Simple enough. Need more help? Just ask.

    ju.c, Oct 16, 2008
  8. Ramesh Srinivasan, MS-MVP, Oct 16, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.