error when creating a win2k3 R2 domain controller in a win2k3 sp1

Discussion in 'Active Directory' started by Juliana, May 27, 2006.

  1. Juliana

    Juliana Guest

    Hi Please help

    I have a win2k3 Sp1 server as domain controller in one location and tried to
    create a win2k3 R2(another location) to that domain as additional domain
    controller. I run dcpromo, the error "The Active Directory Installation
    Wizard cannot continue because the forest is not prepared for installing
    Windows Server 2003. Use the Adprep command-line tool to prepare both the
    forest and the domain. For more information about using the Adprep, see
    Active Directory Help. The version of the Active Directory schema of the
    source forest is not compatible with the version of Active Directory on this
    computer"

    I checked MS support site did not get real help. I run "adprep /forestprep"
    on the win 2k3 R2 machine, it did not work. What should I do? Is it not
    compatible between win 2k3 sp1 and win2k3 R2?

    Thank you for any help.
     
    Juliana, May 27, 2006
    #1
    1. Advertisements

  2. did you used the adprep from the second R2 CD?
     
    Frank Röder [MVP], May 27, 2006
    #2
    1. Advertisements

  3. Juliana

    Omar Guest

    Hello !

    This is a know issue a Microsoft Kb is available
    the solution is to user CD2 when doing adprep /forestprep
     
    Omar, May 28, 2006
    #3
  4. Juliana

    Juliana Guest

    Thank you. adprep was run from R2 disk 2 . The error message said something
    like "the computer is not a domain controller that can not run adprep". The
    R2 server is a new server which is going to be installed as additional domain
    controller, of course it has not be a domain server yet. I am confusing,
    adprep should run on the win 2k3 SP1(the domain server) or on the win2k3
    R2(the new server)?

    Could you please help?
     
    Juliana, May 28, 2006
    #4
  5. yes, you must run it on the existing domain controller (w2k3sp1).
     
    Frank Röder [MVP], May 28, 2006
    #5
  6. Juliana

    Juliana Guest

    Frandk, thank you.

    Is it menas the w2k3 sp1 needs to be upgrade to R2 with adprep?
     
    Juliana, May 29, 2006
    #6
  7. yes, for the R2 Features you need to upgrade the AD-Schema on the
    *existing* w2k3 sp1.
     
    Frank Röder [MVP], May 29, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.