error: You do not have the proper privileges to install the applic

Discussion in 'Windows Vista Security' started by lex3001, Jul 13, 2006.

  1. lex3001

    lex3001 Guest

    I am not sure if this is an IE7 issue or a Vista issue. I am using Vista Beta
    2. I am trying to use a corporate VPN site which installs and runs a Juniper
    ActiveX control to connect via VPN. I get prompted and tell IE to go ahead
    and install the ActiveX control. I also turned off Protected Mode in IE and
    got the same result. I also have local and domain admin rights.

    It starts the installation process, and then comes back with the following
    dialog:
    You do not have the proper privileges to install the application

    Works fine in Win XP Pro SP3 and IE6.
    Any ideas on whether or not I can fix this?
     
    lex3001, Jul 13, 2006
    #1
    1. Advertisements

  2. lex3001

    Jimmy Brush Guest

    Hello,

    Even though you are logged in as an administrator, every program you run in
    Windows Vista is only given limited, "normal user" access permissions.

    The only programs that receive full administrator permissions are the ones
    that ask for permission to run (the one where the screen dims and you have
    to click continue is the one I'm talking about, the IE specific ones don't
    count) or the ones where you explicitly give admin permission using Run As
    Administrator (this works differently than Run As... in XP).

    Normally, when you run an Installation program Windows Vista realizes this
    is going to need admin permission and automatically prompts you.

    However, in the case of an ActiveX control needing admin permission, it's
    not so smart.

    The way to get it to work is to open an "elevated" Internet Explorer window,
    which means that you give a specific IE window full admin permission, and by
    proxy, any activex control or other process IE spawns.

    To do this:

    - Click start
    - Find the IE shortcut
    - Right-click it
    - Click Run As Administrator

    And you should have no problems from there. :)

    - JB

    Vista FAQ
    http://www.jimmah.com/vista/
     
    Jimmy Brush, Jul 14, 2006
    #2
    1. Advertisements

  3. lex3001

    lex3001 Guest

    Hi Jimmy,

    Thanks for the help. I'm not sure if this worked or not, but I sure did get
    different results than before. During the networking install process, Vista
    blue-screened, so I guess it had the permission it needed to continue, but
    the software is not compatible with Vista Beta 2 apparently.

    Thanks
    -L
     
    lex3001, Jul 14, 2006
    #3
  4. lex3001

    Jimmy Brush Guest

    Yea if it bluescreened I'd say it worked a little too well ;)

    - JB
     
    Jimmy Brush, Jul 14, 2006
    #4
  5. lex3001

    lex3001 Guest

    Interestingly enough, I rebooted after the BSOD and then tried again, and
    this time the software appeared to install but gave me a message that it
    couldn't connect (presumably to the server it talks to to build the VPN
    connection).

    I think I've had some residual problems from a failed AV install, so I will
    try again after cleaning that up...
     
    lex3001, Jul 14, 2006
    #5
  6. lex3001

    zanderqin Guest

    What I did that worked for me was, with admin priv, right click on your Vista
    partition drive letter, choose properties. On security tab choose
    TrustedInstaller, click advanced, click Owner tab. If you are not able to see
    or highlight your user name click Edit. Highlight your user name. Tick the
    box for replace owner etc. Click Apply then OK. Hightlight user name, click
    Apply then OK. Click Apply then OK. It will take almost ten minutes for you
    to take over ownership, but let it finish.
    Worked for me ever since.
     
    zanderqin, Jul 16, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.