Exchange 2003 on SBS 2003: Unable to manage Public Folders from System Manager

Discussion in 'Windows Small Business Server' started by Anders K. Olsen, Jul 26, 2005.

  1. Hello group

    I have a problem with the Exchange 2003 server on our Small Business 2003.
    When I try to manage the public folders through System Manager, I get the
    following error message:

    The token supplied to the function is not valid
    ID No: 80090308.
    Exchange System Manager

    I have a SSL certificate for our server. The server name is
    gandalf.mycompany.local, but the FQDN of the server is main.mycompany.com,
    and the name in the SSL certificate is main.mycompany.com.

    I have tried to remove the check in "Require secure channel (SSL)" for the
    Exadmin folder and for the Public folder in IIS admin. This didn't solve my
    problem. Besides, we would like to require SSL access to the server.

    We are also running ISA Server 2000 on the server, could that be a problem?

    Any help is highly appreciated.

    Regards
    Anders Olsen
     
    Anders K. Olsen, Jul 26, 2005
    #1
    1. Advertisements

  2. Dave Nickason [SBS MVP], Jul 26, 2005
    #2
    1. Advertisements

  3. Hello Dave

    Thank you for your answer.

    I have looked at that page, but it didn't help me.

    We have bought a SSL certificate that I have published on IIS. The name in
    the SSL certificate is main.mycompany.com, since this is the name we would
    like for the Exchange server on the internet. The internal servername is
    however gandalf.mycompany.local.

    Could this be the reason for our problems? How do I solve this problem then,
    because I wouldn't like to buy another SSL certificate, and I don't want to
    change internal or external name of the server. Is it because the Exchange
    System Manager tries to access the server on the internal name? How do I
    make System Manager access the server using the external name instead?

    Are there any requirements to the SSL certificate? The only property that
    our certificate supports is "Server authentication", and this is also the
    only property that is enabled.

    I have also tried to follow the second resolution on the page: Do not
    require SSL. This didn't help either, besides it is no a solution that I
    would like to follow, since we will require SSL to access OWA.

    Regards
    Anders
     
    Anders K. Olsen, Jul 27, 2005
    #3
  4. Dave Nickason [SBS MVP], Jul 27, 2005
    #4
  5. Hello Dave

    That article only applies to the SMTP, POP3, IMAP4 and NNTP protocols. My
    problem seem to be with HTTP, and this is apparantly controlled via IIS
    admin.

    I'm going on vacation tomorrow, and I don't want to change anything right
    now, since I wouldn't like to break anything this close to my holiday.

    I will look more into it when I get back, and perhaps send another message
    to the group at that point.

    Regards

    Anders
     
    Anders K. Olsen, Jul 28, 2005
    #5
  6. My rule is to never make a change to a working system within 2 weeks of a
    vacation. I hope you enjoy yourself, and do start a new thread when you get
    back. I'll ignore the new one and hopefully you'll find help from someone
    else with more knowledge of this than I : -)
     
    Dave Nickason [SBS MVP], Jul 28, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.