Experts Challenge: MAPI is unable to access Public Folder store items

Discussion in 'Windows Server' started by Guest, Sep 1, 2006.

  1. Guest

    Guest Guest

    Goodday to all of you,

    I have crosspost my messages to several newsgroups.
    Reason for this is that my previous posts to different newsgroups did not
    solve the problem.
    Maybe if I crosspost, there will be an expert that has a solution.
    Also I am not sure to which group I should post my problem.
    Maybe this post long-winded, do not see at as material for a novel!!! - I am
    just trying to explain the exact TERRIBLE situation!
    ---- ---- ---- ----

    I am experiencing a problem with our Public Folder Store.

    All my users are not be able to access e-mail items in the Public Folders
    using their Outlook (2003) client, even though the users have the correct
    permissions.
    If the user tries to open a messages they receive: "Can't open the item. You
    do not have sufficient permission to perform this operation on this object.
    See the folder contact or your system administrator".

    However if the same users tries to access these same items via OWA, they are
    able to read the items.
    Users in subject are so called "Reviewers".
    User with "Owner" rights are able to open and read. Even stranger it
    becomes, once a "Owner" has opened the item, the "Reviewer" will then be
    able to open these items (while before the where not able to).
    In other words, a "Owner" has to open all the message's, before a "Reviewer"
    can.


    I have done many kbid and Google searches, have tried tools like
    PFDAVAdmin.exe and MFCMAPI.exe.
    These tools did not solve anything.
    Also note that this only occurs to e-mail items. Public addresses and the
    public calendar are not effected with above problem.

    Some specifications:
    Microsoft Exchange Server running on a sbs2k3 machine, I recently added a
    new Exchange Enterprise Server (win2k3) in the domain.
    But this was for testing only. After the new Exchange was added to the
    domain (and a test mailbox was moved) above problems started to occur.
    Currently the new Exchange Server has been removed from the domain (test
    mailbox is back on the SBS), because I was hoping this would solve the
    problem.


    I know I am not the only one that has experienced this behaviour, I have
    seen many posts (going back to 2003) about this problem.
    Example:
    http://groups.google.nl/group/micro..._frm/thread/3b2386aab163684c/8014cce2859581ab
    But all these post I have seen, are unsolved or remain unanswered.
    Therefore I must assume there is no expert in the msnews that has a solution
    to this!!!???
    Can't be, come on experts, please help me out!
     
    Guest, Sep 1, 2006
    #1
    1. Advertisements

  2. Guest

    Guest Guest

    Even set to always request username and password, reviewers are still not
    able to open items in the PBFstore.
    Users only have one profile in use.

    --
    «·´`·.(*·.¸(`·.¸ ¸.·´)¸.·*).·´`·»
    «.............. CHARLIE ..............»
    «·´`·.(¸.·´(¸.·* *·.¸)`·.¸).·´`·»


    <> schreef in bericht
    Try setting the user's Outlook profile to always request username and
    password. Look to see if they are using multiple profiles with
    different authentication properties. I had to do this on mine and it
    cleared up. The tell-tale clue is that it works in OWA, which requests
    authentication if you are using Forms-Based Authentication.

    Matt
     
    Guest, Sep 2, 2006
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    I have changed the permissions for the users overnight from reviewer to
    owner.
    However once the permissions where set back to Reviewer the problems where
    back again.

    Instead of a kick start, don't you have some hotwires?

    --
    «·´`·.(*·.¸(`·.¸ ¸.·´)¸.·*).·´`·»
    «.............. CHARLIE ..............»
    «·´`·.(¸.·´(¸.·* *·.¸)`·.¸).·´`·»


    <> schreef in bericht
    What happens if you take of the PFs that's having issues, change the
    perms so that they are owners, see if it takes and if it does change it
    back to the original reviewer, kinda like giving it a kick start.

    James Chong
    MCSE M+, S+, MCTS, Security+
    msexchangetips.blogspot.com
    ftp://mail.msexchange911.net/
     
    Guest, Sep 3, 2006
    #3
  4. Call PSS.
     
    Andy David - MVP, Sep 3, 2006
    #4
  5. Guest

    Guest Guest

    Just an update to let you know I have found a workaround for my problem.

    After doing a little bit of Google searches on this thread:
    http://groups.google.nl/group/micro..._frm/thread/3b2386aab163684c/8014cce2859581ab

    I found out that it is just another Microsoft bug.
    I (also) don't understand why Microsoft does not acknowledge this bug, since
    it's pretty fundamental.
    How on earth did this get past beta testing???

    The workaround is as following:

    ** ** ** ** ** ** **
    Enable Cached mode and make sure you have the check box for "download public
    folder favourites checked.
    Then add any public folder you want to view to the public folder favourites.
    You can then view them from that location.

    I don't think this is a very good solution but until one is found, that
    should at least get to the point of viewing them.
    Hopefully an actual fix will come out soon*.
    ** ** ** ** ** ** **

    Found the solution at:
    http://groups.google.nl/group/micro...a0e84?lnk=st&q=&rnum=4&hl=nl#91f82ec6acda0e84

    * Note that it was posted around November 6'th 2003 ===> And still not any
    hotfix available from Microsoft!
    Don't think the will do so, since they already start beta testing of Office
    2007 and Exchange 2007 which do not have Public Folders by default.
    I understand Microsoft is "de-emphasizing" Public Folders.......... (why are
    the doing this.......)

    --
    «·´`·.(*·.¸(`·.¸ ¸.·´)¸.·*).·´`·»
    «.............. CHARLIE ..............»
    «·´`·.(¸.·´(¸.·* *·.¸)`·.¸).·´`·»

     
    Guest, Oct 3, 2006
    #5
  6. In
    What exactly *was* the problem? It doesn't appear in the quoted text in this
    thread....
     
    Lanwench [MVP - Exchange], Oct 11, 2006
    #6
  7. Guest

    Guest Guest

    Hi Lawench,

    The problem *was* as following:

    --
    «·´`·.(*·.¸(`·.¸ ¸.·´)¸.·*).·´`·»
    «.............. CHARLIE ..............»
    «·´`·.(¸.·´(¸.·* *·.¸)`·.¸).·´`·»


    "Lanwench [MVP - Exchange]"
     
    Guest, Oct 20, 2006
    #7
  8. Guest

    Guest Guest

    Hi Lawench,

    The problem *was* as following:

    --
    «·´`·.(*·.¸(`·.¸ ¸.·´)¸.·*).·´`·»
    «.............. CHARLIE ..............»
    «·´`·.(¸.·´(¸.·* *·.¸)`·.¸).·´`·»


    "Lanwench [MVP - Exchange]"






    "Lanwench [MVP - Exchange]"
     
    Guest, Oct 20, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.