Exteamly slow internet access (not LAN access)...SPI on router??

Discussion in 'Windows Vista Networking' started by Sterck, May 26, 2006.

  1. Sterck

    Sterck Guest

    in reference to this thread:
    http://windowshelp.microsoft.com/co...90fb-472c-855a-4190c229a1a8&lang=en&cr=US&p=1

    I too am having extreamly bad internet performance. This has been common
    across many builds, such as beta one. Feb CTP and now Beta 2. First the
    background..

    I run a pretty decent LAN at my house. I have a cable modem running 450/5mb
    roughly. I have that going into a Cisco 831 router, gigabit managed switch.
    I am runnin a win 2k3 server with AD. My network works well. I have 4-5
    computers on the network (with random laptops), 2 networked ReplayTV, an Xbox
    and PS2.

    On my living room machinge:
    AMD 2600+, 1gb ram, GeForce 5900

    I am using this box as my Vista testing site. Vista is slow. It pretty
    much idles at 500+mb RAM utilization. But with Beta 2, things (aside from
    memory) things are running really decent. I can copy ISO files from my
    domain controller to the Vista client in 15 or so seconds.

    My main concern is when I go to request a web server outside of my network,
    performance is terrible. Go to Nvidia.com to get the latest Vista graphics
    driver, and 1/3 of the page loads and then just keeps trying with no luck.
    Wait 30 mins, and come back, still waiting.

    Gettin a critical update from windows update is at 19% after 3-4 hours
    (trying to pull down 2.7mb)

    I read the threat that posted above, and it looks like the SPI part is the
    cuplrit. This sucks. Its not like Im running a low quality router, my Cisco
    831 is a decent guy and Im running the advanced IOS on it that can do crazy
    things like HSRP.

    Does anyone have any work arounds besides dumbing down the router? I cant
    imagine what will happen when IT companies around the world try to put Vista
    on their corporate lans to find out that web surfing is essentially disabled.


    MS, any help on this? Its existed on at least the last two major public
    builds.

    Jeff
     
    Sterck, May 26, 2006
    #1
    1. Advertisements

  2. Sterck

    Doting Daddy Guest

    I have a Linksys RV016. I had to shutdown the firewall functionality
    completely in order to overcome the problem. Shutting down SPI wasn't nearly
    enough.
     
    Doting Daddy, May 27, 2006
    #2
    1. Advertisements

  3. Sterck

    wmcmillen Guest

    VERY GOOD Info!!!

    I have just started with Vista Beta 2 - this problem is alive and well and
    was killing me. Amazingly I had thrown every logical combination that in one
    way or another is discussed through out these postings...

    1) Thought IE7 issue... lowered security, etc - not it.
    2) User Account Protection - no avail.
    3) Windows Firewall - disabled from the start - I use a SonicWALL with
    Enhanced OS so I always scratch the Windows Firewall.
    3) Put in an another NIC - no change.
    4) Upgraded my memory from 512 to 2GB - no help
    5) Scratch and reload - hoping for a driver.
    6) Started searching my SonicWALL logs to see if it would show me any
    reports of blocking or thinking Vista was some sort of "internal port scan"

    All of this being done over the last 2 days before I found this post....
    Putting alot more information then necessary here in hopes it will help
    others with key words, etc.

    I am running an AMD 3000+, Soltek MB, NVIDIA Chipset, SonicWALL TZ170 with
    Enhanced OS. Base point here is that there is some sort of HUGE FLAW with
    Vista's TCP/IP stack for Internet Bound traffic, Windows update, Websites,
    etc - just like some have said - I let a 5.3MB update try to load for over 15
    hours and it had only made it 19% of the way (I should note these types of
    speed from a person & same machine that can download 220MB files in 14
    minutes from Microsoft). Websites for simple browsing were taking upwards of
    30 minutes to load.

    SOLUTION - Kill your Hardware Firewall, SonicWALL, DLINK, Cisco/Linksys, etc
    - you either have to be able to turn off SPI (By the way the newer generation
    of SonicWALL's go way beyond SPI doing a Deep Packet Inspection). Just for
    the record I could not find a real easy way to turn this off in my SonicWALL
    so my solution as I type this was to go get an old Linksys - put it in place
    and turn off the firewall on the BEFSX41.

    Basically I have turned my computer into a sitting duck out on the
    internet... but at least now I have a starting place.

    Tomorrow is the holiday, but on Tuesday I will be in a Vista class held by
    Microsoft in Central IL - I will talk to the folks there about it as well as
    get digging through our MSDN & Gold partnership channels. If I find anything
    about a "REAL SOLLUTION" I will pass the info along -

    Thank you folks so much for posting the previous informaiton... I was about
    to loose my mind over this one.
     
    wmcmillen, May 28, 2006
    #3
  4. Sterck

    Sterck Guest

    Im anxious to hear if they mentioned this anywhere in your group? Is anyone
    else having issues like this? Its a pretty big hinderance.

    Jeff
     
    Sterck, Jun 2, 2006
    #4
  5. Sterck

    mdod Guest

    I have the same problem with both the motherboards NVIDIA MCP 10/100
    connector, and a NETGEAR GA311 10/100/1000 PCI card.

    Only by opening the device manager and manually setting the network cards
    communication speed to 10meg Full Duplex can reasonably reliable internet
    access be obtained on my machine. Even then download speeds are very slow and
    erratic.

    Beta 2 installs a generic Reltek RTL8169 Gigabit Ethernet adapter driver for
    my Netgear GA311, but all attempts to access the web come to a screeching
    halt after just a few seconds.

    Disabling all the security options brings no improvement.
    Firefox has no better success than I.E.7 with communication speed set on
    default auto.
    On previous builds bypassing all the gigabit hardware and connecting the
    motherboard network connector directly to the router was an effective
    workaround, but even that doesn’t help on this build.

    Vista Beta 2 Build 5384
    Shuttle SN41G2
    Shuttle FN41 Motherboard
    AMD XP 3000+ processor
    2GB Corsair DDR3200 memory
    Netgear GA311 Network card
    Netgear GS605 Switch
    Netgear DG834G ADSL Router
    Radeon 9600 Graphics

    Mike
     
    mdod, Jun 12, 2006
    #5
  6. Sterck

    [crobar]Phil Guest

    I have a linksys RV016 as well. I have to turn the firewall completely off in
    order to connect to most websites. I couldn't even activate vista. As soon as
    I turned it off. BOOM worked fine. Tried just turning SPI off. No dice. Next
    I'll try putting the Vista PC on the DMZ and see if that works.
     
    [crobar]Phil, Jun 13, 2006
    #6
  7. Sterck

    [crobar]Phil Guest

    In the same boat here. Linksys RV016 had to turn the firewall off completly
    in order to activate, update or browse most websites. Just turning SPI off
    did not work. Next I'll try the DMZ port. This is so basic I don't understand
    how Vista can be in Beta 2 with a bug like this.
     
    [crobar]Phil, Jun 13, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.