F IT!!! I GIVE UP!! I GUESS I WON'T GET UPDATES THEN HUH? SP2? SEC

Discussion in 'Windows Update' started by Tre2004, Aug 12, 2004.

  1. Tre2004

    Tre2004 Guest

    http://www.microsoft.com/windowsxp/...-us-ms-winxp&lang=en&cr=US&sloc=en-us&m=1&p=1

    I have asked this about 3 different times.. I can't find an answer! I give
    up, I'm tired of stressing over it. I have been waiting for 3 days to get an
    answer, and I get 0 RESPONSES.. THANX FOR THE HELP. NO REALLY. I have took up
    for MICROSOFT I dont' know how many times... tell people that they care..
    which I still think they do. I just dont' know how to ASK THEM.. the people
    out here representing them isn't doin them any justice. GO AHEAD, tell me I
    won't get an answer with this attitude, like I said.. I GIVE UP.. I'm not
    getting an answer anyway. So HELL WITH It.
     
    Tre2004, Aug 12, 2004
    #1
    1. Advertisements

  2. Kaylene aka Taurarian, Aug 12, 2004
    #2
    1. Advertisements

  3. Sorry to hear about your problems...

    Lets start by trying to re-register a WUv5 control. To do this you simply:

    1. Press Start
    2. Select Run
    3. Type in "regsvr32 wuweb.dll" (without the quotes)
    4. Press OK

    Then try and access Windows Update v5 again.

    Please let me know if that doesn't work for you, and we will try other
    methods of getting this to work for you.

    -David Herman
     
    David Herman .:MVP:., Aug 12, 2004
    #3
  4. Tre2004

    Tre2004 Guest

    hey David,
    I just now tried that, I typed that in and it said that it was sucessfull,
    then I tried to go to the V5 page and it went to the V4 page again..
    I even tried deleteing the V4 folder, and removing the active x file.. then
    went back to windows update and it was the V4 site again!! I would change the
    V4 to V5 and it would act like it was goin to V5, but then it would go to
    V4!!! Then I had to reinstall the Active X file...

    Can you tell me this? If I have SP2... will V4 still work?? Will I get my
    updates? Cause I heard that SP2 only uses V5... Can you think of anything
    else to try?
    And how would I get ahold of microsoft?
     
    Tre2004, Aug 12, 2004
    #4
  5. You will still be able to update your computer using v4, but I am not sure
    for how long.

    Let me get some advice from Microsoft and I'll get back to you.

    -David Herman
     
    David Herman .:MVP:., Aug 12, 2004
    #5
  6. Tre2004

    Tre2004 Guest

    ok, thank you. I still havn't been able to find out how to fix this. And I
    don't really know if I should even be stressing over this. It is just weired
    that I could only go to the v5 page that one day. Everyone else I have talked
    to said that they could go to the V4 page AND the V5 page.
     
    Tre2004, Aug 13, 2004
    #6
  7. Tre2004

    Tre2004 Guest

    I just got off the phone with a microsoft SP2 tech, and she had me do a few
    things and they didn't work. She had me go to System info and had me read the
    version number and she said since I have a MEDIA CENTER EDITION PC that the
    "Network SP2 UPDATE' on the microsoft page that I installed was the wrong
    one. She said that HP would have their OWN update that would be for my PC.
    Does this sound right? I mean... it makes sence, but everyone in the
    newsgroups said that it really didn't matter.

    Here is what is under "version" in system info.. if you have SP2 please
    tell me what yours says...

    Version 5.1.2600 Service Pack 2 Build 2600

    And here is what is in Hardware Abstraction Layer...
    Hardware Abstraction Layer Version = "5.1.2600.2180
    (xpsp_sp2_rtm.040803-2158)
    --------------------------------------------------------------------------------
    She said that the version number that I have was suppose to change.. is that
    right? Cause I asked someone that and they said that I could find out what
    version I had by looking at the hardware abstraction Layer

    Thanx for the help, i guess I am about to go uninstall SP2 :( HP better
    hurry with the update... HEHE
     
    Tre2004, Aug 13, 2004
    #7
  8. Can you please tell me who you spoke to, I think I should drop them a little
    email ;)

    In answer to your question, it shouldn't make a difference (I think)

    Give me another day to get to the bottom of this.

    -David Herman
     
    David Herman .:MVP:., Aug 13, 2004
    #8
  9. What she told you was totally incorrect, the "Network SP2 update' (and
    the Web Express/WU update) is for all brands of Windows XP, also the
    Media Center Edition. HP is not going to have their own version of SP2.

    That is not right, this number is not going to change.
     
    Torgeir Bakken \(MVP\), Aug 13, 2004
    #9
  10. Tre2004

    Tre2004 Guest

    Are you guys serious??? I'll be damned.. This is 2 days in a row that I have
    removed it!!!! I gues she just couldn't find out how to help me, so she gave
    up or something.. Does your guys say the same thing that mine did under
    "VERSION" cause that is what she went by saying that it didn't install right
    on mine, Then I told her about installing the network install or whatever,
    and she said "that is what it is, that is the wrong version for your pc" She
    said that media center pc's were OEM or whatever, and that it would be a
    different version..
    Even now after removing it I still can't go to the V5 site like I could that
    first day. I can't believe that a SP2 help Tech was wrong like that.. that is
    crazy.. can you guys try to find out for sure? I do appreciate the help.
    I can't remeber her name, but I called 1 888 SP2 HELP
    LOL, they helped alright
     
    Tre2004, Aug 14, 2004
    #10
  11. Hi

    The version information you listed is correct for the final version
    of SP2 (same as what I have), and it is the correct version for your
    computer (Media Center Edition):

    Version 5.1.2600 Service Pack 2 Build 2600

    Hardware Abstraction Layer Version = "5.1.2600.2180
    (xpsp_sp2_rtm.040803-2158)"
     
    Torgeir Bakken \(MVP\), Aug 14, 2004
    #11
  12. Tre2004

    Tre2004 Guest

    ok, thank you.. I will install it... AGAIN hehe
    Hey TOGEIR BAKKEN,
    When you go to windows update, does it take you to the v4 page or the v5? I
    can't get mine to take me to the V5 page... even if I remove the V4 folder...
    is there any way that you could look into that for me? Cause I heard that the
    V5 site was for getting updates for SP2, and if I can't go to it, then I
    won't be able to get new updates for it if they come out... I really
    appreciate it.
    THANX ALLOT about the info on SP2 for my MCE.... I can't believe she told me
    to remove it... that is crazy
     
    Tre2004, Aug 15, 2004
    #12
  13. Can you remember who you spoke to in the PSS team at Microsoft. I'd just
    like to make sure that miss-leading information is not being given out. Name
    or Incident number would be great, or even your details (please email me
    rather than putting here).

    Also, have you made any adjustments to your HOSTs file? Let me know if you
    need more info on what to check.

    Thanks,

    -David Herman
     
    David Herman .:MVP:., Aug 15, 2004
    #13
  14. Your symptom could be explained by an erroneous override in your
    HOSTS file or (less likely) in your dnscache or in your ISP's DNS.

    Particularly questionable along this tack was your earlier statement
    about your firewall:

    Subject: Can't access V5 With SP2 for the love of god someone tell me somet
    Date: Wed, 11 Aug 2004 13:27:04 -0700

    <quote>
    I added a Advanced Rule in Sygate Personal Firewall pro To allow ALL
    protocals for Svchost or whatever with certain ip address's that someone
    gave in another thread that was for windows udate.
    </quote>


    It's the "certain IP address's" that bothers me. It could imply that
    a server which was once V5 is now V4. In general you can't rely
    on those IP addresses being reusable for a long time.


    Try these tests:

    Use nslookup to find out which addresses are now in use for the V5 name.

    ping -n 1 that same name. Does it show one of the addresses that
    you were given by nslookup? If not that means there is an override
    to the lookup somewhere, probably in the HOSTS file.

    See what happens when you try to telnet to the _site_ at port 80.
    (If your firewall somehow blocks telnet give it the same permissions
    that you are giving "Svchost or whatever" and try again.)
    If you can get connected with telnet to port 80 the command window
    will clear. At that point you can try to simulate enough of what IE would
    be doing to capture what IE would be seeing. E.g. type GET /
    (That's GET <space><slash><Enter>.)
    However, it would be better to capture the data flow for an actual
    attempt by IE to connect. You could do that with netcap or
    Ethereal.

    If the ping test shows there is an override try the telnet test
    (and perhaps even an IE connection attempt) with one of the
    IP addresses that nslookup gives.

    Tell us any differences you detect between the two sets of tests
    (i.e., using site name versus using IP address.)


    Good luck

    Robert Aldwinckle
    ---

    ....
     
    Robert Aldwinckle, Aug 15, 2004
    #14
  15. Tre2004

    Tre2004 Guest

    HEY Robert,
    Right before I read this msg I had removed the advanced rule in my firewall.
    I just thought of it, that it might have had something to do with it, but it
    didn't help..

    But about the two tests you are talking about... can you explain how to use
    those? I know how to ping.. in CMD
    But I'm not familiar with NSLOOKUP, or TELNET.. Those sound like they would
    be a good thing to try,
    And what would I need to look for in my host file? What would need to be in
    there for me to be able to go to v5? I will look and see.
     
    Tre2004, Aug 15, 2004
    #15
  16. Tre2004

    Tre2004 Guest

    ok, I figured out that I just type NSLOOKUP, or TELNET in the cmd window.. I
    did nslookup... then v5.windowsupdate.microsoft.com and it gave me 3 ip's for
    it, and on TELNET I tried to connect to port 80 but it wouldn't let me, and I
    couldn't find it in my firewall under applications like PING, NSLOOKUP, and
    such is.
    And in the hosts file, there is nothing to do with windows, windows update,
    v4 or v5 or nothing like that. ALSO, I tried IPCONFIG /FLUSHDNS

    Is there anything that I can do now? In IE, when I would type the ip
    addresses from V5 that I got from NSLOOKUP, it started to go to v5, and then
    back to v4..
    I SWEAR, it is like it is forwarding it back to V4 or something..
     
    Tre2004, Aug 15, 2004
    #16
  17. Does that mean that you should include telnet in your firewall then?

    Could you bypass your firewall and just use the XP firewall instead?

    If you can't get telnet working but have XP Pro there is actually
    a better tool which wouldn't be affected by the firewall, called netcap.
    That captures the packets into a .cap file which is a binary file.
    However, since the HTTP protocol is largely character based
    you could probably get quite a bit out of it just by browsing it with Notepad.
    To actually format the .cap file I use Ethereal (freeware.)


    To allow you to check if the problem is being caused by your DNS
    here is what my nslookup for that alias looks like:

    Non-authoritative answer:
    Name: v5windowsupdate.microsoft.nsatc.net
    Addresses: 64.4.21.188, 207.46.157.29, 207.46.253.92
    Aliases: v5.windowsupdate.microsoft.com


    In case you do manage to get telnet working here is an example of
    what you could capture with it:

    HTTP/1.1 302 Object moved
    Date: Mon, 16 Aug 2004 04:16:41 GMT
    Server: Microsoft-IIS/6.0
    X-Powered-By: ASP.NET
    Location: /v5consumer/default.aspx


    Hmm... that suggests that you could avoid that redirection with IE
    by giving that as part of the full URL. E.g. perhaps if there is a DNS error
    this will at least give you a 404 to clue you in that you're connecting to
    a wrong server:

    http://v5.windowsupdate.microsoft.com/v5consumer/default.aspx?ln=en

    (I'm not sure when the last bit gets tacked on but that is what is in my
    Address bar now.)


    Here's a surprise: WU didn't like me replacing that name by *any* of
    those IP addresses, though the Privacy Report (Alt-V,v) shows that it
    tried using them that way. They all come up with We're Sorry...800c0002
    Even the canonical name gets 800c0002.

    There doesn't seem to be *anything* that I can do to use any of those
    IP addresses directly. I tried putting one of them in the Trusted Sites
    security zone and I tried using https: as a protocol prefix for two of them.

    So, if you find that your DNS is not giving you any of the above IP addresses
    it looks as if you won't be able to use one just by plugging it in to the URL.
    The only thing I haven't tried yet is putting one in my HOSTS file.
    The only advantage that I can see from doing that is that it would avoid
    a small problem I saw where I was getting a prompt about the certificates
    not matching the site name which I Ok'd. Perhaps I'll try that in order to
    try to get a better understanding of how it works but for now it could be
    something for you to try if you have no other options.


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Aug 16, 2004
    #17
  18. Hi,

    Can you try the following?

    Enable ActiveX controls in Internet Explorer

    1. Start Internet Explorer

    2. On the Tools menu, click Internet Options.

    3. Select the Security tab.

    4. Select the Internet Web zone icon.

    5. Click Custom Level, and then select Enable for the following items:

    Download signed ActiveX controls

    Download unsigned ActiveX controls

    Initialize and script ActiveX controls not marked as safe

    Run ActiveX controls and plug-ins

    Script ActiveX controls marked safe for scripting

    6. Click OK, and then click OK again to exit.





    This could also occur if the firewall blocks the ActiveX control.



    Configured Proxy/Firewall to allow the following urls:



    http://*.windowsupdate.microsoft.com

    https://*.windowsupdate.microsoft.com

    http://*.windowsupdate.com



    For help configuring Proxy/Firewall refer to documentation or contact the
    manufacturer.



    -Dave
     
    David Herman .:MVP:., Aug 17, 2004
    #18
  19. If you aren't going to try any of the tests I suggested could you at least
    post back the results of these so David isn't wasting his time?

    Open a command window and enter:

    nslookup v5.windowsupdate.microsoft.com

    Copy the Name: Addresses: and Aliases: lines which are returned


    Next enter:

    ping -n 1 v5.windowsupdate.microsoft.com

    Copy the Pinging... line. We don't care is the request times out.


    If you fixed your firewall to allow telnet to be used and you are interested,
    here is how to capture what IE might be seeing after its first request:

    telnet -f telnet.txt v5.windowsupdate.microsoft.com 80

    Assuming that this results in the screen clearing you can enter: GET / (That's typing GET<space><slash> and pressing <Enter>.
    You won't be able to see what you are typing.)

    To capture the output you can open the telnet.txt file in Notepad.


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Aug 17, 2004
    #19
  20. Tre2004

    Tre2004 Guest

    uhhh, I said that I didn't know how to use telnet, and the others... I found
    out how to use the nslookup, to get the ip address's
    and I enabled the stuff in internet options, advanced...
    I still can't do anything.. Hell I dont' know what the hell to do. I'm just
    pissed off, cause i talked to another TECH and they told me to uninstall it
    again... said that it wasn't for my machine, cause mine is only ONE machine,
    and the SP2 that I installed was for NETWORKS... that was after waiting on
    hold for 30 mins, and then trying a few other things... that I had told her
    that I already tried.... about an hours worth call, for her to tell me to
    remove it...
    I guess I need to follow the name of the subject... I give up
    but I do thank you guys sooo much for trying to help out, YOU GUYS are the
    only people that have tried to help me, and I have been working on this since
    like the 10th... EVERYDAY!!!

    It is just disheartening, ya know? I can't stand when I try to fix
    something, and can't find out how to do it.. Cause you always know that there
    is a fix... know what I mean? But I will try what you just posted, I didn't
    know how to do that...

    Thanx guys, seriously... I do appreciate it
    I wish there were more people like you guys out there..
     
    Tre2004, Aug 17, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.