File sharing problems - "your folder could not be shared"

Discussion in 'Windows Vista Networking' started by bjterp00, Aug 13, 2007.

  1. bjterp00

    bjterp00 Guest

    I am having a terrible time trying to share files from my Vista Home Premium
    PC with my wife's PC (same OS). I am able to access her files, but not vice
    versa. After lots of searching and trying, and even call to Microsoft, I am
    still stuck.

    Please do not respond to this with a link about how to setup a home network.

    If I follow all the instructions exactly, I still get to "Your folder could
    not be shared" when I try to share one of my folders. Even though this
    message comes up, going back to check the folder by right clicking and
    checking the properties, it looks like sharing and permission are both setup
    correctly to share.

    However, if I try to access my shared folders from my PC by going to network
    then picking my computers name (BILL-LAPTOP) or if I try to access
    BILL-LAPTOP from my wife's PC, we both get the error:

    \\bill-laptop\c_drive is not accessible. You might not have permission to
    use this network resource. Contact the administrator of this server to find
    out if you have access permissions. Windows cannot find the network path.
    Verify that the network path is correct and the destination computer is not
    busy or turned off. If Windows still cannot find the network path, contact
    your network administrator

    As an FYI, here is the latest email I sent back to my Microsoft support
    agent. For $60, I am hoping they can figure this out.

    I still cannot share files from my computer to be shared by other computers
    on my home network. I can, however, access shared files on my wife’s laptop
    with no problem. Both are running Vista Home Premium.

    I have take the following steps to “start over†from scratch:

    1. Uninstalled Norton Internet Security 2007
    2. Rebooted
    3. Turn off network discovery, file sharing, and password protected sharing
    4. Rebooted
    5. Turn on network discovery, file sharing, and password protected sharing
    6. Rebooted
    7. Attempted to share various folders, but always get “Your folder could not
    be shared†error message every time, regardless of folder.
    8. Went in to c: properties, added “everyone†to the permissions, then
    enabled a share called “c_drive†which made the share path
    \\bill-laptop\c_drive
    9. Still cannot access this share from my wife’s PC, and cannot even access
    it from my PC if I go to Network  bill-laptop  c_drive because I get the
    error message \\bill-laptop\c_drive is not accessible. You might not have
    permission to use this network resource. Contact the administrator of this
    server to find out if you have access permissions. Windows cannot find the
    network path. Verify that the network path is correct and the destination
    computer is not busy or turned off. If Windows still cannot find the network
    path, contact your network administrator
    10. This is the same error message that my wife receives if we try to access
    \\bill-laptop\c_drive from her computer
     
    bjterp00, Aug 13, 2007
    #1
    1. Advertisements

  2. bjterp00

    Malke Guest

    (snippage)

    Where are the folders located which you are trying to share? Tell us the
    full path, please.


    Malke
     
    Malke, Aug 13, 2007
    #2
    1. Advertisements

  3. bjterp00

    bjterp00 Guest

    The folders are in my user folder.

    c:\users\<username>\Documents\Miscellaneous
    c:\users\<username>\Pictures\
    c:\users\<username>\Documents\Temp

    The Microsoft tech setup my entire c: drive to be shared by setting
    permissions so "everyone" could have full control, and setting a share up as
    \\bill-laptop\c

    None of this has worked.

    :
     
    bjterp00, Aug 13, 2007
    #3
  4. bjterp00

    Malke Guest

    1. Assign passwords to both user accounts on both machines if you have
    not already done so. You can set the machines to automatically log into
    the desired user account for convenience the same way as with XP:

    Configure Windows to Automatically Login (MVP Ramesh) -
    http://windowsxp.mvps.org/Autologon.htm

    2. Create identical user accounts and passwords on both computers. You
    don't ever have to log into the second user account; it just needs to be
    there.

    3. Make sure you have set your Local Area Network to "private".

    4. There is no reason to share a Temp directory. Don't do this. If this
    is a directory you created for something like "work in progress", rename
    it to anything except "Temp", "Temporary Files", or the like.


    Malke
     
    Malke, Aug 13, 2007
    #4
  5. bjterp00

    bjterp00 Guest

    Steps 1 - 3 are and always have been in place since I have been trying to get
    this working.

    Step 4 -- I just created a folder called 'temp' in my documents then tried
    to share it to see if a new folder could be shared. This was not a temp
    directory in the system sense.

    Any other thoughts? Any ideas what triggers the "your folder could not be
    shared" error message?
     
    bjterp00, Aug 13, 2007
    #5
  6. bjterp00

    Malke Guest

    Sorry, not without seeing your network. You are definitely doing
    something wrong but there is no way for me to know what. I've had no
    problems sharing between Vista Ultimate, XP Home, XP Pro, Linux and OS X
    on my own network and in setting up home networks for clients.
    Therefore, even though you said you specifically did not want to be
    given links, basic instructions, etc., I can only suggest you go through
    them systematically once again or have a local professional familiar
    with Vista (and networking in general) come on-site and set you up.

    In general, problems sharing files between computers on a network are
    generally caused by 1) a misconfigured firewall; or 2) inadvertently
    running two firewalls such as the built-in Windows Firewall and a
    third-party firewall; and/or 3) not having identical user accounts and
    passwords on all Workgroup machines; 4) trying to create shares where
    the operating system does not permit it. You say you've done all those
    things and still can't share files so something is wrong, but I'm afraid
    I can't guess what. Perhaps someone else reading this thread will have a
    better idea; however, often someone skilled who can actually *see* the
    machines involved will immediately find the issue where people just
    reading about it in a newsgroup will not.

    Best of luck and I'm sorry I was unable to help you.


    Malke
     
    Malke, Aug 13, 2007
    #6
  7. bjterp00

    GTS Guest

    This won't solve your problem but might help narrow it. I suggest creating
    a new folder off the root and seeing if that can be shared successfully.
    Please let us know the result..
    --
     
    GTS, Aug 13, 2007
    #7
  8. bjterp00

    bjterp00 Guest

    Interesting ... I created a new folder, right clicked to share and it ended
    up being shared successfully. I did not get the "Your folder could not be
    shared" error message. That said, I was still unable to access it from
    either my PC by going to \\bill-laptop\testing or from my wife's PC.

    I then tried to share an existing folder and got the message "Your folder
    could not be shared" just as previously.

    I double-checked by Norton firewall history to make sure there were no
    blocks. It did not report blocking my wife's computer, so I do not thing
    that is the issue.
     
    bjterp00, Aug 14, 2007
    #8
  9. bjterp00

    GTS Guest

    It seems as if there are 2 different problems going on. I'm thinking about
    the inability to share an existing folder - that one is a puzzle.
    As far as access to the new share, if password protected sharing is
    currently enabled, do you have a matching user for your wife's machine on
    yours? If you open a command prompt on your wife's PC and run >start
    \\bill-laptop\testing what error message is reported?
    --
     
    GTS, Aug 14, 2007
    #9
  10. bjterp00

    bjterp00 Guest

    I can only hope that it is only 2 problems with this new OS. I miss my XP
    even though it was getting sluggish. This OS started sluggish with a fast
    new dual-core machine. But, sorry for the diversion.

    If I run \\bill-laptop\testing from my wife's PC, I get the error that has
    been showing up whenever I try to access \\bill-laptop\ from her PC (whether
    by command lind, going into network, etc.), which follows:

    \\bill-laptop\c_drive is not accessible. You might not have permission to
    use this network resource. Contact the administrator of this server to find
    out if you have access permissions. Windows cannot find the network path.
    Verify that the network path is correct and the destination computer is not
    busy or turned off. If Windows still cannot find the network path, contact
    your network administrator

    I double-checked last night that her username and password were the same on
    both PCs and they are. I also disabled password protected sharing and it
    still didn't work.

    I appreciate the ideas ... please keep them coming since I am out of my own
    hypotheses / ideas.

    I am supposed to get a phone call from Microsoft tonight at 9 pm. If they
    resolve the issue, I will post the solution here in case others have the same
    problem.
     
    bjterp00, Aug 14, 2007
    #10
  11. bjterp00

    GTS Guest

    Sorry, but I've had no new ideas on this. Did you make any headway with
    Microsoft?
    __
     
    GTS, Aug 16, 2007
    #11
  12. bjterp00

    bjterp00 Guest

    Hi - I posted the results, but not as a reply to your last post. Here you go:

    All -

    Thanks for the help. As it turns out, my issue was something that was not
    obvious even to Microsoft support. After about 4-5 hours on the phone with
    Microsoft over a few days, my problem is resolved.

    The network browser service was not working correctly. The tech tried to
    stop and
    restart it, but it would not restart. So, he had to copy over the part of
    the registry that pertains to the browser service from his Vista setup to
    mine. This corrected the issue.

    He said that maybe trying to repair my Vista installation would have fixed
    this. He hypothesized that an installation issue caused this problem, which
    is not confidence inspiring since my PC came from Lenovo pre-loaded with
    Vista.
     
    bjterp00, Aug 17, 2007
    #12
  13. bjterp00

    bjterp00 Guest

    All -

    Thanks for the help. As it turns out, my issue was something that was not
    obvious even to Microsoft support. After about 4-5 hours on the phone with
    Microsoft over a few days, my problem is resolved.

    The browser service was not working correctly. The tech tried to stop and
    restart it, but it would not restart. So, he had to copy over the part of
    the registry that pertains to the browser service from his Vista setup to
    mine. This corrected the issue.

    He said that maybe trying to repair my Vista installation would have fixed
    this. He hypothesized that an installation issue caused this problem, which
    is not confidence inspiring since my PC came from Lenovo pre-loaded with
    Vista.
     
    bjterp00, Aug 17, 2007
    #13
  14. bjterp00

    GTS Guest

    Interesting. Thanks for the update.

     
    GTS, Aug 17, 2007
    #14
  15. bjterp00

    Jordan C Guest

    Hello, I have a Lenovo laptop and am having the exact problem identified above. I have tried all the steps with no luck. I assume the registry correction will also fix my problem. Do you have a copy of the registry correction or more information so I can duplicate the fix? Thanks!

    EggHeadCafe - .NET Developer Portal of Choice
    http://www.eggheadcafe.com
     
    Jordan C, Aug 24, 2007
    #15
  16. Hi. Can you please paste the registry he changed

    I think the problem is with OEM versions of Vista since some peopl
    said their Vista came preinstalled..
     
    joseamirandavelez, Dec 29, 2007
    #16
  17. bjterp00

    bjterp00 Guest

    Sorry -

    I do not know exactly what was done. However, my problem has recurred, and
    MS email support was unable to assist, referring me back to the phone line,
    which I've not yet had time to call. Frustrating that they cannot
    communicate with one another to solve my problem.

    If I do get it solved via the phone support, I will post what was done.
     
    bjterp00, Jan 1, 2008
    #17
  18. bjterp00

    bjterp00 Guest

    Jordan -

    Did you ever get resolution to this issue? If so, could you post the results?
     
    bjterp00, Jan 1, 2008
    #18
  19. bjterp00

    bjterp00 Guest

    Okay, here's what the fix ended up being:

    Despite correct settings in my firewall, network & sharing center, etc., the
    actual connection was not setup to have "File & Printer Sharing for Microsoft
    Networks" enabled.

    So, go to Control Panel => Network & Sharing Center => Manage Network
    Connections

    Right-click on the connection you're using (in my case, "Wireless Network
    Connection", click on "Properties" and make sure "File & Printer Sharing for
    Microsoft Networks" is enabled.

    The tech said this should be inheriting its settings from the network
    settings in Control Panel, but something may be inhibiting that from
    happening.
     
    bjterp00, Jan 1, 2008
    #19
  20. Is your version an OEM version? (No physical CD, just a copy of the CD
    in a partition on your hard drive...?)
     
    joseamirandavelez, Jan 2, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.