Files required to use Microsoft Update are no longer registered

Discussion in 'Windows Update' started by Kevin, Nov 10, 2005.

  1. Kevin

    Kevin Guest

    Installed a new hard drive, loaded 2000 pro and small business office xp. Did
    service pack 4, then went ot update to IE6 and I get this reponse: Files
    required to use Microsoft Update are no longer registered. I do the register
    function it offers, it runs but does not fix the problem??
     
    Kevin, Nov 10, 2005
    #1
    1. Advertisements

  2. Some have reported that simply re-registering the MSXML3.DLL seems to fix the
    problem.
    1. Click Start.
    2. Choose Run.
    3. In the Run box, type: regsvr32 MSXML3.DLL
    Press okay

    If that hasn't helped you may need to re-registered some more files:

    1. Click Start.
    2. Choose Run.
    3. In the Run box, type (pressing okay after each one) :-

    net stop wuauserv

    Repeat for the following:
    regsvr32 wuapi.dll
    regsvr32 wups.dll
    regsvr32 wuaueng.dll
    regsvr32 wuaueng1.dll
    regsvr32 wucltui.dll
    regsvr32 wuweb.dll
    regsvr32 MSXML3.dll
    regsvr32 qmgr.dll
    regsvr32 qmgrprxy.dll
    regsvr32 jscript.dll

    net start wuauserv
     
    TaurArian [MVP], Nov 11, 2005
    #2
    1. Advertisements

  3. Kevin

    Kevin Guest

    Problem solved

    Thanx

     
    Kevin, Jan 9, 2006
    #3
  4. Kevin

    Tom Guest

    OK, now try to install any software, anything, and report back please.
    thnx
     
    Tom, Jan 9, 2006
    #4
  5. Kevin

    Frank Guest

    I had the same problems when I tried to use update -I kept going around in a
    loop of reregistering & seeking updates & eery time it came back "Files
    required to use Widows update are no longer registered or installed on your
    computer. To continue ---- etc etc"

    I found that a recommended action by somebodywho had previously answered a
    posted question work well for me. This was to click Start & then Run & enter
    the following :- "regsvr32 msxml3.dll"

    This cleared the problem & then Windows Update recommended high priority
    update of a number of ".netframe service packs" - I think version 1 followed
    by version 1.1. Just keep using Windows Update until it tells you no more
    available.

    Hope this works
     
    Frank, Feb 10, 2006
    #5
  6. Kevin

    Applegatej Guest

    I was able to get two of the files to register (perhaps they already were:
    wuweb.dll & MSXML3.dll) but this did fix the problem, much thanks!
     
    Applegatej, Sep 14, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.