Fixed! Remote Desktop Connection (RDC) SLOW/NO Connection Issue

Discussion in 'Windows Vista Networking' started by p0wertech, Jul 21, 2007.

  1. p0wertech

    p0wertech Guest

    http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-slow-problem-solved.asp

    In the above-mentioned article, Tom Keating describes how he has found the
    issue in Windows Vista which causes Remote Desktop Connection (RDC) to either
    fail to connect, or operate extremely slow.

    In my experiences, I was trying to connect to Windows 2003 Server and
    Windows XP based systems from my Windows Vista (Home Premium) operating
    system using RDC. Each time I would try, the connection would stop
    completely after opening the window and drawing a small portion of my remote
    system's desktop.

    After searching the internet for over an hour, I found Mr. Keating's article
    and executed the following instructions:

    1) Open Command Prompt (START - PROGRAMS - ACCESSORIES - COMMAND PROMPT) as
    an Administrator by right-clicking on Command Prompt.

    2) Type: netsh interface tcp set global autotuninglevel=disabled

    This command disables TCP Auto Tuning which is the cause of this particular
    problem. To re-enable it, execute the following:

    1) Open Command Prompt (START - PROGRAMS - ACCESSORIES - COMMAND PROMPT) as
    an Administrator by right-clicking on Command Prompt.

    2) Type: netsh interface tcp set global autotuninglevel=normal

    If you're technically savvy, there's much more to this issue (fine tuning
    the problem, etc), so I recommend reading this article in Mr. Keating's blog.
    But for the layman, this quick fix will solve the problem of not being able
    to connect to <Vista Operating Systems.

    And to Microsoft - recognize this problem and PUT A SOLUTION IN THE
    KNOWLEDGEBASE!

    Enjoy and good luck!
     
    p0wertech, Jul 21, 2007
    #1
    1. Advertisements

  2. p0wertech

    Kerry Brown Guest

    Kerry Brown, Jul 21, 2007
    #2
    1. Advertisements

  3. p0wertech

    duanyang Guest

    when i try to disable the autotuninglevel, it said:
    set global command failed on IPv4 The requested operation requires
    elevation.

    i am running as administator.

    anyone knows how to solve this problem? i read microsoft's article. i
    am using Cisco 800 series router (supplied by my cable provider). my RDP
    session has this problem: when i RDP to my office pc from home,
    everything is fine; however, when my remote RDP is on (from home) and i
    come back to office and log into my pc, i get the problem you guys
    mentioned. The pc only shows small portion of screen. It takes 10
    minutes to return the normal state.

    I use Vista Ultimate. 32bits Dell PC.

    thanks,
    Dan
     
    duanyang, Mar 24, 2008
    #3
  4. Logon administrator is not good enough. You need to run elevation command
    prompt. This link may help.

    netsh commandSet command failed requested operation requires elevation.
    Netsh is a command-line scripting utility that allows you to, either locally
    or remotely, ...
    www.chicagotech.net/netsh.htm


    --
    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on
    http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on
    http://www.HowToNetworking.com
     
    Robert L. \(MS-MVP\), Mar 24, 2008
    #4
  5. p0wertech

    esk Guest

    Hi,

    I am similar slowness with RDP. Unfortunately even after implementing
    below changes, it is still very slow.

    I am trying to connect from home m/c(vista) to windows terminal server
    work m/c (windows xp).

    Any other ideas?

    Thanks
     
    esk, Mar 24, 2008
    #5
  6. p0wertech

    dww Guest

    are you issueing this command on the machine you are using to connec
    too or the one you want to connect too
    thank
     
    dww, Oct 17, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.