Flash Player and IE7 (v7.0.6000.16575) in Vista Ultimate

Discussion in 'Internet Explorer' started by Brian Atherton, Jan 12, 2008.

  1. I keep all of my critical software fully up to date.
    Up until a few days before Christmas, Flash Player was working normally.
    After the festivities, I found that sites were reporting Flash Player Not
    Installed.
    Since then I have tried every suggestion from the Adobe Site and from other
    sites that I can find, including a complete IE7 Reset but to no avail.
    Flash Player apparently downloads OK; It appears to install OK and appears
    in the IE7 add-ons as well as in Control Panel. But it does not run.
    I have tried to post a question on the Adobe forum site but clicking on "New
    Topic" automatically sets up the maximum number of Explorer tabs and then, of
    course, stops.
    Can anybody on this site help please?
     
    Brian Atherton, Jan 12, 2008
    #1
    1. Advertisements

  2. PA Bear [MS MVP], Jan 12, 2008
    #2
    1. Advertisements

  3. Well many thanks for that very thorough and prompt response but,
    unfortunately, it has not resolved the issue. (I followed the instructions to
    the letter).

    Should I have disabled virus checking (I use Windows Live OneCare) and
    exited Live Messenger before re-installing? I closed all other applicaitons
    that I am aware of.

    On completion of both the uninstaller and the installer, I checked the
    COMMENTS and there was nothing untoward. Everything had been deleted as
    expected and, on re-install, all files were "new". None had been skipped.

    The only thing I'm not sure about is the comment in the instructions against
    "Adobe Flash Player 9 Stand-alone Installer" NB: Link to the Direct Download
    of the updated executable in the instructions. Vista does not give any option
    to do that, it just downloads install_flash_player_active_x.exe. However, I
    had both the uninstaller and the installer in the same place, in my downloads
    folder.

    The only other point is that, even after re-booting, there was no entry in
    the IE Add-ons for flash player under "Add-ons currently loaded in Internet
    Explorer". The only entry was under "Add-ons that have been used by Internet
    Explorer". That entry was "Shockwave Flash Object" and it was enabled. It
    then appeared under "Add-ons currently loaded in Internet Explorer" after
    trying to view a site using the ActiveX Control.

    I'm sorry to give you so much trouble but this problem has halted my website
    development for a week now.
     
    Brian Atherton, Jan 12, 2008
    #3
  4. You might try the following:

    Navigate to the main Flash folder on your hard drive, usually:
    C:\WINDOWS\system32\Macromed\Flash

    Inside that Flash folder you should see a small executable utility file with
    the following name:
    "FlashUtil9e.exe"

    Make sure you are connected to the internet and execute that file and allow
    it to update the flash player.

    Good luck,

    Donald Anadell
     
    Donald Anadell, Jan 12, 2008
    #4
  5. Brian Atherton

    Inger Guest

    HeY!
    Exactly the same have happened to me. i can`t download flash, IE7 or
    messenger live. it's seems ok, but nothing happens!! irritating!!
     
    Inger, Jan 12, 2008
    #5
  6. Try uninstalling / reinstalling Flash Player. Use the uninstaller at
    http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_14157
    Flash player download:
    http://www.adobe.com/products/flashplayer/
    If there are still problems see
    http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=fb1634cb

    Download SubInACL from Microsoft to fix permission issues that prevent the
    Flash Player Installation.
    See
    http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=fb1634cb
     
    Frank Saunders MS-MVP IE,OE/WM, Jan 12, 2008
    #6
  7. Thanks for that thought Don. I've tried it again but, unfortunately, it's one
    of the many I've tried before and it still has no effect.
     
    Brian Atherton, Jan 12, 2008
    #7
  8. Thanks for your response Frank. Unfortunately, your suggestions are all
    things that I have tried before - more than once!

    Is, perhaps, there anything that can stop Activex running, other than
    improper installation in IE. Does Vista have some other setting(s) buried
    elsewhere that could cause the problem?

    If not, it's beginning to look as 'though I'll have to re-install Vista
    although nothing else, other than ActiveX is malfunctioning.
     
    Brian Atherton, Jan 12, 2008
    #8
  9. When you tried it, did you right-click on FlashUtil9e.exe and choose "Run as
    Administrator"? Perhaps doing it that way would allow the Utility to make
    the necessary Registry changes required.

    Good luck,

    Donald Anadell
     
    Donald Anadell, Jan 13, 2008
    #9
  10. Again, thanks for the thought Don but that's not the answer. As I said in my
    original post, I have tried all of the proposed solutions on the Adobe
    website and others, very, very carefully. All to no avail. So far as I can
    tell, the registry entries are being made correctly (I am now something of an
    expert on "permissions" in Vista). Indeed, to all intents and purposes,
    v9.115 downloads and installs but it doesn't run. However, I cannot say for
    100% that it installs until it does run! I have three other computers here
    (at home), all running Vista Ultimate and all running flash player but an
    earlier v9, not v 9.115. I haven't tried 9.115 on any of those and I'm not
    going to until I solve the problem on this one! Many thanks for your help.
     
    Brian Atherton, Jan 13, 2008
    #10
  11. What anti-virus application and third-party firewall (if any) were installed
    prior to installing OneCare, Brian?

    What other security applications (other than Defender) are currently
    installed?
     
    PA Bear [MS MVP], Jan 13, 2008
    #11
  12. Donald Anadell, Jan 13, 2008
    #12
  13. Rob

    It's a long time ago mate but if I remember correctly, there are no previous
    versions on this computer. It had LiveOneCare installed immediately after
    delivery in mid-2007. It may have come with Norton installed but, if so, that
    didn't stay there for long!

    I have tried repeating the complete suggestions that you sent me, this time
    with LiveOneCare disabled but to no effect.

    However, the good news is that by reverting to the previous version of Flash
    Player, all is working again (That's v 9.47 as opposed to 9.115).

    I arrived at this position, having failed to find how to revert to an
    earlier version on the Adobe website, via a search engine enquiry that led me
    to http://www.tic-tac-dough.com/files/soundproblem.pdf. From that, I did a
    clean de-install via the cmd prompt as instructed and then tried to install
    v9.115. Again, that did not work (same symptons. An apperently OK install but
    would not run.) and, again, I had LiveOneCare disabled.

    I then, without bothering to re-boot (because by now I was convinced that
    there's something wrong with v9.115) I did a clean uninstall again via the
    cmd prompt then installed v9.47. Immediately, flash player worked. So that's
    it. I've never liked Adobe (apart from their Lightroom program for photo
    handing and editing). I don't like their cavalier attitude and I don't like
    their software but, of course, I can't do without it. Do you an email address
    for their CEO so that I can send a formal complaint?

    Very many thanks for your help and to everybody else who responded.

    Sincerely

    Brian.
     
    Brian Atherton, Jan 13, 2008
    #13

  14. Then why not revert to the earlier version on the problem machine?

    In any case, you should be running ProcMon to find out what is happening.
    Since you have two cases, one working and one not working, you have an
    opportunity for comparing two otherwise identical traces to find out what the
    differences are. Note that ProcMon makes such comparison easy by allowing
    you to save the traces in a reusable format and by allowing you to have multiple
    instances running concurrently.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jan 13, 2008
    #14
  15. PA Bear [MS MVP], Jan 13, 2008
    #15
  16. Rob, please see my last reply to PA Bear on 1/13/2008. I have reverted and
    all is now well. You need to see my whole reply to understand where I'm
    coming from.

    Sincerely

    Brian
     
    Brian Atherton, Jan 13, 2008
    #16
  17. And see my reply to your reply!

     
    PA Bear [MS MVP], Jan 13, 2008
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.