Font setting for webpages not having specified font

Discussion in 'Internet Explorer' started by tytung, Jun 4, 2006.

  1. tytung

    tytung Guest

    Abt setting fonts for webpages that do not have a specified text font.
    I tried to set it in Internet option->general->fonts, and change the
    language script, webpage fonts and plain text fonts. But when I reopens the
    dialog box, all settings remains unchanged. Why?
     
    tytung, Jun 4, 2006
    #1
    1. Advertisements

  2. tytung

    C A Upsdell Guest

    AFAIK with IE6 (and probably earlier versions) there are two different
    situations.

    First, if the page specifies no font at all, the user settings are
    honoured, and what you have done should have worked.

    Second, if the page uses CSS to specify fonts, but specifies the generic
    serif or san-serif font -- e.g. using 'font-family:serif;' -- the user
    settings are not honoured: IE makes it own decision as to what the
    default fonts are, and you have no direct control over its decision.

    I don't know about IE7, but since other browsers do allow the user to
    specify the generic CSS fonts, I would hope that IE7 will also do so.
     
    C A Upsdell, Jun 4, 2006
    #2
    1. Advertisements

  3. tytung

    tytung Guest

    Thanks for the respond Upsdell... but my prob is within the browser setting
    itself, not with the webpages.
    The problem is: I can select by highlighting another font type in the dialog
    box for font setting in Internet options, but then after i click OK, closes
    the dialog box, and then reopen it, it is the same old font being
    highlighted, not the one I just selected.
     
    tytung, Jun 5, 2006
    #3

  4. I think you were given a correct answer.
    Please post a sample link which will demonstrate your symptom.

    E.g. here is one which I found by searching for: sample plain text html

    http://www.i18nguy.com/unicode/unicode-example-intro.html

    View source makes me think that I should be able to see it with my
    preferred Webpage font (which happens to be Comic Sans MS).

    However, only by using the IE Developer Toolbar: Disable All CSS
    does that happen.


    FYI

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jun 7, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.