Force 60hz for BF2 on Toshiba Satellite x205 notebook

Discussion in 'Windows Vista Games' started by kenney001, Aug 25, 2007.

  1. kenney001

    kenney001 Guest

    I have a Toshiba Sattelite x205 s9359, with a Dedicated Geforce 8700m GT
    Graphics card, Intel core 2 duo T7300 @ 2.0Ghz, 2 Gig RAM, etc.

    MY problem lies with BF2 crashing after it changes resolution, and goes
    black on startup. I have been doing research and found that my problem
    lies with vista locking the refresh rate at 59hz, and BF2 requires 60 to
    run. I have gone through display settings, nvidia controll panel,
    changed the resolution to 800x600, talked to tech support at toshiba,
    downloaded the latest vista 32bit drivers, and still nothing.

    Is there any possible way to force the native refresh rate to 60 or
    more Hz?
     
    kenney001, Aug 25, 2007
    #1
    1. Advertisements

  2. kenney001

    Steve Guest

    try this kenney,

    go to your monitor setting page in the Graphic Settings.

    Click Monitor.

    Under Attributes tab, uncheck Use DDC information and select you
    required setting.

    regards
    Stev
     
    Steve, Aug 25, 2007
    #2
    1. Advertisements

  3. kenney001

    davey_griffo Guest

    I had the same problem a few years ago. I upgraded my OS, & Serious Sam &
    another game I can't remember, wouldn't work because they were trying to use
    refresh rates my monitor wasn't capable of displaying (the safety kicked in
    on the monitor, & it shut down the tube to prevent damage). I found in the
    drivers a part that let you overide the refresh rates, & set your own default
    for each resolution, even the wierd ones no-one ever uses.

    I can't find it in the current Vista driver, so maybe they took it out, or
    you have to unlock it somehow.

    It didn't work for me, I ended up reverting to an old version of Forceware
    that worked, but maybe it'll solve your problem, if you can find out how it's
    done.
     
    davey_griffo, Aug 27, 2007
    #3
  4. kenney001

    confireman Guest

    Hey Kenny,

    Have you solved your problem yet with B2? I'm in the same predicament. If
    you've figured out anything please pass it on to me. I would very much
    appreciate it.
    Thanks
     
    confireman, Oct 3, 2007
    #4
  5. kenney001

    Andy [YaYa] Guest

    10 second google search for bf2 notebook came up with this link.
    (http://forum.notebookreview.com/showthread.php?t=173496)

    "Solved my own problem by looking on Expert-Exchange. I got a clue about
    changing the video.con file. It seems that the games default to 60hz and my
    display is 62Hz. Go figure. It didn't like being switched to a refresh rate
    it couldn't handle.

    OMG that was simple, wonder why no one has mentioned it. Hope this saves
    someone else the hassle."

    So basically try looking through the video.con file (open it in notepad) for
    informationa bout the hz settings, and try setting it to 59hz or whatever
    messed up frequency your notebook uses.

    -A.
     
    Andy [YaYa], Oct 3, 2007
    #5
  6. kenney001

    confireman Guest

    Hey Andy,

    Yeah, I tried that too and it didn't seem to work. I not only changed the hz
    but also the resolution to see if that was the problem. NOPE! Dead End. I've
    dl'd the latest patched version of the game and the latest driver for my
    video card (GeForce GT 8700M) Still Nothing. I believe I need to somehow
    force my monitor to refresh at 60hz. Havn't found anything that will do that
    for my computer yet. I think it's a vista thing. Thanks though for your
    imput.

    Kenney, if you're still out there, let me know if you've found and success.

    T
     
    confireman, Oct 4, 2007
    #6
  7. There's a little software called rivatune or rivatuner... in that you can
    force the refresh rate (hz). Try it out if nothing else works, but be
    careful, the software does alot other than changing the hz, and you could do
    some serious wrong with it :)
     
    André Grønmo, Oct 5, 2007
    #7
  8. kenney001

    Nielsie Guest

    Heya,

    Had same problem with my notebook. only could choose 58 or 59hz and bf2
    wont start. also tried programs like force and such but no fix. now i
    downloaded a driver from laptopvideo2go. newest version and in this
    version you can add custom resolutions. Right click on screen than
    nvidea setings. (maby not exact since i got dutch version) than go to
    custom resolutions or someting onder monitor. than add your ip with 60hz
    and say test. than yes yes yes and presto. you can now choose 60hz in
    windows. after that you can probably play bf2. enjoy.
     
    Nielsie, Nov 15, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.